aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-11-25 11:43:05 +0800
committeredwin <edwin@FreeBSD.org>2005-11-25 11:43:05 +0800
commit5312fdb36e1e8ad82660b0e84ebdb9a61204ca10 (patch)
tree100fc992c4c9a492d83075d21343910dca65a6df /games
parent7b1fb9fa4981b67aab980d9c953ccf49956907ef (diff)
downloadfreebsd-ports-gnome-5312fdb36e1e8ad82660b0e84ebdb9a61204ca10.tar.gz
freebsd-ports-gnome-5312fdb36e1e8ad82660b0e84ebdb9a61204ca10.tar.zst
freebsd-ports-gnome-5312fdb36e1e8ad82660b0e84ebdb9a61204ca10.zip
New port: games/shootingstar
The Red-Shirted-Guy served happily in the police forces for many years, until he got kicked out because he used too much violence. He started drinking. After couple months his twin brother, the Green-Shirted-Guy, thought that Red's life wasn't very glamourous, so Green asked Red if he wanted to collaborate and start killing bad guys. They both thought it was a good idea and so they started their agency, The Shooting Stars. It was finally the time to take law to their own hands. WWW: http://www.2ndpoint.fi/ss PR: ports/89516 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/shootingstar/Makefile25
-rw-r--r--games/shootingstar/distinfo3
-rw-r--r--games/shootingstar/files/patch-src--engine--cTextureFont.cpp10
-rw-r--r--games/shootingstar/files/patch-src--game--cOptions.cpp11
-rw-r--r--games/shootingstar/pkg-descr10
-rw-r--r--games/shootingstar/pkg-plist119
7 files changed, 179 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 6c3b4ac1d382..6cd33e0db44b 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -519,6 +519,7 @@
SUBDIR += senso
SUBDIR += sex
SUBDIR += shaaft
+ SUBDIR += shootingstar
SUBDIR += six
SUBDIR += sl
SUBDIR += slashem-tty
diff --git a/games/shootingstar/Makefile b/games/shootingstar/Makefile
new file mode 100644
index 000000000000..56cfc277e458
--- /dev/null
+++ b/games/shootingstar/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: shootingstar
+# Date created: 20 Nov 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shootingstar
+PORTVERSION= 1.2.0
+CATEGORIES= games
+MASTER_SITES= http://www.2ndpoint.fi/projektit.xml/shootingstar/files/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= SDL/OpenGL top-down shooter
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GL= yes
+USE_SDL= sdl mixer image
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ SDL_CONFIG="${SDL_CONFIG}"
+
+.include <bsd.port.mk>
diff --git a/games/shootingstar/distinfo b/games/shootingstar/distinfo
new file mode 100644
index 000000000000..ec30146ce3cf
--- /dev/null
+++ b/games/shootingstar/distinfo
@@ -0,0 +1,3 @@
+MD5 (shootingstar-1.2.0.tar.gz) = 6cd6e11ec00be95a0a5b5e4cd3649ace
+SHA256 (shootingstar-1.2.0.tar.gz) = 21ed7e557a77a12c1bde5f968c55659667c1b14702f3b0ca5762d10374c6b1d9
+SIZE (shootingstar-1.2.0.tar.gz) = 7755911
diff --git a/games/shootingstar/files/patch-src--engine--cTextureFont.cpp b/games/shootingstar/files/patch-src--engine--cTextureFont.cpp
new file mode 100644
index 000000000000..8bb271989363
--- /dev/null
+++ b/games/shootingstar/files/patch-src--engine--cTextureFont.cpp
@@ -0,0 +1,10 @@
+--- src/engine/cTextureFont.cpp.orig Sun Jul 6 22:31:10 2003
++++ src/engine/cTextureFont.cpp Sun Nov 20 02:33:54 2005
+@@ -31,6 +31,7 @@
+ #include <stdio.h>
+ #include <GL/gl.h>
+ #include <GL/glu.h>
++#include <math.h>
+ #include "cTextureManager.hpp"
+ #include "Debug.hpp"
+ //------------------------------------------------------------------------------
diff --git a/games/shootingstar/files/patch-src--game--cOptions.cpp b/games/shootingstar/files/patch-src--game--cOptions.cpp
new file mode 100644
index 000000000000..085646cf8e84
--- /dev/null
+++ b/games/shootingstar/files/patch-src--game--cOptions.cpp
@@ -0,0 +1,11 @@
+--- src/game/cOptions.cpp.orig Mon Dec 22 08:09:06 2003
++++ src/game/cOptions.cpp Sun Nov 20 03:12:28 2005
+@@ -201,7 +201,7 @@
+ dbgError () << "Unable to read from options file\n";
+ throw runtime_error ("Unable to load options");
+ }
+- int (keys.keys[i]) = key; // IS THIS SAFE?
++ keys.keys[i] = (SDLKey)key; // IS THIS SAFE?
+
+ fin >> key;
+ keys.buttons[i] = key;
diff --git a/games/shootingstar/pkg-descr b/games/shootingstar/pkg-descr
new file mode 100644
index 000000000000..849f9abe7230
--- /dev/null
+++ b/games/shootingstar/pkg-descr
@@ -0,0 +1,10 @@
+The Red-Shirted-Guy served happily in the police forces for many
+years, until he got kicked out because he used too much violence.
+He started drinking. After couple months his twin brother, the
+Green-Shirted-Guy, thought that Red's life wasn't very glamourous,
+so Green asked Red if he wanted to collaborate and start killing
+bad guys. They both thought it was a good idea and so they started
+their agency, The Shooting Stars. It was finally the time to take
+law to their own hands.
+
+WWW: http://www.2ndpoint.fi/ss
diff --git a/games/shootingstar/pkg-plist b/games/shootingstar/pkg-plist
new file mode 100644
index 000000000000..3cce62049f7f
--- /dev/null
+++ b/games/shootingstar/pkg-plist
@@ -0,0 +1,119 @@
+bin/shootingstar
+%%DATADIR%%/animations/bloodpool
+%%DATADIR%%/animations/enemy_shoot
+%%DATADIR%%/animations/enemy_stand
+%%DATADIR%%/animations/enemy_walk
+%%DATADIR%%/animations/enemy_wshoot
+%%DATADIR%%/animations/gibs
+%%DATADIR%%/animations/medpack
+%%DATADIR%%/animations/player1_shoot
+%%DATADIR%%/animations/player1_stand
+%%DATADIR%%/animations/player1_walk
+%%DATADIR%%/animations/player1_wshoot
+%%DATADIR%%/animations/player2_shoot
+%%DATADIR%%/animations/player2_stand
+%%DATADIR%%/animations/player2_walk
+%%DATADIR%%/animations/player2_wshoot
+%%DATADIR%%/animations/rocket
+%%DATADIR%%/animations/weaponbox
+%%DATADIR%%/maps/city.map
+%%DATADIR%%/maps/city.obj
+%%DATADIR%%/maps/factory.map
+%%DATADIR%%/maps/factory.obj
+%%DATADIR%%/maps/highway.map
+%%DATADIR%%/maps/highway.obj
+%%DATADIR%%/maps/levels
+%%DATADIR%%/maps/office.map
+%%DATADIR%%/maps/office.obj
+%%DATADIR%%/maps/park.map
+%%DATADIR%%/maps/park.obj
+%%DATADIR%%/maps/test.map
+%%DATADIR%%/maps/test.obj
+%%DATADIR%%/maps/village.map
+%%DATADIR%%/maps/village.obj
+%%DATADIR%%/maps/warehouse.map
+%%DATADIR%%/maps/warehouse.obj
+%%DATADIR%%/shootingstar.cfg
+%%DATADIR%%/sounds/bazookareload.wav
+%%DATADIR%%/sounds/burning.wav
+%%DATADIR%%/sounds/dead.ogg
+%%DATADIR%%/sounds/death.wav
+%%DATADIR%%/sounds/empty.wav
+%%DATADIR%%/sounds/explosion.wav
+%%DATADIR%%/sounds/flamer.wav
+%%DATADIR%%/sounds/hit.wav
+%%DATADIR%%/sounds/hurt.wav
+%%DATADIR%%/sounds/machinegun.wav
+%%DATADIR%%/sounds/menu.ogg
+%%DATADIR%%/sounds/pickup.wav
+%%DATADIR%%/sounds/pistol.wav
+%%DATADIR%%/sounds/reload.wav
+%%DATADIR%%/sounds/rocket.wav
+%%DATADIR%%/sounds/shotgun.wav
+%%DATADIR%%/sounds/shotgunreload.wav
+%%DATADIR%%/textures/ammobox.png
+%%DATADIR%%/textures/archive.png
+%%DATADIR%%/textures/archive_open.png
+%%DATADIR%%/textures/barrel.png
+%%DATADIR%%/textures/barrel1.png
+%%DATADIR%%/textures/barrel2.png
+%%DATADIR%%/textures/bitmaps.png
+%%DATADIR%%/textures/blood1.png
+%%DATADIR%%/textures/blood2.png
+%%DATADIR%%/textures/blood3.png
+%%DATADIR%%/textures/blood4.png
+%%DATADIR%%/textures/blood_big1.png
+%%DATADIR%%/textures/blood_big2.png
+%%DATADIR%%/textures/body1.png
+%%DATADIR%%/textures/body2.png
+%%DATADIR%%/textures/concrete.png
+%%DATADIR%%/textures/enemy.png
+%%DATADIR%%/textures/floor1.png
+%%DATADIR%%/textures/floor2.png
+%%DATADIR%%/textures/font_11x20.png
+%%DATADIR%%/textures/gibs.png
+%%DATADIR%%/textures/grass.png
+%%DATADIR%%/textures/ground.png
+%%DATADIR%%/textures/hear.png
+%%DATADIR%%/textures/hud_p1.png
+%%DATADIR%%/textures/hud_p2.png
+%%DATADIR%%/textures/laatikko1.png
+%%DATADIR%%/textures/laatikko2.png
+%%DATADIR%%/textures/laatikko3.png
+%%DATADIR%%/textures/laatikko4.png
+%%DATADIR%%/textures/laatikko4_p.png
+%%DATADIR%%/textures/laatikko_p.png
+%%DATADIR%%/textures/logo_left.png
+%%DATADIR%%/textures/logo_right.png
+%%DATADIR%%/textures/mainmenu.png
+%%DATADIR%%/textures/medpak.png
+%%DATADIR%%/textures/menu_selector.png
+%%DATADIR%%/textures/pipe.png
+%%DATADIR%%/textures/player1.png
+%%DATADIR%%/textures/player2.png
+%%DATADIR%%/textures/poyta.png
+%%DATADIR%%/textures/poyta2.png
+%%DATADIR%%/textures/road.png
+%%DATADIR%%/textures/smoke.png
+%%DATADIR%%/textures/stonefloor.png
+%%DATADIR%%/textures/stones1.png
+%%DATADIR%%/textures/stones2.png
+%%DATADIR%%/textures/stones3.png
+%%DATADIR%%/textures/suer.png
+%%DATADIR%%/textures/toilet_clean.png
+%%DATADIR%%/textures/toilet_dirty.png
+%%DATADIR%%/textures/track.png
+%%DATADIR%%/textures/treetop1.png
+%%DATADIR%%/textures/tuli2.png
+%%DATADIR%%/textures/tuoli.png
+%%DATADIR%%/textures/wall_32.png
+%%DATADIR%%/textures/warning.png
+%%DATADIR%%/textures/wcfloor.png
+%%DATADIR%%/textures/weam.png
+%%DATADIR%%/textures/weaponlogos.png
+%%DATADIR%%/textures/woodfloor.png
+@dirrm %%DATADIR%%/animations
+@dirrm %%DATADIR%%/maps
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/textures
+@dirrm %%DATADIR%%