aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-09-11 00:24:05 +0800
committerjylefort <jylefort@FreeBSD.org>2005-09-11 00:24:05 +0800
commit6fe80d4876f5dbb681266547c24d52c8637803b1 (patch)
tree576425d750ffd3cd3b46883d9c2f4339904c913d /games
parentdac3a32c30df127dfce02a6becfb6f614452dae9 (diff)
downloadfreebsd-ports-gnome-6fe80d4876f5dbb681266547c24d52c8637803b1.tar.gz
freebsd-ports-gnome-6fe80d4876f5dbb681266547c24d52c8637803b1.tar.zst
freebsd-ports-gnome-6fe80d4876f5dbb681266547c24d52c8637803b1.zip
Add sdb.
Shotgun Debugger is a 2D, top-down action game. It is The Future, and your habit of computer network exploration has finally done you in. You are captured and taken to a strange underground complex populated by robot soldiers. Your task is to escape the facility--but the hordes of walking death machines aren't just gonna let you. Shotgun Debugger is pseudo-3D -- while gameplay is strictly two-dimensional, the world is rendered in three dimensions. Worlds are not tile-based, but polygon-based -- rooms and hallways can be made to any shape imaginable, allowing for some rather impressive architecture. WWW: http://sdb.gamecreation.org/ PR: ports/85857 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/sdb/Makefile61
-rw-r--r--games/sdb/distinfo2
-rw-r--r--games/sdb/files/patch-src_sdb.h11
-rw-r--r--games/sdb/pkg-descr15
5 files changed, 90 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index e7226fe239b8..3bbea958b9ff 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -464,6 +464,7 @@
SUBDIR += scorched3d
SUBDIR += scummvm
SUBDIR += scummvm-tools
+ SUBDIR += sdb
SUBDIR += sdlroids
SUBDIR += seabattle
SUBDIR += seahaven
diff --git a/games/sdb/Makefile b/games/sdb/Makefile
new file mode 100644
index 000000000000..9d1e9f51762a
--- /dev/null
+++ b/games/sdb/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: sdb
+# Date created: 08 Sep 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdb
+PORTVERSION= 1.0.2
+CATEGORIES= games
+MASTER_SITES= http://gcsociety.sp.cs.cmu.edu/~frenzy/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Futuristic overhead shooter
+
+USE_X_PREFIX= yes
+USE_SDL= mixer image sdl
+USE_GL= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GCC= 3.4+
+
+BUILD_WRKSRC= ${WRKSRC}/src
+
+CPPFLAGS= `${SDL_CONFIG} --cflags` -I${X11BASE}/include
+LDFLAGS= `${SDL_CONFIG} --libs` -L${X11BASE}/lib -lSDL_image -lSDL_mixer -lGL -lGLU
+MAKE_ARGS= CPP="${CXX}" CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" LIBS="${LDFLAGS}"
+
+PLIST_FILES= bin/sdb
+PLIST_DIRS= %%DATADIR%%
+PORTDOCS= README
+
+PLIST= ${WRKDIR}/pkg-plist
+DATADIRS= levels models snd sprites
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<SDL/|<|' ${WRKSRC}/src/sdb.h
+ @${REINPLACE_CMD} -Ee 's,(levels|models|snd|sprites)/,${DATADIR}/&,g' \
+ ${WRKSRC}/src/sdb.h ${WRKSRC}/src/game.cpp
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @cd ${WRKSRC} && \
+ ${FIND} ${DATADIRS} ! -type d | ${SORT} \
+ | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
+ ${FIND} ${DATADIRS} -type d ! -empty | ${SORT} -r \
+ | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/sdb ${PREFIX}/bin
+ cd ${WRKSRC} && \
+ ${FIND} ${DATADIRS} -type d ! -empty -exec \
+ ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} ${DATADIRS} ! -type d -exec \
+ ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/sdb/distinfo b/games/sdb/distinfo
new file mode 100644
index 000000000000..d9fa704cd3b3
--- /dev/null
+++ b/games/sdb/distinfo
@@ -0,0 +1,2 @@
+MD5 (sdb-1.0.2.tar.gz) = efad97ca4f5b24f7603339743df4a6d2
+SIZE (sdb-1.0.2.tar.gz) = 10342311
diff --git a/games/sdb/files/patch-src_sdb.h b/games/sdb/files/patch-src_sdb.h
new file mode 100644
index 000000000000..eb9ff3507ba5
--- /dev/null
+++ b/games/sdb/files/patch-src_sdb.h
@@ -0,0 +1,11 @@
+--- src/sdb.h.orig Sat Sep 10 18:02:32 2005
++++ src/sdb.h Sat Sep 10 18:05:50 2005
+@@ -82,7 +82,7 @@
+ #define PLAYER_DATA_FILE "player.dat"
+
+ #define NEXT_TOK nextToken(line, start, end)
+-#define S2F(x) strtof(x.c_str(), NULL)
++#define S2F(x) ((float) strtod(x.c_str(), NULL))
+ #define S2I(x) strtol(x.c_str(), NULL, 10)
+
+ #define X 0
diff --git a/games/sdb/pkg-descr b/games/sdb/pkg-descr
new file mode 100644
index 000000000000..3719837c68e7
--- /dev/null
+++ b/games/sdb/pkg-descr
@@ -0,0 +1,15 @@
+Shotgun Debugger is a 2D, top-down action game. It is The Future, and your
+habit of computer network exploration has finally done you in. You are
+captured and taken to a strange underground complex populated by robot
+soldiers. Your task is to escape the facility--but the hordes of walking
+death machines aren't just gonna let you.
+
+Shotgun Debugger is pseudo-3D -- while gameplay is strictly two-dimensional,
+the world is rendered in three dimensions. Worlds are not tile-based, but
+polygon-based -- rooms and hallways can be made to any shape imaginable,
+allowing for some rather impressive architecture.
+
+WWW: http://sdb.gamecreation.org/
+
+- Dmitry Marakasov
+amdmi3@mail.ru