aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-11-23 09:37:50 +0800
committerjylefort <jylefort@FreeBSD.org>2005-11-23 09:37:50 +0800
commit9435186dc334dca531d047fc610e0cb96da6c285 (patch)
tree02e9a8fd4a09a128008863d1909562b771786b5d /games
parent8810ef94057429eeb6e53df13b1bfb571efd2c99 (diff)
downloadfreebsd-ports-gnome-9435186dc334dca531d047fc610e0cb96da6c285.tar.gz
freebsd-ports-gnome-9435186dc334dca531d047fc610e0cb96da6c285.tar.zst
freebsd-ports-gnome-9435186dc334dca531d047fc610e0cb96da6c285.zip
Add linux-alienarena.
AA2K6 is the latest in a series of standalone games based on a classic Sci-Fi theme with a modern, updated visual experience. With 25 levels, five modes of play, mutators, built-in bots, 9 characters, 8 weapons (3 with alt-fire modes), the game has an endless supply of replayability. Billed as the sequel to 2004's CodeRED: Alien Arena, AA2K6 is much more than that. With the trials and tribulations of software development, endless hours of playing, gathering feedback, COR Entertainment has been able to not only fine tune and perfect it's flagship game, but add completely new dimensions to it. WWW: http://red.planetarena.org/ PR: ports/88911 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-alienarena/Makefile113
-rw-r--r--games/linux-alienarena/distinfo9
-rw-r--r--games/linux-alienarena/files/AlienArena.in4
-rw-r--r--games/linux-alienarena/files/AlienArenaDedicated.in4
-rw-r--r--games/linux-alienarena/pkg-descr10
6 files changed, 141 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 8377b5da1513..dfac162bc898 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -324,6 +324,7 @@
SUBDIR += libshhcards
SUBDIR += lincity
SUBDIR += lincity-ng
+ SUBDIR += linux-alienarena
SUBDIR += linux-americasarmy
SUBDIR += linux-doom3-demo
SUBDIR += linux-enemyterritory
diff --git a/games/linux-alienarena/Makefile b/games/linux-alienarena/Makefile
new file mode 100644
index 000000000000..42e80e10043d
--- /dev/null
+++ b/games/linux-alienarena/Makefile
@@ -0,0 +1,113 @@
+# New ports collection makefile for: Alien Arena 2006
+# Date created: 2005-11-12
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alienarena
+PORTVERSION= 2006
+CATEGORIES= games linux
+MASTER_SITES= http://www.forsakenweb.com/gamepage/loaders/games/:full \
+ ftp://download1.gamershell.com/pub/pc/games/gamershell/demo/:full \
+ ftp://download2.gamershell.com/pub/pc/games/gamershell/demo/:full \
+ ftp://download4.gamershell.com/pub/pc/games/gamershell/demo/:full \
+ ftp://download6.gamershell.com/pub/pc/games/gamershell/demo/:full \
+ ftp://download7.gamershell.com/pub/pc/games/gamershell/demo/:full \
+ ftp://download9.gamershell.com/pub/pc/games/gamershell/demo/:full \
+ ftp://download11.gamershell.com/pub/pc/gamershell/demo/:full \
+ ftp://download12.gamershell.com/pub/pc/gamershell/demo/:full \
+ http://offload1.icculus.org/~ravage/alienarena2006/:patch
+PKGNAMEPREFIX= linux-
+DISTFILES= ${PORTNAME}-${PORTVERSION}-x86.run:full \
+ ${PORTNAME}-${PORTVERSION}-sdl-i386.tar.gz:patch \
+ ${PORTNAME}-${PORTVERSION}-sdl-x86_64.tar.gz:patch
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Alien Arena 2006 (Linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libGLU.so.1.3:${PORTSDIR}/graphics/linux_dri \
+ ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_X_PREFIX= yes
+USE_LINUX= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+RESTRICTED= "Redistribution is limited, see license"
+NO_PACKAGE= "Package will be 150MB, set FORCE_PACKAGE if you really want to build it"
+
+ALIENDIR= ${PREFIX}/lib/${PORTNAME}
+ALIENDIR_REL= ${ALIENDIR:S,^${PREFIX}/,,}
+LIBDIRS= arena botinfo data1
+
+SUB_FILES= AlienArena AlienArenaDedicated
+
+PLIST= ${WRKDIR}/pkg-plist
+PLIST_FILES= bin/AlienArena bin/AlienArenaDedicated \
+ ${ALIENDIR_REL}/crded ${ALIENDIR_REL}/crx \
+ share/pixmaps/alienarena.xpm
+PLIST_DIRS= ${ALIENDIR_REL}
+PORTDOCS= README.txt
+
+DESKTOP_ENTRIES="Alien Arena 2006" \
+ "Play Alien Arena 2006" \
+ "alienarena.xpm" \
+ "AlienArena" \
+ "Application;Game;" \
+ false
+
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} != xfree86-3
+.if defined(WITH_NVIDIA_GL)
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
+.endif
+.else
+RUN_DEPENDS+= ${LINUXBASE}/lib/libGL.so.1:${PORTSDIR}/graphics/linux_glx
+.endif
+
+.if ${ARCH} == "i386"
+ENGINE_ARCH= x86
+SDL_ARCH= i386
+.elif ${ARCH} == "amd64"
+ENGINE_ARCH= x86_64
+SDL_ARCH= x86_64
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @cd ${WRKSRC} && \
+ ${TAIL} -c +8778 ${_DISTDIR}/${PORTNAME}-${PORTVERSION}-x86.run | ${TAR} xfz -
+ @${TAR} xfj ${WRKSRC}/alienarena-2006-data.tar.bz2 -C ${WRKSRC}
+
+ @${CP} -R ${WRKSRC}/engine/${ENGINE_ARCH}/* ${WRKSRC}
+ @${TAR} xfz ${_DISTDIR}/${PORTNAME}-${PORTVERSION}-sdl-${SDL_ARCH}.tar.gz -C ${WRKSRC}
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @cd ${WRKSRC} && \
+ ${FIND} ${LIBDIRS} -type f | ${SORT} \
+ | ${SED} -e 's|^|${ALIENDIR_REL}/|' >> ${PLIST} && \
+ ${FIND} ${LIBDIRS} -type d | ${SORT} -r \
+ | ${SED} -e 's|^|@dirrm ${ALIENDIR_REL}/|' >> ${PLIST}
+
+do-install:
+ cd ${WRKSRC} && \
+ ${FIND} ${LIBDIRS} -type d -exec ${MKDIR} "${ALIENDIR}/{}" \; && \
+ ${FIND} ${LIBDIRS} -type f -exec ${INSTALL_DATA} "{}" "${ALIENDIR}/{}" \;
+
+ ${INSTALL_SCRIPT} ${WRKDIR}/AlienArena ${WRKDIR}/AlienArenaDedicated ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/crded ${WRKSRC}/crx ${ALIENDIR}
+
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/alienarena.xpm ${PREFIX}/share/pixmaps
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/linux-alienarena/distinfo b/games/linux-alienarena/distinfo
new file mode 100644
index 000000000000..d594df8ca8d5
--- /dev/null
+++ b/games/linux-alienarena/distinfo
@@ -0,0 +1,9 @@
+MD5 (alienarena-2006-x86.run) = 0467b8ec4b1cb77ef5299857b270d27d
+SHA256 (alienarena-2006-x86.run) = 6277c5ee53b6477401c96bdaf6b1e97cc33ffeb07a8b6c13e070bc99fb5174ea
+SIZE (alienarena-2006-x86.run) = 151752065
+MD5 (alienarena-2006-sdl-i386.tar.gz) = 8286490846cbd87ebac1b00ba8436db9
+SHA256 (alienarena-2006-sdl-i386.tar.gz) = b3632d730d19a49918f1c6dd1ea3a058138e7f3f9d5573c9908aecd1892e9d5d
+SIZE (alienarena-2006-sdl-i386.tar.gz) = 262900
+MD5 (alienarena-2006-sdl-x86_64.tar.gz) = 141cee773f89792b9b40c49ce0074d46
+SHA256 (alienarena-2006-sdl-x86_64.tar.gz) = 4008ac079683d7cc64d2e443794a56f3fe2b4f8dd6145dd6ddbf47bb633bf44f
+SIZE (alienarena-2006-sdl-x86_64.tar.gz) = 311216
diff --git a/games/linux-alienarena/files/AlienArena.in b/games/linux-alienarena/files/AlienArena.in
new file mode 100644
index 000000000000..ce011b6c1ad1
--- /dev/null
+++ b/games/linux-alienarena/files/AlienArena.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%PREFIX%%/lib/alienarena || exit 1
+exec ./crx +set game arena "$@"
diff --git a/games/linux-alienarena/files/AlienArenaDedicated.in b/games/linux-alienarena/files/AlienArenaDedicated.in
new file mode 100644
index 000000000000..09dc9f89966d
--- /dev/null
+++ b/games/linux-alienarena/files/AlienArenaDedicated.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd %%PREFIX%%/lib/alienarena || exit 1
+exec ./crded +set game arena +set port 27910 "$@"
diff --git a/games/linux-alienarena/pkg-descr b/games/linux-alienarena/pkg-descr
new file mode 100644
index 000000000000..a19014498bfe
--- /dev/null
+++ b/games/linux-alienarena/pkg-descr
@@ -0,0 +1,10 @@
+AA2K6 is the latest in a series of standalone games based on a classic Sci-Fi
+theme with a modern, updated visual experience. With 25 levels, five modes of
+play, mutators, built-in bots, 9 characters, 8 weapons (3 with alt-fire
+modes), the game has an endless supply of replayability. Billed as the sequel
+to 2004's CodeRED: Alien Arena, AA2K6 is much more than that. With the trials
+and tribulations of software development, endless hours of playing, gathering
+feedback, COR Entertainment has been able to not only fine tune and perfect
+it's flagship game, but add completely new dimensions to it.
+
+WWW: http://red.planetarena.org/