aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-12-15 21:35:52 +0800
committermva <mva@FreeBSD.org>2013-12-15 21:35:52 +0800
commit9d90be6b8729550b44b06f8bdedfcfb0f4cdaa9b (patch)
treecf9af08b5320c46a6d78b02e5f957e0fc71a5cbd /games
parent1eb5ec27068a2f265eff7ba91b9e77a7ef7c85ef (diff)
downloadfreebsd-ports-gnome-9d90be6b8729550b44b06f8bdedfcfb0f4cdaa9b.tar.gz
freebsd-ports-gnome-9d90be6b8729550b44b06f8bdedfcfb0f4cdaa9b.tar.zst
freebsd-ports-gnome-9d90be6b8729550b44b06f8bdedfcfb0f4cdaa9b.zip
- Fix the usage of 'python' to get rid of the implicit lang/python
dependency - Restrict the build to the supported Python versions Reported by: exp-run (PR 184591) Approved by: portmgr (blanket)
Diffstat (limited to 'games')
-rw-r--r--games/teeworlds/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/games/teeworlds/Makefile b/games/teeworlds/Makefile
index 157f04f79df7..8fdcce1da8cd 100644
--- a/games/teeworlds/Makefile
+++ b/games/teeworlds/Makefile
@@ -16,7 +16,7 @@ LICENSE= ZLIB
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
-USE_PYTHON_BUILD= yes
+USE_PYTHON_BUILD= 2
BAM_VERSION= 0.4.0
BAM_WRKSRC= ${WRKDIR}/bam-${BAM_VERSION}
@@ -52,6 +52,8 @@ DESKTOP_ENTRIES="Teeworlds" \
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|"python "|"${PYTHON_CMD} "|' \
+ ${WRKSRC}/bam.lua
@${REINPLACE_CMD} -e 's|-O.||; s|-lpthread|${PTHREAD_LIBS}|; s|^gcc|${CC} ${CFLAGS}|; s|-ldl||g' \
${BAM_WRKSRC}/make_unix.sh
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/other/sdl/sdl.lua