aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-11-19 22:04:39 +0800
committerbarner <barner@FreeBSD.org>2005-11-19 22:04:39 +0800
commita85304d357d07bb98bf0db1ef8d5bfc7d1d79607 (patch)
treef2d2dec064be619af8cb54728b7c4c7fb87e1909 /games
parent0af5933c1069f1525a91340fed58549e27fc4875 (diff)
downloadfreebsd-ports-gnome-a85304d357d07bb98bf0db1ef8d5bfc7d1d79607.tar.gz
freebsd-ports-gnome-a85304d357d07bb98bf0db1ef8d5bfc7d1d79607.tar.zst
freebsd-ports-gnome-a85304d357d07bb98bf0db1ef8d5bfc7d1d79607.zip
Really fix build on 6.0+: Use CFLAGS="-O -pipe" because -fno-strict-aliasing
(default since FreeBSD 6.0) produces non-working code for the `vcc' tool that is needed during the build (it dumps core). However, the optimizations that can be enabled with the WITH_OPTIMIZIED_CFLAGS work just fine. Reported by: pointyhat via kris
Diffstat (limited to 'games')
-rw-r--r--games/vavoom/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index a7778f940abb..f71db4f06cf8 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -47,6 +47,13 @@ SUB_LIST= "PREFIX=${PREFIX}" "PORTSDIR=${PORTSDIR}"
.include <bsd.port.pre.mk>
+# -fno-strict-aliasing (default on FreeBSD 6.0+) produces run-working
+# code for `vcc', so use a more conservative setting here
+.if (${OSVERSION} >= 600000)
+CFLAGS= -O -pipe
+CXXFLAGS= -O -pipe
+.endif
+
pre-everything::
@${ECHO_CMD} ""
.ifndef (WITH_OPENAL)