aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-12-19 05:32:03 +0800
committermakc <makc@FreeBSD.org>2010-12-19 05:32:03 +0800
commitbe05325da052581f4173293a2bfeb4351a1a6d44 (patch)
tree3fb92c5b800ed75e80879f38ddb61598b81d6ada /games
parent0ed6f0e3c835f438789de1fd21cec6fb7bd3246e (diff)
downloadfreebsd-ports-gnome-be05325da052581f4173293a2bfeb4351a1a6d44.tar.gz
freebsd-ports-gnome-be05325da052581f4173293a2bfeb4351a1a6d44.tar.zst
freebsd-ports-gnome-be05325da052581f4173293a2bfeb4351a1a6d44.zip
Add new port games/hexglass:
Tetris-like puzzle game based on a hexagonal grid. WWW: http://code.google.com/p/hexglass/
Diffstat (limited to 'games')
-rw-r--r--games/hexglass/Makefile38
-rw-r--r--games/hexglass/distinfo2
-rw-r--r--games/hexglass/pkg-descr8
3 files changed, 48 insertions, 0 deletions
diff --git a/games/hexglass/Makefile b/games/hexglass/Makefile
new file mode 100644
index 000000000000..6fb49239a4d8
--- /dev/null
+++ b/games/hexglass/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: hexglass
+# Date created: 2010-12-17
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hexglass
+PORTVERSION= 1.2.0
+CATEGORIES= games
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Tetris-like puzzle game based on a hexagonal grid
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui qmake_build moc_build rcc_build
+HAS_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.xpm
+
+DESKTOP_ENTRIES= "HexGlass" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.xpm" \
+ "${PORTNAME}" "Application;BlocksGame;Game;" false
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/resources/logo512x512.xpm \
+ ${PREFIX}/share/pixmaps/${PORTNAME}.xpm
+
+.include <bsd.port.mk>
diff --git a/games/hexglass/distinfo b/games/hexglass/distinfo
new file mode 100644
index 000000000000..7c7d28e0c0d9
--- /dev/null
+++ b/games/hexglass/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hexglass-1.2.0.tar.gz) = b280815bbe92b09ad5c272b40b37b89fa6c1431134ffdae39415a85a82208214
+SIZE (hexglass-1.2.0.tar.gz) = 146670
diff --git a/games/hexglass/pkg-descr b/games/hexglass/pkg-descr
new file mode 100644
index 000000000000..233b99f8a7e5
--- /dev/null
+++ b/games/hexglass/pkg-descr
@@ -0,0 +1,8 @@
+The HexGlass is a Tetris-like puzzle game. Ten different types of
+blocks continuously fall from above and you must arrange them to
+make horizontal rows of hexagonal bricks. Completing any row causes
+those hexagonal blocks to disappear and the rest above move downwards.
+The blocks above gradually fall faster and the game is over when
+the screen fills up and blocks can no longer fall from the top.
+
+WWW: http://code.google.com/p/hexglass/