aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2006-09-01 19:05:09 +0800
committeraz <az@FreeBSD.org>2006-09-01 19:05:09 +0800
commitd14ecb4997d6cd874be10c50226e5e3cb0980719 (patch)
treeb13bfa8a1b5ff77d7051dc9df28167a44890e28e /games
parent615fbd3f767ed00f0263fb5b40edd201e9ca3c41 (diff)
downloadfreebsd-ports-gnome-d14ecb4997d6cd874be10c50226e5e3cb0980719.tar.gz
freebsd-ports-gnome-d14ecb4997d6cd874be10c50226e5e3cb0980719.tar.zst
freebsd-ports-gnome-d14ecb4997d6cd874be10c50226e5e3cb0980719.zip
- Fix pkg-plist
Diffstat (limited to 'games')
-rw-r--r--games/lincity-ng/Makefile4
-rw-r--r--games/lincity-ng/files/patch-mk-jam-install.jam13
2 files changed, 12 insertions, 5 deletions
diff --git a/games/lincity-ng/Makefile b/games/lincity-ng/Makefile
index ca63cf1487ab..4a6920795920 100644
--- a/games/lincity-ng/Makefile
+++ b/games/lincity-ng/Makefile
@@ -8,7 +8,7 @@
PORTNAME= lincity-ng
PORTVERSION= 1.0.3
CATEGORIES= games
-MASTER_SITES= http://download2.berlios.de/lincity-ng/
+MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= az@FreeBSD.org
@@ -17,8 +17,6 @@ COMMENT= Improved rich city simulation game for X
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
LIB_DEPENDS= physfs-1.0.1:${PORTSDIR}/devel/physfs
-BROKEN= Incorrect pkg-plist
-
USE_BZIP2= yes
USE_GCC= 3.2+
USE_SDL= sdl mixer image ttf gfx
diff --git a/games/lincity-ng/files/patch-mk-jam-install.jam b/games/lincity-ng/files/patch-mk-jam-install.jam
index b175e548be28..24bcef8e0d72 100644
--- a/games/lincity-ng/files/patch-mk-jam-install.jam
+++ b/games/lincity-ng/files/patch-mk-jam-install.jam
@@ -1,5 +1,5 @@
---- mk/jam/install.jam.orig Mon Jun 20 05:08:10 2005
-+++ mk/jam/install.jam Wed Jun 29 15:45:25 2005
+--- mk/jam/install.jam.orig Sat Apr 15 04:53:26 2006
++++ mk/jam/install.jam Fri Sep 1 13:11:31 2006
@@ -11,7 +11,7 @@
# set some paths
@@ -9,3 +9,12 @@
appconfdir ?= [ ConcatDirs $(sysconfdir) $(PACKAGE_NAME) ] ;
plugindir ?= [ ConcatDirs $(libdir) $(PACKAGE_NAME) ] ;
applicationsdir ?= [ ConcatDirs $(datadir) applications ] ;
+@@ -111,7 +111,7 @@
+ rule DoInstall
+ {
+ local targets target i dir gdir ;
+- dir = [ ConcatDirs $(DESTDIR) $(2) ] ;
++ dir = [ ConcatDirs $(2) ] ;
+
+ gdir = $(dir:G=dir) ;
+ MkDir $(gdir) ;