aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-04-07 09:55:57 +0800
committerwill <will@FreeBSD.org>2001-04-07 09:55:57 +0800
commitd99b51ad3bbfdf6e25495704200c2990de05722c (patch)
tree56fc16d3f2c720255e0977f3a2c3300adbb5150a /games
parentce0af04642dc19d786a215be8f0db74f5a2e9491 (diff)
downloadfreebsd-ports-gnome-d99b51ad3bbfdf6e25495704200c2990de05722c.tar.gz
freebsd-ports-gnome-d99b51ad3bbfdf6e25495704200c2990de05722c.tar.zst
freebsd-ports-gnome-d99b51ad3bbfdf6e25495704200c2990de05722c.zip
Add xpenguins 1.2, a program where cute little penguins that walk along
the tops of your windows. (heh.) PR: 24607 Submitted by: Michael Lyngbøl <michael@lyngbol.dk>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/xpenguins/Makefile29
-rw-r--r--games/xpenguins/distinfo1
-rw-r--r--games/xpenguins/pkg-comment1
-rw-r--r--games/xpenguins/pkg-descr12
-rw-r--r--games/xpenguins/pkg-plist1
6 files changed, 45 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index b5f89b5a61c5..cd499ced7bc8 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -283,6 +283,7 @@
SUBDIR += xpacman
SUBDIR += xpanex
SUBDIR += xpat2
+ SUBDIR += xpenguins
SUBDIR += xphotohunter
SUBDIR += xpilot
SUBDIR += xpipeman
diff --git a/games/xpenguins/Makefile b/games/xpenguins/Makefile
new file mode 100644
index 000000000000..176d40026db0
--- /dev/null
+++ b/games/xpenguins/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xpenguins
+# Date created: 24 January 2001
+# Whom: ` lyngbol@candid.dk
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpenguins
+PORTVERSION= 1.2
+CATEGORIES= games
+MASTER_SITES= http://xpenguins.seul.org/
+
+MAINTAINER= lyngbol@candid.dk
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_GMAKE= yes
+
+MAN1= xpenguins.1
+
+pre-build:
+ ${PERL} -pi.orig -e "s@-L/usr/local/lib@@g; \
+ s@-I/usr/local/include@@g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xpenguins $(PREFIX)/bin
+ ${INSTALL_MAN} ${WRKSRC}/xpenguins.1 $(PREFIX)/man/man1
+
+.include <bsd.port.mk>
diff --git a/games/xpenguins/distinfo b/games/xpenguins/distinfo
new file mode 100644
index 000000000000..80a3d5f68281
--- /dev/null
+++ b/games/xpenguins/distinfo
@@ -0,0 +1 @@
+MD5 (xpenguins-1.2.tar.gz) = d87aabddc455d12d9ccffbe491fa3b5d
diff --git a/games/xpenguins/pkg-comment b/games/xpenguins/pkg-comment
new file mode 100644
index 000000000000..bd8a04eedeca
--- /dev/null
+++ b/games/xpenguins/pkg-comment
@@ -0,0 +1 @@
+Cute little penguins that walk along the tops of your windows
diff --git a/games/xpenguins/pkg-descr b/games/xpenguins/pkg-descr
new file mode 100644
index 000000000000..53bd25df4c2d
--- /dev/null
+++ b/games/xpenguins/pkg-descr
@@ -0,0 +1,12 @@
+XPenguins animates a friendly family of penguins in your
+root window. They drop in from the top of the screen, walk
+along the tops of your windows, up the side of your win-
+dows, up the side of the screen, and sometimes even levi-
+tate with their genetically-modified go-go-gadget 'copter
+ability. Be careful when you move windows as the little
+guys squash easily. If you send the program an interupt
+
+WWW: http://xpenguins.seul.org/
+
+- Michael Lyngbol
+lyngbol@candid.dk
diff --git a/games/xpenguins/pkg-plist b/games/xpenguins/pkg-plist
new file mode 100644
index 000000000000..8323c114387d
--- /dev/null
+++ b/games/xpenguins/pkg-plist
@@ -0,0 +1 @@
+bin/xpenguins