aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-06-16 17:20:07 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-06-16 17:20:07 +0800
commit09ea0d8f4ba211eeb2e403abcc36780a559e9147 (patch)
treeb25f842a52891de4048edbf5f5fab772a7e89156 /games
parent3bd31a09b1d8b4dce58f7f87c555fc0743ada255 (diff)
downloadfreebsd-ports-gnome-09ea0d8f4ba211eeb2e403abcc36780a559e9147.tar.gz
freebsd-ports-gnome-09ea0d8f4ba211eeb2e403abcc36780a559e9147.tar.zst
freebsd-ports-gnome-09ea0d8f4ba211eeb2e403abcc36780a559e9147.zip
Pentobi is a computer opponent for the board game Blokus.
* Supported game variants: Classic, Duo, Trigon, Junior, Nexos, GembloQ, Callisto * Strong Blokus engine with 9 different playing levels * Player rating by playing rated games against the computer * Game analysis function * Save and load games in Smart Game Format including comments and move variations * Source code is available under the GNU General Public License * System requirements: 1 GB RAM, 1 GHz CPU (4 GB RAM, 2.5 GHz dual-core or faster CPU recommended for playing level 9) WWW: https://pentobi.sourceforge.io/
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/pentobi/Makefile27
-rw-r--r--games/pentobi/distinfo3
-rw-r--r--games/pentobi/files/patch-src_libboardgame__sgf_MissingProperty.cpp24
-rw-r--r--games/pentobi/pkg-descr14
-rw-r--r--games/pentobi/pkg-plist87
6 files changed, 156 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 2708b8c2f396..198b6075ddc4 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -742,6 +742,7 @@
SUBDIR += pengpong
SUBDIR += penguin-command
SUBDIR += pengupop
+ SUBDIR += pentobi
SUBDIR += phalanx
SUBDIR += phlipple
SUBDIR += picmi
diff --git a/games/pentobi/Makefile b/games/pentobi/Makefile
new file mode 100644
index 000000000000..255223266456
--- /dev/null
+++ b/games/pentobi/Makefile
@@ -0,0 +1,27 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pentobi
+PORTVERSION= 13.1
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Computer opponent for the board game Blokus
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake desktop-file-utils shared-mime-info tar:xz
+USE_QT5= core gui widgets svg concurrent \
+ qmake_build buildtools_build linguisttools_build
+
+PORTDOCS= NEWS
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/games/pentobi/distinfo b/games/pentobi/distinfo
new file mode 100644
index 000000000000..580f84d7d85b
--- /dev/null
+++ b/games/pentobi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1497519656
+SHA256 (pentobi-13.1.tar.xz) = 3903935654f5a2e369a3fe8bf7f08bfe2700cf5be3c3392dad164d6ab8bf9734
+SIZE (pentobi-13.1.tar.xz) = 419672
diff --git a/games/pentobi/files/patch-src_libboardgame__sgf_MissingProperty.cpp b/games/pentobi/files/patch-src_libboardgame__sgf_MissingProperty.cpp
new file mode 100644
index 000000000000..2f70a2aa5986
--- /dev/null
+++ b/games/pentobi/files/patch-src_libboardgame__sgf_MissingProperty.cpp
@@ -0,0 +1,24 @@
+--- src/libboardgame_sgf/MissingProperty.cpp.orig 2017-06-06 11:23:03 UTC
++++ src/libboardgame_sgf/MissingProperty.cpp
+@@ -10,17 +10,19 @@
+
+ #include "MissingProperty.h"
+
++#include <string>
++
+ namespace libboardgame_sgf {
+
+ //-----------------------------------------------------------------------------
+
+ MissingProperty::MissingProperty(const string& message)
+- : InvalidTree("Missing SGF property: " + message)
++ : InvalidTree(string{"Missing SGF property: "} + message)
+ {
+ }
+
+ MissingProperty::MissingProperty(const string& id, const string& message)
+- : InvalidTree("Missing SGF property '" + id + ": " + message)
++ : InvalidTree(string{"Missing SGF property '"} + id + ": " + message)
+ {
+ }
+
diff --git a/games/pentobi/pkg-descr b/games/pentobi/pkg-descr
new file mode 100644
index 000000000000..8bdf8ef4cbf7
--- /dev/null
+++ b/games/pentobi/pkg-descr
@@ -0,0 +1,14 @@
+Pentobi is a computer opponent for the board game Blokus.
+
+* Supported game variants: Classic, Duo, Trigon, Junior, Nexos,
+ GembloQ, Callisto
+* Strong Blokus engine with 9 different playing levels
+* Player rating by playing rated games against the computer
+* Game analysis function
+* Save and load games in Smart Game Format including comments and
+ move variations
+* Source code is available under the GNU General Public License
+* System requirements: 1 GB RAM, 1 GHz CPU (4 GB RAM, 2.5 GHz
+ dual-core or faster CPU recommended for playing level 9)
+
+WWW: https://pentobi.sourceforge.io/
diff --git a/games/pentobi/pkg-plist b/games/pentobi/pkg-plist
new file mode 100644
index 000000000000..b6948d4547a4
--- /dev/null
+++ b/games/pentobi/pkg-plist
@@ -0,0 +1,87 @@
+bin/pentobi
+bin/pentobi-thumbnailer
+man/man6/pentobi-thumbnailer.6.gz
+man/man6/pentobi.6.gz
+share/applications/io.sourceforge.pentobi.desktop
+share/help/C/pentobi/analysis.jpg
+share/help/C/pentobi/become_stronger.html
+share/help/C/pentobi/board_callisto.png
+share/help/C/pentobi/board_classic.png
+share/help/C/pentobi/board_duo.png
+share/help/C/pentobi/board_gembloq.png
+share/help/C/pentobi/board_nexos.png
+share/help/C/pentobi/board_trigon.jpg
+share/help/C/pentobi/callisto_rules.html
+share/help/C/pentobi/classic_rules.html
+share/help/C/pentobi/duo_rules.html
+share/help/C/pentobi/gembloq_rules.html
+share/help/C/pentobi/index.html
+share/help/C/pentobi/junior_rules.html
+share/help/C/pentobi/license.html
+share/help/C/pentobi/nexos_rules.html
+share/help/C/pentobi/pieces.png
+share/help/C/pentobi/pieces_callisto.png
+share/help/C/pentobi/pieces_gembloq.jpg
+share/help/C/pentobi/pieces_junior.png
+share/help/C/pentobi/pieces_nexos.png
+share/help/C/pentobi/pieces_trigon.jpg
+share/help/C/pentobi/position_callisto.png
+share/help/C/pentobi/position_classic.png
+share/help/C/pentobi/position_duo.png
+share/help/C/pentobi/position_gembloq.png
+share/help/C/pentobi/position_nexos.png
+share/help/C/pentobi/position_trigon.jpg
+share/help/C/pentobi/rating.jpg
+share/help/C/pentobi/shortcuts.html
+share/help/C/pentobi/stylesheet.css
+share/help/C/pentobi/system.html
+share/help/C/pentobi/trigon_rules.html
+share/help/C/pentobi/user_interface.html
+share/help/C/pentobi/window_menu.html
+share/help/de/pentobi/become_stronger.html
+share/help/de/pentobi/callisto_rules.html
+share/help/de/pentobi/classic_rules.html
+share/help/de/pentobi/duo_rules.html
+share/help/de/pentobi/gembloq_rules.html
+share/help/de/pentobi/index.html
+share/help/de/pentobi/junior_rules.html
+share/help/de/pentobi/license.html
+share/help/de/pentobi/nexos_rules.html
+share/help/de/pentobi/shortcuts.html
+share/help/de/pentobi/system.html
+share/help/de/pentobi/trigon_rules.html
+share/help/de/pentobi/user_interface.html
+share/help/de/pentobi/window_menu.html
+share/icons/hicolor/16x16/apps/pentobi.png
+share/icons/hicolor/16x16/mimetypes/application-x-blokus-sgf.png
+share/icons/hicolor/32x32/apps/pentobi.png
+share/icons/hicolor/32x32/mimetypes/application-x-blokus-sgf.png
+share/icons/hicolor/48x48/apps/pentobi.png
+share/icons/hicolor/48x48/mimetypes/application-x-blokus-sgf.png
+share/icons/hicolor/64x64/apps/pentobi.png
+share/icons/hicolor/64x64/mimetypes/application-x-blokus-sgf.png
+share/icons/hicolor/scalable/apps/pentobi.svg
+share/icons/hicolor/scalable/mimetypes/application-x-blokus-sgf.svg
+share/metainfo/io.sourceforge.pentobi.appdata.xml
+share/mime/packages/pentobi-mime.xml
+%%DATADIR%%/books/book_callisto.blksgf
+%%DATADIR%%/books/book_callisto_2.blksgf
+%%DATADIR%%/books/book_callisto_3.blksgf
+%%DATADIR%%/books/book_classic.blksgf
+%%DATADIR%%/books/book_classic_2.blksgf
+%%DATADIR%%/books/book_classic_3.blksgf
+%%DATADIR%%/books/book_duo.blksgf
+%%DATADIR%%/books/book_gembloq.blksgf
+%%DATADIR%%/books/book_gembloq_2.blksgf
+%%DATADIR%%/books/book_gembloq_2_4.blksgf
+%%DATADIR%%/books/book_gembloq_3.blksgf
+%%DATADIR%%/books/book_junior.blksgf
+%%DATADIR%%/books/book_nexos.blksgf
+%%DATADIR%%/books/book_nexos_2.blksgf
+%%DATADIR%%/books/book_trigon.blksgf
+%%DATADIR%%/books/book_trigon_2.blksgf
+%%DATADIR%%/books/book_trigon_3.blksgf
+%%DATADIR%%/translations/libpentobi_gui_de.qm
+%%DATADIR%%/translations/pentobi.qm
+%%DATADIR%%/translations/pentobi_de.qm
+share/thumbnailers/pentobi.thumbnailer