aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-05-04 04:56:57 +0800
committerak <ak@FreeBSD.org>2012-05-04 04:56:57 +0800
commit0b91bfa57f6f5d7e517b00c3878fc8cc155c3c7c (patch)
tree5c18279a8e04112d09f9bf55085872d839113258 /games
parent571d645260c9d8f070275a42b32bb2f229acb56a (diff)
downloadfreebsd-ports-gnome-0b91bfa57f6f5d7e517b00c3878fc8cc155c3c7c.tar.gz
freebsd-ports-gnome-0b91bfa57f6f5d7e517b00c3878fc8cc155c3c7c.tar.zst
freebsd-ports-gnome-0b91bfa57f6f5d7e517b00c3878fc8cc155c3c7c.zip
The object of the game is to remove all of the blocks from the screen
before the time runs out. Two blocks are removed at a time, and must be of the same color. After completing a level, you will be rewarded with a bonus point for every tick left on the clock. For each level thereafter, the time to complete the the level will be shorter. PR: ports/166854 Submitted by: nemysis <nemysis@gmx.ch> Approved by: eadler (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/twind/Makefile47
-rw-r--r--games/twind/distinfo2
-rw-r--r--games/twind/pkg-descr7
4 files changed, 57 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 427fc2fb17b6..e1d113a7eee2 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -900,6 +900,7 @@
SUBDIR += tuxracer
SUBDIR += tuxracer_golf
SUBDIR += tuxtype
+ SUBDIR += twind
SUBDIR += twitch
SUBDIR += tycho
SUBDIR += typespeed
diff --git a/games/twind/Makefile b/games/twind/Makefile
new file mode 100644
index 000000000000..0946c541d4a4
--- /dev/null
+++ b/games/twind/Makefile
@@ -0,0 +1,47 @@
+# New Ports collection makefile for: twind
+# Date created: 2012-04-11
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= twind
+PORTVERSION= 1.1.0
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Match and remove all of the blocks before time runs out
+
+LICENSE= GPLv2
+
+USE_SDL= sdl image mixer
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/twind \
+ share/pixmaps/${PORTNAME}.png
+
+PORTDATA= *
+PORTDOCS= AUTHORS CREDITS ChangeLog NEWS README TODO
+
+do-build:
+ cd ${WRKSRC} && ${CC} -o ${PORTNAME} ${CFLAGS} \
+ -DDATA_PREFIX=\"${DATADIR}/\" -DAUDIO -DLINUX \
+ -lm `${SDL_CONFIG} --cflags --libs` -lSDL_mixer -lSDL_image twind.c
+do-install:
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+# Pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/graphics/twind.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
+# Data
+ ${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "graphics music sound" ${DATADIR})
+# Documentation
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/twind/distinfo b/games/twind/distinfo
new file mode 100644
index 000000000000..eb20b195f5d5
--- /dev/null
+++ b/games/twind/distinfo
@@ -0,0 +1,2 @@
+SHA256 (twind-1.1.0.tar.gz) = 392a09e92862cf8a89a9b8c6f5ed7255c15c7f058a89d889c32f59ed8da73382
+SIZE (twind-1.1.0.tar.gz) = 2837845
diff --git a/games/twind/pkg-descr b/games/twind/pkg-descr
new file mode 100644
index 000000000000..dd167e5d3c12
--- /dev/null
+++ b/games/twind/pkg-descr
@@ -0,0 +1,7 @@
+The object of the game is to remove all of the blocks from the screen
+before the time runs out. Two blocks are removed at a time,
+and must be of the same color. After completing a level,
+you will be rewarded with a bonus point for every tick left on the clock.
+For each level thereafter, the time to complete the the level will be shorter.
+
+WWW: http://twind.sourceforge.net/