aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-05-12 02:53:55 +0800
committeralepulver <alepulver@FreeBSD.org>2006-05-12 02:53:55 +0800
commit2fd8c5265cb52871d9f288ab471b520d683d58ad (patch)
tree1c753807f62f906ae771f7621aa8a9fdaeafa91d /games
parent50a4b01aab9d94cbd46f3bb49858b88e2576805e (diff)
downloadfreebsd-ports-gnome-2fd8c5265cb52871d9f288ab471b520d683d58ad.tar.gz
freebsd-ports-gnome-2fd8c5265cb52871d9f288ab471b520d683d58ad.tar.zst
freebsd-ports-gnome-2fd8c5265cb52871d9f288ab471b520d683d58ad.zip
The shrub mod is a server-side mod for Wolfenstein: Enemy Territory.
WWW: http://www.planetwolfenstein.com/shrub/ PR: ports/93545 Approved by: garga (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-enemyterritory-shrub/Makefile47
-rw-r--r--games/linux-enemyterritory-shrub/distinfo3
-rw-r--r--games/linux-enemyterritory-shrub/pkg-descr3
4 files changed, 54 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index a5051eeacfc6..20e93df99e95 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -363,6 +363,7 @@
SUBDIR += linux-enemyterritory-etpub
SUBDIR += linux-enemyterritory-fortress
SUBDIR += linux-enemyterritory-jaymod
+ SUBDIR += linux-enemyterritory-shrub
SUBDIR += linux-enemyterritory-tce
SUBDIR += linux-goodway
SUBDIR += linux-nwnclient
diff --git a/games/linux-enemyterritory-shrub/Makefile b/games/linux-enemyterritory-shrub/Makefile
new file mode 100644
index 000000000000..3ee535d83753
--- /dev/null
+++ b/games/linux-enemyterritory-shrub/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: shrub
+# Date created: 7 May 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= shrub
+PORTVERSION= 1.2
+CATEGORIES= games linux
+MASTER_SITES= http://www.etstats.com/shrubet/downloads/
+PKGNAMEPREFIX= linux-enemyterritory-
+DISTNAME= 1.2-test13-l
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Shrub - An Enemy Territory Modification
+
+RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_ZIP= yes
+USE_LINUX= yes
+NO_WRKSUBDIR= yes
+
+DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
+
+PLIST_FILES= bin/et-${PORTNAME} \
+ bin/etded-${PORTNAME} \
+ %%DATADIR%%/qagame.mp.i386.so
+PLIST_DIRS= %%DATADIR%%
+
+do-build:
+.for f in et etded
+ @(${ECHO} "#!/bin/sh"; \
+ ${ECHO} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} "$$@"') > \
+ ${WRKSRC}/${f}-${PORTNAME}
+.endfor
+
+do-install:
+.for f in et etded
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/qagame.mp.i386.so ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/linux-enemyterritory-shrub/distinfo b/games/linux-enemyterritory-shrub/distinfo
new file mode 100644
index 000000000000..7801a13c6bad
--- /dev/null
+++ b/games/linux-enemyterritory-shrub/distinfo
@@ -0,0 +1,3 @@
+MD5 (1.2-test13-l.zip) = b8aa344e128070d1b5174ee7e2b1d3d4
+SHA256 (1.2-test13-l.zip) = d90d0dbf364d2fffd85ca265d7189f5c9e03035961892309f6445f5fe9cb69fa
+SIZE (1.2-test13-l.zip) = 567743
diff --git a/games/linux-enemyterritory-shrub/pkg-descr b/games/linux-enemyterritory-shrub/pkg-descr
new file mode 100644
index 000000000000..1addee5d1f19
--- /dev/null
+++ b/games/linux-enemyterritory-shrub/pkg-descr
@@ -0,0 +1,3 @@
+The shrub mod is a server-side mod for Wolfenstein: Enemy Territory.
+
+WWW: http://www.planetwolfenstein.com/shrub/