aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-09-25 19:22:58 +0800
committerrafan <rafan@FreeBSD.org>2007-09-25 19:22:58 +0800
commit422a417880f72a6024d69cfb1785832c532f1dab (patch)
tree313127f36d12fd6f6237b9aa3ff547e4247691e2 /games
parentb81f77c2829ddeae7d201528e27f9e36827a7d67 (diff)
downloadfreebsd-ports-gnome-422a417880f72a6024d69cfb1785832c532f1dab.tar.gz
freebsd-ports-gnome-422a417880f72a6024d69cfb1785832c532f1dab.tar.zst
freebsd-ports-gnome-422a417880f72a6024d69cfb1785832c532f1dab.zip
- Remove -malign-double on non-i386 platform to fix build on amd64:
quantumminigolf.cpp:1: error: -malign-double makes no sense in the 64bit mode PR: ports/116614 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/quantumminigolf/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/quantumminigolf/Makefile b/games/quantumminigolf/Makefile
index 5352d792b71d..ea7e577630c3 100644
--- a/games/quantumminigolf/Makefile
+++ b/games/quantumminigolf/Makefile
@@ -28,7 +28,10 @@ OPTIONS= OCFLAGS "Use optimized compiler flags" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_OCFLAGS)
-CXXFLAGS+= -O3 -fomit-frame-pointer -finline-functions -malign-double -funroll-all-loops
+CXXFLAGS+= -O3 -fomit-frame-pointer -finline-functions -funroll-all-loops
+. if ${ARCH} == "i386"
+CXXFLAGS+= -malign-double
+. endif
.endif
post-patch: