aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-05-19 18:23:04 +0800
committerak <ak@FreeBSD.org>2012-05-19 18:23:04 +0800
commit4b6ce9b9e4c1e3e6bd5dc9a61f2b43c975118a66 (patch)
tree9160aceef70cebccaa07258b58a6d9bc77e94bea /games
parent461420572e5eacdd38df6dad8651f802421b9785 (diff)
downloadfreebsd-ports-gnome-4b6ce9b9e4c1e3e6bd5dc9a61f2b43c975118a66.tar.gz
freebsd-ports-gnome-4b6ce9b9e4c1e3e6bd5dc9a61f2b43c975118a66.tar.zst
freebsd-ports-gnome-4b6ce9b9e4c1e3e6bd5dc9a61f2b43c975118a66.zip
This is a puzzle from the old C64 Impossible Mission game.
The idea is to combine the 36 tiles in sets of 4, such that each set of 4 makes a solid block. Clicking on the tiles on the left toggles them. A tile can't be turned on if it overlaps with any existing on tiles. The lone rectangle on the right is the combination of all the on tiles. Clicking on that is an easy way to turn all tiles off. When 4 tiles combine to make a solid block, they vanish. The goal is to get rid of all the tiles. There is no score or timer. Just do it for the intellectual exercise. PR: ports/167354 Submitted by: nemysis <nemysis@gmx.ch> Approved by: eadler, itetcu (mentors, implicit)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/impossible_mission_puzzle/Makefile43
-rw-r--r--games/impossible_mission_puzzle/distinfo2
-rw-r--r--games/impossible_mission_puzzle/pkg-descr12
4 files changed, 58 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index e3f50e864511..84d962d9bead 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -384,6 +384,7 @@
SUBDIR += icebreaker
SUBDIR += ifm
SUBDIR += imaze
+ SUBDIR += impossible_mission_puzzle
SUBDIR += inform
SUBDIR += inform7
SUBDIR += instead
diff --git a/games/impossible_mission_puzzle/Makefile b/games/impossible_mission_puzzle/Makefile
new file mode 100644
index 000000000000..f3b35e415ae3
--- /dev/null
+++ b/games/impossible_mission_puzzle/Makefile
@@ -0,0 +1,43 @@
+# New Ports collection makefile for: impossible_mission_puzzle
+# Date created: 2012-04-27
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= impossible_mission_puzzle
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= http://www.linuxmotors.com/puzzle/downloads/
+DISTNAME= puzzle-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= This is a puzzle from the old C64 Impossible Mission game
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/puzzle-${PORTVERSION}
+
+USE_SDL= sdl
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/impossible_mission_puzzle
+
+PORTDOCS= README
+
+do-build:
+ @cd ${WRKSRC} && ${CC} -o ${PORTNAME} ${CFLAGS} \
+ `${SDL_CONFIG} --cflags --libs` puzzle.c
+
+do-install:
+# Executable
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Documentation
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/impossible_mission_puzzle/distinfo b/games/impossible_mission_puzzle/distinfo
new file mode 100644
index 000000000000..1675c989d928
--- /dev/null
+++ b/games/impossible_mission_puzzle/distinfo
@@ -0,0 +1,2 @@
+SHA256 (puzzle-1.0.1.tgz) = ea6bf4e2edc4c9ed1f5656355e5f25a9666f8060fd53849ee7822f29c6597578
+SIZE (puzzle-1.0.1.tgz) = 4414
diff --git a/games/impossible_mission_puzzle/pkg-descr b/games/impossible_mission_puzzle/pkg-descr
new file mode 100644
index 000000000000..d42eece9fba2
--- /dev/null
+++ b/games/impossible_mission_puzzle/pkg-descr
@@ -0,0 +1,12 @@
+This is a puzzle from the old C64 Impossible Mission game.
+The idea is to combine the 36 tiles in sets of 4, such that each set
+of 4 makes a solid block. Clicking on the tiles on the left toggles
+them. A tile can't be turned on if it overlaps with any existing on
+tiles. The lone rectangle on the right is the combination of all
+the on tiles. Clicking on that is an easy way to turn all tiles off.
+
+When 4 tiles combine to make a solid block, they vanish. The goal is
+to get rid of all the tiles. There is no score or timer. Just do it
+for the intellectual exercise.
+
+WWW: http://www.linuxmotors.com/puzzle