aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-07-04 21:30:38 +0800
committermat <mat@FreeBSD.org>2016-07-04 21:30:38 +0800
commit51d7329927644d8ee1a84c1e76addcbeb9b6f490 (patch)
tree9c499d3202d3f0e9049ad9d02da90997174e998d /games
parent59cb5d44f697cd4cc0ac5238c0da96ac8b1bb9e9 (diff)
downloadfreebsd-ports-gnome-51d7329927644d8ee1a84c1e76addcbeb9b6f490.tar.gz
freebsd-ports-gnome-51d7329927644d8ee1a84c1e76addcbeb9b6f490.tar.zst
freebsd-ports-gnome-51d7329927644d8ee1a84c1e76addcbeb9b6f490.zip
Fix runtime error.
PR: 210793 Submitted by: tkato432 yahoo com Sponsored by: Absolight
Diffstat (limited to 'games')
-rw-r--r--games/xshisen/Makefile14
-rw-r--r--games/xshisen/files/patch-body.C11
2 files changed, 18 insertions, 7 deletions
diff --git a/games/xshisen/Makefile b/games/xshisen/Makefile
index afdff6aaa606..c177e4f25ebd 100644
--- a/games/xshisen/Makefile
+++ b/games/xshisen/Makefile
@@ -10,19 +10,19 @@ MASTER_SITES= LOCAL/hrs
MAINTAINER= TsurutaniNaoki@gmail.com
COMMENT= Shisen-sho puzzle game for X11
-BROKEN= fails to start
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-07-04
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
USE_XORG= xpm
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sharedstatedir="${DATADIR}"
INSTALL_TARGET= install-prog
-.if !defined(WITHOUT_MOTIF)
-USES= motif
-CONFIGURE_ARGS+= --with-motif
-.endif
+OPTIONS_DEFINE= MOTIF
+OPTIONS_DEFAULT= MOTIF
+
+MOTIF_USES= motif
+MOTIF_CONFIGURE_WITH= motif
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/games/xshisen/files/patch-body.C b/games/xshisen/files/patch-body.C
new file mode 100644
index 000000000000..ece3a898017c
--- /dev/null
+++ b/games/xshisen/files/patch-body.C
@@ -0,0 +1,11 @@
+--- body.C.orig 2002-07-07 07:22:35 UTC
++++ body.C
+@@ -227,7 +227,7 @@ Body::refreshhint(void)
+ p = new Point[max_c][2];
+ t = new Point[xsize*ysize/PKIND];
+
+- if (hintNum == 0)
++ if (hintNum != 0)
+ delete[] hintArray;
+ for(int i=0; i<PKIND; i++) {
+ piepos[i]->GetPosArray(t, num);