aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-03-25 00:25:48 +0800
committermiwi <miwi@FreeBSD.org>2012-03-25 00:25:48 +0800
commit756fdcf435508cfd558a8b1d1b4bc711faf67e05 (patch)
tree292cd1a4e0ea6b566bdc0f20d04d6a2eed5159f7 /games
parenta8c67e8e536282d89a0e66506e118f92172096ed (diff)
downloadfreebsd-ports-gnome-756fdcf435508cfd558a8b1d1b4bc711faf67e05.tar.gz
freebsd-ports-gnome-756fdcf435508cfd558a8b1d1b4bc711faf67e05.tar.zst
freebsd-ports-gnome-756fdcf435508cfd558a8b1d1b4bc711faf67e05.zip
- Fix OPTIONS handling
PR: 166027 Submitted by: Ports Fury Feature safe: yes
Diffstat (limited to 'games')
-rw-r--r--games/awale/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/awale/Makefile b/games/awale/Makefile
index 7b157aa73a07..283d11d788f1 100644
--- a/games/awale/Makefile
+++ b/games/awale/Makefile
@@ -17,13 +17,12 @@ OPTIONS= GUI "Installs Tcl/Tk GUI" on
MAN6= ${PORTNAME}.6
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITHOUT_GUI)
PLIST_SUB+= GUI="@comment "
.else
USE_TK_WRAPPER= yes
-.include "${PORTSDIR}/Mk/bsd.tcl.mk"
MAN6+= x${PORTNAME}.6
PLIST_SUB+= GUI=""
.endif
@@ -38,14 +37,14 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.6 ${MANPREFIX}/man/man6
+ ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.6 ${MAN6PREFIX}/man/man6
@${MKDIR} ${DATADIR}
.for f in README *.bmp *.gif *.ico *.png
${INSTALL_DATA} ${WRKSRC}/src/${f} ${DATADIR}
.endfor
-.if !defined(WITHOUT_X11)
+.if !defined(WITHOUT_GUI)
${INSTALL_SCRIPT} ${WRKSRC}/src/x${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/x${PORTNAME}.6 ${MANPREFIX}/man/man6
+ ${INSTALL_MAN} ${WRKSRC}/man/x${PORTNAME}.6 ${MAN6PREFIX}/man/man6
${INSTALL_SCRIPT} ${WRKSRC}/src/xawale.tcl ${DATADIR}
.endif
.if !defined(NOPORTDOCS)
@@ -55,4 +54,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>