aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-07-29 06:02:10 +0800
committeralepulver <alepulver@FreeBSD.org>2006-07-29 06:02:10 +0800
commit7aedb2ca9d98147c316d57d61ba0d971692233b6 (patch)
treeadb7f7e8b03260270bc9ac9d955ab06c03b7a918 /games
parenta6ffb305db7ed61a398602fef8026e9309ae2218 (diff)
downloadfreebsd-ports-gnome-7aedb2ca9d98147c316d57d61ba0d971692233b6.tar.gz
freebsd-ports-gnome-7aedb2ca9d98147c316d57d61ba0d971692233b6.tar.zst
freebsd-ports-gnome-7aedb2ca9d98147c316d57d61ba0d971692233b6.zip
Quake II: The Reckoning (Xatrix) Mission Pack.
You are part of an elite commando foce that must infiltrate a hostile alien cite. Once inside, you must scour industrial landscapes, crawl through waterways and air ducts, navigate treacherous canyons teeming with vicious mutants, stow away on an alien spacecraft, and destroy the enemy's secret moon base. - 18 Arduous Levels to Conquer. - Added Weapons. - New Enemies. This port installs the game.so file, but you still need the original data. WWW: http://www.idsoftware.com/games/quake/quake2-reckoning/
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/quake2-xatrix/Makefile49
-rw-r--r--games/quake2-xatrix/distinfo3
-rw-r--r--games/quake2-xatrix/files/Makefile64
-rw-r--r--games/quake2-xatrix/files/pkg-message.in8
-rw-r--r--games/quake2-xatrix/pkg-descr15
6 files changed, 140 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 07e35401b0d2..a12aca543c8f 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -559,6 +559,7 @@
SUBDIR += quake2-relay
SUBDIR += quake2-rogue
SUBDIR += quake2-source
+ SUBDIR += quake2-xatrix
SUBDIR += quake2forge
SUBDIR += quake2lnx
SUBDIR += quake3
diff --git a/games/quake2-xatrix/Makefile b/games/quake2-xatrix/Makefile
new file mode 100644
index 000000000000..829919e31826
--- /dev/null
+++ b/games/quake2-xatrix/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: quake2-xatrix
+# Date created: 26 Jul 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= xatrix
+PORTVERSION= 3.20
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_IDSOFTWARE}
+MASTER_SITE_SUBDIR= quake2/source
+PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}src${PORTVERSION:S/.//}
+EXTRACT_SUFX= .shar.Z
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Quake II: The Reckoning (Xatrix) Mission Pack
+
+NO_WRKSUBDIR= yes
+
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
+
+PLIST_FILES= %%Q2DIR%%/${PORTNAME}/game.so
+PLIST_DIRS= %%Q2DIR%%/${PORTNAME}
+
+SUB_FILES= pkg-message
+
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @cd ${WRKDIR} && \
+ uncompress -c ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAIL} +441 | ${SH}
+
+post-extract:
+ @${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/__linux__/__unix__/' ${WRKSRC}/q_shared.[ch]
+
+do-install:
+ ${MKDIR} ${Q2DIR}/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/game.so ${Q2DIR}/${PORTNAME}
+
+.include <bsd.port.post.mk>
diff --git a/games/quake2-xatrix/distinfo b/games/quake2-xatrix/distinfo
new file mode 100644
index 000000000000..be67cdab55c4
--- /dev/null
+++ b/games/quake2-xatrix/distinfo
@@ -0,0 +1,3 @@
+MD5 (xatrixsrc320.shar.Z) = 41fc4ecc4f25c068e7d1f488bd4a1e1a
+SHA256 (xatrixsrc320.shar.Z) = 94bf596cd85d38ea294b99ccb0ebb5e4b9776cca335001b3803e2d8407395589
+SIZE (xatrixsrc320.shar.Z) = 455917
diff --git a/games/quake2-xatrix/files/Makefile b/games/quake2-xatrix/files/Makefile
new file mode 100644
index 000000000000..12e8c1362fbf
--- /dev/null
+++ b/games/quake2-xatrix/files/Makefile
@@ -0,0 +1,64 @@
+# $FreeBSD$
+
+SHLIB= game
+SHLIB_NAME= game.so
+
+SRCS= g_ai.c \
+ g_cmds.c \
+ g_chase.c \
+ g_combat.c \
+ g_func.c \
+ g_items.c \
+ g_main.c \
+ g_misc.c \
+ g_monster.c \
+ g_phys.c \
+ g_save.c \
+ g_spawn.c \
+ g_svcmds.c \
+ g_target.c \
+ g_trigger.c \
+ g_turret.c \
+ g_utils.c \
+ g_weapon.c \
+ m_actor.c \
+ m_berserk.c \
+ m_boss2.c \
+ m_boss3.c \
+ m_boss31.c \
+ m_boss32.c \
+ m_boss5.c \
+ m_brain.c \
+ m_chick.c \
+ m_fixbot.c \
+ m_flash.c \
+ m_flipper.c \
+ m_float.c \
+ m_flyer.c \
+ m_gekk.c \
+ m_gladb.c \
+ m_gladiator.c \
+ m_gunner.c \
+ m_hover.c \
+ m_infantry.c \
+ m_insane.c \
+ m_medic.c \
+ m_move.c \
+ m_mutant.c \
+ m_parasite.c \
+ m_soldier.c \
+ m_supertank.c \
+ m_tank.c \
+ p_client.c \
+ p_hud.c \
+ p_trail.c \
+ p_view.c \
+ p_weapon.c \
+ q_shared.c
+
+CFLAGS+= -Dstricmp=strcasecmp -ffast-math -funroll-loops \
+ -fomit-frame-pointer -fexpensive-optimizations
+
+LDFLAGS+= -L/lib -L/usr/lib -lm
+
+.include <bsd.lib.mk>
diff --git a/games/quake2-xatrix/files/pkg-message.in b/games/quake2-xatrix/files/pkg-message.in
new file mode 100644
index 000000000000..6f5c317c7f96
--- /dev/null
+++ b/games/quake2-xatrix/files/pkg-message.in
@@ -0,0 +1,8 @@
+==============================================================================
+
+To complete the installation of this port you need to copy the file
+"xatrix/pak0.pak" and the directory "xatrix/video" with its contents from the
+original Quake II: The Reckoning (Xatrix) Mission Pack distribution to
+"%%Q2DIR%%/xatrix".
+
+==============================================================================
diff --git a/games/quake2-xatrix/pkg-descr b/games/quake2-xatrix/pkg-descr
new file mode 100644
index 000000000000..5c3476843d75
--- /dev/null
+++ b/games/quake2-xatrix/pkg-descr
@@ -0,0 +1,15 @@
+Quake II: The Reckoning (Xatrix) Mission Pack.
+
+You are part of an elite commando foce that must infiltrate a hostile alien
+cite. Once inside, you must scour industrial landscapes, crawl through
+waterways and air ducts, navigate treacherous canyons teeming with vicious
+mutants, stow away on an alien spacecraft, and destroy the enemy's secret moon
+base.
+
+- 18 Arduous Levels to Conquer.
+- Added Weapons.
+- New Enemies.
+
+This port installs the game.so file, but you still need the original data.
+
+WWW: http://www.idsoftware.com/games/quake/quake2-reckoning/