aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-01-06 14:20:22 +0800
committerwill <will@FreeBSD.org>2002-01-06 14:20:22 +0800
commit7eb7e56282b3d26029261bb2d568d95ee0d63aa9 (patch)
treefad9de51cf97a70df5fe58cca638640e3ab5d923 /games
parent33365d87de0091e8c98f38b81447d07d6a67315a (diff)
downloadfreebsd-ports-gnome-7eb7e56282b3d26029261bb2d568d95ee0d63aa9.tar.gz
freebsd-ports-gnome-7eb7e56282b3d26029261bb2d568d95ee0d63aa9.tar.zst
freebsd-ports-gnome-7eb7e56282b3d26029261bb2d568d95ee0d63aa9.zip
First round of auto* cleanups:
- USE_AUTO* -> USE_AUTO*_VER=* where required - USE_AUTO* / *_DEPENDS=.*auto*:*/devel/auto* -> GNU_CONFIGURE where OK - Other minor changes to fix things These changes should be no-ops with the current bsd.port.mk, but will assist in preparing for the next generation of USE_AUTO*. Submitted by: bento 4-exp USE_AUTO* cleanups http://people.FreeBSD.org/~will/4-exp/ http://bento.FreeBSD.org/errorlogs/4-exp-latest/
Diffstat (limited to 'games')
-rw-r--r--games/fgfs-base/Makefile6
-rw-r--r--games/flightgear-data/Makefile6
-rw-r--r--games/flightgear/Makefile6
-rw-r--r--games/gracer/Makefile2
-rw-r--r--games/quakeforge/Makefile4
-rw-r--r--games/tuxtype/Makefile3
-rw-r--r--games/zangband/Makefile2
7 files changed, 20 insertions, 9 deletions
diff --git a/games/fgfs-base/Makefile b/games/fgfs-base/Makefile
index 4409885d99b2..a70555288268 100644
--- a/games/fgfs-base/Makefile
+++ b/games/fgfs-base/Makefile
@@ -39,11 +39,13 @@ pre-configure:
.else
PLIST= ${MASTERDIR}/pkg-plist.notools
ADDPATCHES= ${MASTERDIR}/patches.tools/disable-tools
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER=213
.endif
USE_NEWGCC= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -lGLU -lGL -lglut ${PTHREAD_LIBS}"
CONFIGURE_ARGS+=--bindir=${PREFIX}/FlightGear/bin
USE_GMAKE= yes
@@ -54,6 +56,8 @@ pre-patch:
done )
post-configure:
+ @find ${WRKSRC} -type f | xargs ${PERL} -pi -e \
+ "s@#include.*<malloc.h>@#include <stdlib.h>@g"
@(cd ${WRKSRC};touch Makefile.in */Makefile.in */*/Makefile.in \
*/*/*/Makefile.in; \
./config.status)
diff --git a/games/flightgear-data/Makefile b/games/flightgear-data/Makefile
index 4409885d99b2..a70555288268 100644
--- a/games/flightgear-data/Makefile
+++ b/games/flightgear-data/Makefile
@@ -39,11 +39,13 @@ pre-configure:
.else
PLIST= ${MASTERDIR}/pkg-plist.notools
ADDPATCHES= ${MASTERDIR}/patches.tools/disable-tools
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER=213
.endif
USE_NEWGCC= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -lGLU -lGL -lglut ${PTHREAD_LIBS}"
CONFIGURE_ARGS+=--bindir=${PREFIX}/FlightGear/bin
USE_GMAKE= yes
@@ -54,6 +56,8 @@ pre-patch:
done )
post-configure:
+ @find ${WRKSRC} -type f | xargs ${PERL} -pi -e \
+ "s@#include.*<malloc.h>@#include <stdlib.h>@g"
@(cd ${WRKSRC};touch Makefile.in */Makefile.in */*/Makefile.in \
*/*/*/Makefile.in; \
./config.status)
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 4409885d99b2..a70555288268 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -39,11 +39,13 @@ pre-configure:
.else
PLIST= ${MASTERDIR}/pkg-plist.notools
ADDPATCHES= ${MASTERDIR}/patches.tools/disable-tools
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER=213
.endif
USE_NEWGCC= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ LDFLAGS="${LDFLAGS} -L${X11BASE}/lib -lGLU -lGL -lglut ${PTHREAD_LIBS}"
CONFIGURE_ARGS+=--bindir=${PREFIX}/FlightGear/bin
USE_GMAKE= yes
@@ -54,6 +56,8 @@ pre-patch:
done )
post-configure:
+ @find ${WRKSRC} -type f | xargs ${PERL} -pi -e \
+ "s@#include.*<malloc.h>@#include <stdlib.h>@g"
@(cd ${WRKSRC};touch Makefile.in */Makefile.in */*/Makefile.in \
*/*/*/Makefile.in; \
./config.status)
diff --git a/games/gracer/Makefile b/games/gracer/Makefile
index 7f0412c0aa11..bec53b2b82d9 100644
--- a/games/gracer/Makefile
+++ b/games/gracer/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
tcl82.1:${PORTSDIR}/lang/tcl82
USE_MESA= YES
-USE_AUTOCONF= YES
+USE_AUTOCONF_VER=213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
-I${LOCALBASE}/include/tcl8.2 \
-I${X11BASE}/include" \
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 7aac1653cf42..74ac1deaa3e6 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -55,8 +55,8 @@ pre-configure:
.if !defined(WITH_GLX)
@${ECHO_MSG} "Define WITH_GLX to use GLX (otherwise it is explicitly disabled!)"
.endif
- @cd ${WRKSRC} ; aclocal
- @cd ${WRKSRC} ; autoheader213
+ @cd ${WRKSRC} ; ${ACLOCAL}
+ @cd ${WRKSRC} ; ${AUTOHEADER}
do-install:
@${CP} ${PKGDIR}/pkg-plist ${PLIST}
diff --git a/games/tuxtype/Makefile b/games/tuxtype/Makefile
index ede21f585603..12f96cdac131 100644
--- a/games/tuxtype/Makefile
+++ b/games/tuxtype/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
USE_X_PREFIX= yes
-USE_AUTOCONF= yes
-USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER=14
USE_GMAKE= yes
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index bed472e67e7a..faf5982021dd 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= makoto@pinpott.spnet.ne.jp
USE_XLIB= yes
USE_GMAKE= yes
-USE_AUTOMAKE= yes
+USE_AUTOMAKE_VER=14
CONFIGURE_ARGS= --datadir=${PREFIX}/lib \
--with-setgid=${SHAREGRP}