aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-12-30 08:09:32 +0800
committernemysis <nemysis@FreeBSD.org>2013-12-30 08:09:32 +0800
commit8a76ecafa8aa85685f66f56eba429e17b48b7bf0 (patch)
treeb8d1338f06382a09b7971305925f75a3566d2e49 /games
parent9ab71b6541f5d59bdfbdba3be2f1cf63826d5195 (diff)
downloadfreebsd-ports-gnome-8a76ecafa8aa85685f66f56eba429e17b48b7bf0.tar.gz
freebsd-ports-gnome-8a76ecafa8aa85685f66f56eba429e17b48b7bf0.tar.zst
freebsd-ports-gnome-8a76ecafa8aa85685f66f56eba429e17b48b7bf0.zip
- Change master sites
- Remove dependency for desktopfileutils - Add DOCS Option - Support STAGEDIR - Change Desktop entry file - Change pkg-plist, remove update-desktop-database Approved by: pawel / wg (mentors, implicit)
Diffstat (limited to 'games')
-rw-r--r--games/nuclearchess/Makefile21
-rw-r--r--games/nuclearchess/pkg-plist2
2 files changed, 8 insertions, 15 deletions
diff --git a/games/nuclearchess/Makefile b/games/nuclearchess/Makefile
index b3364b6f1593..4c8ed62cc457 100644
--- a/games/nuclearchess/Makefile
+++ b/games/nuclearchess/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 1.0.0
PORTREVISION= 8
CATEGORIES= games
MASTER_SITES= http://www.linux-games.com/nuclearchess/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
DIST_SUBDIR= ${PORTNAME}
@@ -18,27 +18,22 @@ COMMENT= Chess variant designed to be short and fun for all players
LICENSE= GPLv2
USE_SDL= sdl image
-USE_GNOME= desktopfileutils
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${DATADIR}
PORTDOCS= AUTHORS ChangeLog
-DESKTOP_ENTRIES="NuclearChess" "${COMMENT}" \
- "${PREFIX}/share/pixmaps/${PORTNAME}.png" \
- "${PORTNAME}" "Game;BoardGame;" false
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+DESKTOP_ENTRIES="NuclearChess" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;BoardGame;" ""
post-install:
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
- @-update-desktop-database
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/nuclearchess/pkg-plist b/games/nuclearchess/pkg-plist
index 5c82127a89c6..3f2fe4fe3027 100644
--- a/games/nuclearchess/pkg-plist
+++ b/games/nuclearchess/pkg-plist
@@ -36,5 +36,3 @@ bin/nuclearchess
share/pixmaps/nuclearchess.png
@dirrm %%DATADIR%%/gfx
@dirrm %%DATADIR%%
-@exec %%LOCALBASE%%/bin/update-desktop-database -q || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database -q || /usr/bin/true