aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-11-12 18:06:49 +0800
committermadpilot <madpilot@FreeBSD.org>2016-11-12 18:06:49 +0800
commita962dea9c6c3feb11b9bb909e42b0b46c3e4ced0 (patch)
treecb84ba4cd196e6b22a91479c94d370f6f7a8734d /games
parent38bfee785882295e10e69ae5a26aa90b2b997d2e (diff)
downloadfreebsd-ports-gnome-a962dea9c6c3feb11b9bb909e42b0b46c3e4ced0.tar.gz
freebsd-ports-gnome-a962dea9c6c3feb11b9bb909e42b0b46c3e4ced0.tar.zst
freebsd-ports-gnome-a962dea9c6c3feb11b9bb909e42b0b46c3e4ced0.zip
- Update to 20161110
- Convert to USES=localbase - Removed upstreamed patches PR: 214420 Submitted by: lightside@gmx.com (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/pioneer/Makefile19
-rw-r--r--games/pioneer/distinfo6
-rw-r--r--games/pioneer/files/patch-contrib_PicoDDS_PicoDDS.cpp10
-rw-r--r--games/pioneer/files/patch-src_GameConfig.h12
4 files changed, 11 insertions, 36 deletions
diff --git a/games/pioneer/Makefile b/games/pioneer/Makefile
index 4243112ff65d..1298fc055909 100644
--- a/games/pioneer/Makefile
+++ b/games/pioneer/Makefile
@@ -36,9 +36,9 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USE_GITHUB= yes
GH_ACCOUNT= pioneerspacesim
-GH_TAGNAME= 20161028
+GH_TAGNAME= 20161110
-USES= autoreconf gmake pkgconfig
+USES= autoreconf compiler:c++11-lib gmake localbase pkgconfig
USE_GL= gl
USE_SDL= image2 sdl2
@@ -72,21 +72,18 @@ PROFILER_CONFIGURE_ON= --enable-profiler
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000054
-USE_GCC= yes
-.else
-USES+= compiler:c++11-lang
-CPPFLAGS+= -I${LOCALBASE}/include
+.if ${COMPILER_TYPE} == gcc
+# Unhide std::to_string() for GCC (ports/193528)
+CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
post-patch: .SILENT
${REINPLACE_CMD} -e '/^OPTIMISE=/d' \
${WRKSRC}/configure.ac
- ${REINPLACE_CMD} -e 's/std:://g' \
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000054
+ ${REINPLACE_CMD} -e 's/std::acosh/acosh/g ; s/std::copysign/copysign/g' \
${WRKSRC}/src/Orbit.cpp
- ${REINPLACE_CMD} -e 's/std::to_string/to_string/g' \
- ${WRKSRC}/src/graphics/opengl/GenGasGiantColourMaterial.cpp \
- ${WRKSRC}/src/graphics/opengl/RendererGL.cpp
+.endif
post-patch-MODELCOMPILER-off: .SILENT
${REINPLACE_CMD} -e 's/pioneer modelcompiler/pioneer/' \
diff --git a/games/pioneer/distinfo b/games/pioneer/distinfo
index 76ddc19ba9e1..c4982b36404d 100644
--- a/games/pioneer/distinfo
+++ b/games/pioneer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477647657
-SHA256 (pioneerspacesim-pioneer-0.0.20161028-20161028_GH0.tar.gz) = d8ceefc7ec22ecdbaf2408a13c80d0368675feebff558457bef2ffc7258f4b77
-SIZE (pioneerspacesim-pioneer-0.0.20161028-20161028_GH0.tar.gz) = 194439211
+TIMESTAMP = 1478769845
+SHA256 (pioneerspacesim-pioneer-0.0.20161110-20161110_GH0.tar.gz) = 24d86095e2080fdbc6ae849dc543dcbdf214d09d34208697d915167c80775b50
+SIZE (pioneerspacesim-pioneer-0.0.20161110-20161110_GH0.tar.gz) = 194432857
diff --git a/games/pioneer/files/patch-contrib_PicoDDS_PicoDDS.cpp b/games/pioneer/files/patch-contrib_PicoDDS_PicoDDS.cpp
deleted file mode 100644
index ee88f5119f96..000000000000
--- a/games/pioneer/files/patch-contrib_PicoDDS_PicoDDS.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- contrib/PicoDDS/PicoDDS.cpp.orig 2015-06-07 21:44:10 UTC
-+++ contrib/PicoDDS/PicoDDS.cpp
-@@ -48,6 +48,7 @@
- */
-
- #include "PicoDDS.h"
-+#include <stdlib.h>
- #include <cstdio>
- #include <cstring>
- #include <cassert>
diff --git a/games/pioneer/files/patch-src_GameConfig.h b/games/pioneer/files/patch-src_GameConfig.h
deleted file mode 100644
index 168fb45a2eb1..000000000000
--- a/games/pioneer/files/patch-src_GameConfig.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/GameConfig.h.orig 2015-06-07 21:44:10 UTC
-+++ src/GameConfig.h
-@@ -8,7 +8,8 @@
-
- class GameConfig : public IniConfig {
- public:
-- GameConfig(const std::map<std::string,std::string> &override_ = std::map<std::string,std::string>());
-+ typedef std::map<std::string, std::string> map_string;
-+ GameConfig(const map_string &override_ = map_string());
-
- void Load();
- bool Save();