aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-08-14 13:51:07 +0800
committerjgh <jgh@FreeBSD.org>2012-08-14 13:51:07 +0800
commitb55b01bed9f819738236fe8d5769e63ee5282265 (patch)
treed4af73ae406ac2f6ce7052449446d65b1d1fcf02 /games
parent64bc48e3e947f427a072c68bb15782097cf1b9b9 (diff)
downloadfreebsd-ports-gnome-b55b01bed9f819738236fe8d5769e63ee5282265.tar.gz
freebsd-ports-gnome-b55b01bed9f819738236fe8d5769e63ee5282265.tar.zst
freebsd-ports-gnome-b55b01bed9f819738236fe8d5769e63ee5282265.zip
Connectagram is a word unscrambling game. The board consists
of several scrambled words that are joined together. You can choose the length of the words, the amount of words, and the pattern that the words are arranged in. The game provides a hint option for times when you are stuck, and features an online word lookup that fetches the definitions of each word from www.dict.org. Your current progress is automatically saved. Note that this game involves a large and varied word list, some of which may be considered inappropriate for children. You can edit the file containing the word list if you wish to remove words from your game. The location of this file varies by platform. WWW: http://gottcode.org/connectagram/ PR: ports/167849 Submitted by: nemysis@gmx.ch
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/connectagram/Makefile59
-rw-r--r--games/connectagram/distinfo2
-rw-r--r--games/connectagram/pkg-descr14
4 files changed, 76 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index b4318f08a440..c674b9bcb9eb 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -134,6 +134,7 @@
SUBDIR += colorcode
SUBDIR += columns
SUBDIR += concentration
+ SUBDIR += connectagram
SUBDIR += connectfive
SUBDIR += conquest
SUBDIR += construo
diff --git a/games/connectagram/Makefile b/games/connectagram/Makefile
new file mode 100644
index 000000000000..20d79a6c2ba7
--- /dev/null
+++ b/games/connectagram/Makefile
@@ -0,0 +1,59 @@
+# New Ports collection makefile for: connectagram
+# Date created: 23 April 2012
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= connectagram
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= http://gottcode.org/${PORTNAME}/
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Word unscrambling game
+
+LICENSE= GPLv3
+
+OPTIONS_DEFINE= DATA
+OPTIONS_DEFAULT= DATA
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build corelib gui iconengines imageformats network
+INSTALLS_ICONS= yes
+
+MAKE_JOBS_SAFE= yes
+
+PORTDATA= *
+PORTDOCS= ChangeLog INSTALL
+
+PLIST_FILES= bin/connectagram \
+ share/applications/connectagram.desktop \
+ share/icons/hicolor/48x48/apps/connectagram.png
+
+PLIST_DIRSTRY= share/icons/hicolor/48x48/apps \
+ share/icons/hicolor/48x48 \
+ share/icons/hicolor \
+ share/icons \
+ share/applications
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS}
+
+.include <bsd.port.options.mk>
+
+post-install:
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/connectagram/distinfo b/games/connectagram/distinfo
new file mode 100644
index 000000000000..c1dbe7b0bf23
--- /dev/null
+++ b/games/connectagram/distinfo
@@ -0,0 +1,2 @@
+SHA256 (connectagram-1.0.1-src.tar.bz2) = 6d3696b69f09eda26cdd2a42fe4d91de3effc4757c68f5109b19c1d4d6510e37
+SIZE (connectagram-1.0.1-src.tar.bz2) = 263808
diff --git a/games/connectagram/pkg-descr b/games/connectagram/pkg-descr
new file mode 100644
index 000000000000..52dd1382c848
--- /dev/null
+++ b/games/connectagram/pkg-descr
@@ -0,0 +1,14 @@
+Connectagram is a word unscrambling game. The board consists
+of several scrambled words that are joined together.
+You can choose the length of the words, the amount of words,
+and the pattern that the words are arranged in.
+The game provides a hint option for times when you are stuck,
+and features an online word lookup that fetches the definitions
+of each word from www.dict.org. Your current progress is automatically saved.
+
+Note that this game involves a large and varied word list,
+some of which may be considered inappropriate for children.
+You can edit the file containing the word list if you wish
+to remove words from your game. The location of this file varies by platform.
+
+WWW: http://gottcode.org/connectagram/