aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-10-13 12:00:00 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-10-13 12:00:00 +0800
commitd14841048bfeb678d3514b2592854675b94c50b2 (patch)
treed4bb5dadadf36cf30949e4a4cdd106850ca2be05 /games
parent47867b09b856196e56bb38abc6770419c738b529 (diff)
downloadfreebsd-ports-gnome-d14841048bfeb678d3514b2592854675b94c50b2.tar.gz
freebsd-ports-gnome-d14841048bfeb678d3514b2592854675b94c50b2.tar.zst
freebsd-ports-gnome-d14841048bfeb678d3514b2592854675b94c50b2.zip
- Unbreak by installing missing data files
- Remove unused depends - Remove /var/games stuff which is not used MFH: 2015Q4
Diffstat (limited to 'games')
-rw-r--r--games/super_methane_brothers/Makefile19
-rw-r--r--games/super_methane_brothers/pkg-req16
2 files changed, 8 insertions, 27 deletions
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
index bb29be2bb8f9..2fecb094d4d9 100644
--- a/games/super_methane_brothers/Makefile
+++ b/games/super_methane_brothers/Makefile
@@ -3,7 +3,7 @@
PORTNAME= super_methane_brothers
PORTVERSION= 1.5.1
-PORTREVISION= 4
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF/methane/Methane%20Stable/Methane%20V${PORTVERSION}
DISTNAME= methane-${PORTVERSION}
@@ -17,20 +17,20 @@ LIB_DEPENDS= libclan23Core.so:${PORTSDIR}/devel/clanlib
USES= execinfo gmake pkgconfig tar:tgz
USE_GCC= yes
-USE_GL= glu
MAKE_ENV= METHANE_FLAGS="${CPPFLAGS}" METHANE_LIBS="${LIBS}"
MAKE_JOBS_UNSAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lexecinfo
+DATADIR= ${PREFIX}/share/methane
+
PORTDOCS= *
+PORTDATA= *
PLIST_FILES= bin/methane
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e \
's|-2.2|-2.3|g ; \
@@ -40,14 +40,11 @@ post-patch:
s|gcc|$${CXX}|' ${WRKSRC}/Makefile
do-install:
- (cd ${WRKDIR}/${DISTNAME} && ${INSTALL_PROGRAM} methane ${STAGEDIR}${PREFIX}/bin)
- ${CHGRP} games ${STAGEDIR}${PREFIX}/bin/methane
- ${CHMOD} g+s ${STAGEDIR}${PREFIX}/bin/methane
-.if ${PORT_OPTIONS:MDOCS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/methane ${STAGEDIR}${PREFIX}/bin
+ cd ${WRKSRC}/resources && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKDIR}/${DISTNAME}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
-.endif
- @${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGREQ} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>
diff --git a/games/super_methane_brothers/pkg-req b/games/super_methane_brothers/pkg-req
deleted file mode 100644
index 639e2ac18456..000000000000
--- a/games/super_methane_brothers/pkg-req
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-SCOREFILE="/var/games/methane.scores"
-
-if [ "x$2" = "xPOST-INSTALL" ]; then
- mkdir -p /var/games
- touch $SCOREFILE
- chown root:games $SCOREFILE
- chmod 664 $SCOREFILE
-fi
-
-if [ "x$2" = "xPOST-DEINSTALL" ]; then
- if [ ! -s $SCOREFILE ]; then
- rm -f $SCOREFILE
- fi
-fi