aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-22 21:17:38 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-22 21:17:38 +0800
commitd93393cbfee266ac9f218632d0e2f0e64de8a8dc (patch)
treef7a9a3f705ff6a19879564f16dea8fcc43168f42 /games
parent93843cfe0eadb88915d5d83f2a0d584a36cf71c6 (diff)
downloadfreebsd-ports-gnome-d93393cbfee266ac9f218632d0e2f0e64de8a8dc.tar.gz
freebsd-ports-gnome-d93393cbfee266ac9f218632d0e2f0e64de8a8dc.tar.zst
freebsd-ports-gnome-d93393cbfee266ac9f218632d0e2f0e64de8a8dc.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket) Reported by: swills
Diffstat (limited to 'games')
-rw-r--r--games/0ad/Makefile5
-rw-r--r--games/ags/Makefile2
-rw-r--r--games/blobby/Makefile4
-rw-r--r--games/bloodfrontier/Makefile6
-rw-r--r--games/cataclysm-dda/Makefile4
-rw-r--r--games/corsix-th/Makefile2
-rw-r--r--games/divide-and-succeed/Makefile2
-rw-r--r--games/dunelegacy/Makefile2
-rw-r--r--games/el/Makefile3
-rw-r--r--games/emptyepsilon/Makefile2
-rw-r--r--games/fishsupper/Makefile2
-rw-r--r--games/hyperrogue/Makefile2
-rw-r--r--games/iortcw/Makefile6
-rw-r--r--games/lbreakout2/Makefile2
-rw-r--r--games/manaplus/Makefile2
-rw-r--r--games/openomf/Makefile2
-rw-r--r--games/openspades/Makefile5
-rw-r--r--games/openttd/Makefile2
-rw-r--r--games/openxcom/Makefile2
-rw-r--r--games/retroarch/Makefile2
-rw-r--r--games/stepmania-devel/Makefile2
-rw-r--r--games/traingame/Makefile2
-rw-r--r--games/trigger-rally/Makefile1
-rw-r--r--games/uhexen/Makefile7
-rw-r--r--games/voxelands/Makefile2
-rw-r--r--games/wesnoth/Makefile2
-rw-r--r--games/xmoto/Makefile2
-rw-r--r--games/zdoom/Makefile3
28 files changed, 63 insertions, 17 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index 44f7fd58af30..9831eeacde36 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -41,8 +41,9 @@ USE_WX= 2.8+
WX_COMPS= wx:lib
MAKE_ENV+= JOBS=${_MAKE_JOBS}
-BROKEN_aarch64= Fails to compile: no member named verifyHeapAccessDisassembly
-BROKEN_armv6= Fails to link: fatal error: conftest: Unknown error: -1
+BROKEN_aarch64= fails to compile: no member named verifyHeapAccessDisassembly
+BROKEN_armv6= fails to link: fatal error: conftest: Unknown error: -1
+BROKEN_powerpc64= fails to compile: _psutil_bsd.c: error: 'struct xtcpcb' has no member named 'xt_tp'
PORTDATA= *
diff --git a/games/ags/Makefile b/games/ags/Makefile
index 9d811a3fd91a..41bbb588dfdd 100644
--- a/games/ags/Makefile
+++ b/games/ags/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= liballeg.so:devel/allegro \
libvorbis.so:audio/libvorbis \
libfreetype.so:print/freetype2
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
+
USE_GITHUB= yes
GH_ACCOUNT= adventuregamestudio
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index eb4df4aa719e..cec02dfcf283 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -19,7 +19,9 @@ LIB_DEPENDS= libphysfs.so:devel/physfs
BUILD_DEPENDS= zip:archivers/zip \
${LOCALBASE}/include/boost/crc.hpp:devel/boost-libs
-BROKEN_aarch64= fails to compile: I can't tell what endian-ness to use for your architecture
+BROKEN_powerpc64= fails to build: cc1plus: unrecognized command line option "-std=c++11"
+NOT_FOR_ARCHS= aarch64
+NOT_FOR_ARCHS_REASON= fails to compile: I can't tell what endian-ness to use for your architecture
USES= cmake dos2unix localbase:ldflags pkgconfig
DOS2UNIX_REGEX= .*\.(c|h|cpp)
diff --git a/games/bloodfrontier/Makefile b/games/bloodfrontier/Makefile
index 50eb40d5d899..8d00e8d21ba0 100644
--- a/games/bloodfrontier/Makefile
+++ b/games/bloodfrontier/Makefile
@@ -13,9 +13,9 @@ COMMENT= Single- and multi-player first-person shooter based on Cube 2
LICENSE= ZLIB
-BROKEN_ia64= does not compile
-BROKEN_powerpc= does not compile
-BROKEN_sparc64= does not compile
+BROKEN_powerpc= fails to compile
+BROKEN_powerpc64= fails to compile: tools.h: incompatible types in assignment
+BROKEN_sparc64= fails to compile
USES= tar:bzip2 gmake
GNU_CONFIGURE= yes
diff --git a/games/cataclysm-dda/Makefile b/games/cataclysm-dda/Makefile
index c7b42105d9dc..26aec076a888 100644
--- a/games/cataclysm-dda/Makefile
+++ b/games/cataclysm-dda/Makefile
@@ -60,7 +60,9 @@ SOUND_IMPLIES= SDL
SOUND_FILES= cataclysmthemeREV6.ogg Dark_Days_Ahead_demo_2.ogg
-BROKEN_aarch64= Fails to compile: error: comparison of integers of different signs: wchar_t and const int
+BROKEN_aarch64= fails to compile: comparison of integers of different signs: wchar_t and const int
+BROKEN_armv6= fails to compile: comparison of integers of different signs: wchar_t and const int
+BROKEN_powerpc64= fails to compile: overmap.cpp: 'pow' is not a member of 'std'
.include <bsd.port.pre.mk>
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
index 316535efe696..8dc69e9fcaf6 100644
--- a/games/corsix-th/Makefile
+++ b/games/corsix-th/Makefile
@@ -16,6 +16,8 @@ LIB_DEPENDS= libfreetype.so:print/freetype2
RUN_DEPENDS= ${LUA_MODLIBDIR}/lfs.so:devel/luafilesystem \
${LUA_MODLIBDIR}/lpeg.so:devel/lua-lpeg
+BROKEN_powerpc64= fails to compile: th_map_overlays.cpp: 'to_string' is not a member of 'std'
+
USES= cmake compiler:c++11-lib dos2unix iconv lua pkgconfig
USE_SDL= mixer2
DOS2UNIX_FILES= CMake/FindFFmpeg.cmake \
diff --git a/games/divide-and-succeed/Makefile b/games/divide-and-succeed/Makefile
index 52fc1a150aa5..fa54c3bd3636 100644
--- a/games/divide-and-succeed/Makefile
+++ b/games/divide-and-succeed/Makefile
@@ -12,6 +12,8 @@ COMMENT= Divide polygons into the rigth number of equal parts
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: Polygone.h: 'vector' was not declared in this scope
+
USES= cmake
USE_SDL= sdl ttf
DATADIR= ${PREFIX}/share/divideandsucceed
diff --git a/games/dunelegacy/Makefile b/games/dunelegacy/Makefile
index 8d020afcd160..04a5fccb489f 100644
--- a/games/dunelegacy/Makefile
+++ b/games/dunelegacy/Makefile
@@ -14,6 +14,8 @@ COMMENT= Open source clone of Dune II
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: functional.h: 'std::bind' has not been declared
+
USES= autoreconf compiler:c++11-lib tar:bzip2
GNU_CONFIGURE= yes
USE_SDL= sdl mixer
diff --git a/games/el/Makefile b/games/el/Makefile
index 55b1b4899648..400a26876d07 100644
--- a/games/el/Makefile
+++ b/games/el/Makefile
@@ -17,7 +17,8 @@ LIB_DEPENDS= libpng.so:graphics/png \
libcal3d.so:graphics/cal3d
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/el.ini:games/el-data
-BROKEN_sparc64= Does not build on sparc64
+BROKEN_powerpc64= fails to compile: cal3d_io_wrapper.cpp: undefined reference to CalCoreAnimation::setFilename
+BROKEN_sparc64= fails to build on sparc64
USES= compiler:c++11-lang gmake iconv openal:al,alut
USE_GNOME= libxml2
diff --git a/games/emptyepsilon/Makefile b/games/emptyepsilon/Makefile
index ef068ef5ae76..8d02acf19b67 100644
--- a/games/emptyepsilon/Makefile
+++ b/games/emptyepsilon/Makefile
@@ -14,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libsfml-system.so:devel/sfml
+BROKEN_powerpc64= fails to compile: scienceDatabase.cpp: call of overloaded 'abs(float)' is ambiguous
+
USE_GITHUB= yes
GH_ACCOUNT= daid
GH_PROJECT= EmptyEpsilon SeriousProton:sproton
diff --git a/games/fishsupper/Makefile b/games/fishsupper/Makefile
index 28708c0d86b5..f87ee154ef55 100644
--- a/games/fishsupper/Makefile
+++ b/games/fishsupper/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/boost/bind.hpp:devel/boost-libs
+BROKEN_powerpc64= fails to compile: Log.h: expected initializer before '<' token
+
GNU_CONFIGURE= yes
USES= gmake localbase:ldflags
USE_SDL= sdl image mixer
diff --git a/games/hyperrogue/Makefile b/games/hyperrogue/Makefile
index 19140ee9936f..e87c99e8fe89 100644
--- a/games/hyperrogue/Makefile
+++ b/games/hyperrogue/Makefile
@@ -13,6 +13,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
+BROKEN_powerpc64= fails to link: langen-langen.o: relocation truncated to fit: R_PPC64_TOC16_DS
+
USE_GITHUB= yes
GH_ACCOUNT= zenorogue
diff --git a/games/iortcw/Makefile b/games/iortcw/Makefile
index 2aa2a79098e3..56551111193a 100644
--- a/games/iortcw/Makefile
+++ b/games/iortcw/Makefile
@@ -16,6 +16,9 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libopus.so:audio/opus \
libfreetype.so:print/freetype2
+NOT_FOR_ARCHS= aarch64 armv6 powerpc64
+NOT_FOR_ARCHS_REASON= fails to configure: Architecture not supported
+
USES= jpeg pkgconfig gmake
USE_GL= gl
USE_SDL= sdl2
@@ -45,9 +48,6 @@ SP_INSTALL_TARGET= sp-install
MP_ALL_TARGET= mp
MP_INSTALL_TARGET= mp-install
-BROKEN_aarch64= Fails to configure: error: Architecture not supported
-BROKEN_armv6= Fails to configure: error: Architecture not supported
-
post-extract:
${CP} ${FILESDIR}/Makefile ${WRKSRC}
diff --git a/games/lbreakout2/Makefile b/games/lbreakout2/Makefile
index d41452965873..877cae947efe 100644
--- a/games/lbreakout2/Makefile
+++ b/games/lbreakout2/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gif2png:graphics/gif2png
LIB_DEPENDS= libpng.so:graphics/png
+BROKEN_powerpc64= fails to build: gif2png: error in reading DataBlock: Segmentation fault (core dumped)
+
USES= gmake
USE_SDL= mixer net sdl
GNU_CONFIGURE= yes
diff --git a/games/manaplus/Makefile b/games/manaplus/Makefile
index 63c0259a7d0a..f89e8671270f 100644
--- a/games/manaplus/Makefile
+++ b/games/manaplus/Makefile
@@ -16,6 +16,8 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2 \
libpng.so:graphics/png \
libcurl.so:ftp/curl
+BROKEN_powerpc64= fails to install: zip.cpp: 'bswap_16' was not declared in this scope
+
USES= autoreconf pkgconfig:build tar:xz
USE_XORG= x11
USE_SDL= sdl2 gfx2 image2 mixer2 net2 ttf2
diff --git a/games/openomf/Makefile b/games/openomf/Makefile
index b9aad26fde9c..4f10d937fa6a 100644
--- a/games/openomf/Makefile
+++ b/games/openomf/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= libconfuse.so:devel/libconfuse \
libenet.so:net/enet
EXTRACT_DEPENDS= unrar:archivers/unrar
+BROKEN_powerpc64= fails to compile: gcc5: error: unrecognized command line option '-msse'
+
USE_GITHUB= yes
GH_ACCOUNT= omf2097
GH_TAGNAME= c36c421
diff --git a/games/openspades/Makefile b/games/openspades/Makefile
index d245f7ca33de..10718592f710 100644
--- a/games/openspades/Makefile
+++ b/games/openspades/Makefile
@@ -18,6 +18,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= convert:graphics/ImageMagick # for building icons
LIB_DEPENDS= libcurl.so:ftp/curl
+NOT_FOR_ARCHS= aarch64 powerpc64
+NOT_FOR_ARCHS_REASON= fails to compile: uses x86 assembly
+
USE_GITHUB= yes
GH_ACCOUNT= yvt
@@ -35,8 +38,6 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS
-BROKEN_aarch64= Fails to compile: unknown register name %xmm0 in asm
-
post-extract:
@${MKDIR} ${WRKSRC}/Resources/DevPak
@${MV} ${WRKDIR}/*.pak ${WRKSRC}/Resources/DevPak/
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index add96e58ed5b..10a8af8126ca 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -21,6 +21,8 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png \
liblzo2.so:archivers/lzo2
+BROKEN_powerpc64= fails to compile: libicuuc.so: undefined reference to __cxa_throw_bad_array_new_length
+
USES= cpe gmake pkgconfig tar:xz
HAS_CONFIGURE= yes
CONFIGURE_ENV= STRIP="${STRIP_CMD} ${STRIP}"
diff --git a/games/openxcom/Makefile b/games/openxcom/Makefile
index e12e1b44ce8c..1e165e34f3f3 100644
--- a/games/openxcom/Makefile
+++ b/games/openxcom/Makefile
@@ -15,6 +15,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libyaml-cpp.so:devel/yaml-cpp
+BROKEN_powerpc64= fails to compile: XcomResourcePack.cpp: undefined reference to YAML::LoadFile
+
USE_GITHUB= yes
GH_ACCOUNT= SupSuper
GH_PROJECT= OpenXcom
diff --git a/games/retroarch/Makefile b/games/retroarch/Makefile
index 2f1b9e44abd6..705889ca55a9 100644
--- a/games/retroarch/Makefile
+++ b/games/retroarch/Makefile
@@ -17,6 +17,8 @@ LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon \
libdrm.so:graphics/libdrm \
libass.so:multimedia/libass
+BROKEN_powerpc64= fails to compile: features_cpu.c: undefined reference to __mftb
+
OPTIONS_DEFINE= FFMPEG OSS JACK PULSEAUDIO ALSA SDL OPENGL OPENAL NETPLAY PYTHON V4L FREETYPE FBO
OPTIONS_DEFAULT=FFMPEG OSS PULSEAUDIO SDL OPENGL OPENAL NETPLAY PYTHON V4L FREETYPE FBO
FFMPEG_DESC= On-the-fly recording of gameplay with libavcodec
diff --git a/games/stepmania-devel/Makefile b/games/stepmania-devel/Makefile
index 19641d56f21f..2414353e232b 100644
--- a/games/stepmania-devel/Makefile
+++ b/games/stepmania-devel/Makefile
@@ -18,6 +18,8 @@ LICENSE_FILE= ${WRKSRC}/Docs/Licenses.txt
LIB_DEPENDS= libpcre.so:devel/pcre \
libpng.so:graphics/png
+BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-msse2"
+
USE_GITHUB= yes
USES= cmake:outsource iconv jpeg perl5 pkgconfig shebangfix
diff --git a/games/traingame/Makefile b/games/traingame/Makefile
index 33300c46a910..1d0a0462d5d7 100644
--- a/games/traingame/Makefile
+++ b/games/traingame/Makefile
@@ -16,6 +16,8 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libxerces-c.so:textproc/xerces-c3 \
libboost_filesystem.so:devel/boost-libs
+BROKEN_powerpc64= fails to compile: Main.cpp.o: undefined reference to boost::program_options::arg
+
USE_GITHUB= yes
GH_ACCOUNT= nickg
GH_TAGNAME= cb6513e
diff --git a/games/trigger-rally/Makefile b/games/trigger-rally/Makefile
index 61431082498a..026fb67499ea 100644
--- a/games/trigger-rally/Makefile
+++ b/games/trigger-rally/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS+= libalut.so:audio/freealut
BROKEN_aarch64= fails to compile: error: the clang compiler does not support -march=native
BROKEN_armv6= fails to compile: error: the clang compiler does not support -march=native
+BROKEN_powerpc64= fails to compile: error: the clang compiler does not support -march=native
WRKSRC_SUBDIR= src
USES= gmake openal:al,alut
diff --git a/games/uhexen/Makefile b/games/uhexen/Makefile
index 6871e3f4ad05..c670a7a83564 100644
--- a/games/uhexen/Makefile
+++ b/games/uhexen/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/U-hexen%20version%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet another port of Hexen, popular game from Raven Software
+BROKEN_powerpc= fails to compile
+BROKEN_powerpc64= fails to compile: m_misc.o: undefined reference to 'ShortSwap'
+
USES= gmake
USE_SDL= mixer sdl
MAKE_ENV= EXTRA_LIBS=-lm
@@ -23,10 +26,6 @@ MUSIC_RUN_DEPENDS= ${LOCALBASE}/lib/timidity/goemon.cfg:audio/timidity
.include <bsd.port.pre.mk>
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on ${ARCH}
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/games/voxelands/Makefile b/games/voxelands/Makefile
index efd5a375577a..dd5e48170d90 100644
--- a/games/voxelands/Makefile
+++ b/games/voxelands/Makefile
@@ -15,6 +15,8 @@ LICENSE= GPLv3+
LIB_DEPENDS= libIrrlicht.so:x11-toolkits/irrlicht \
libfreetype.so:print/freetype2
+BROKEN_powerpc64= fails to link: sibling call optimization does not allow automatic multiple TOCs
+
USES= cmake tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 161fdbd870fe..da63cde3886c 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -21,6 +21,8 @@ LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libpng.so:graphics/png \
libfontconfig.so:x11-fonts/fontconfig
+BROKEN_powerpc64= fails to link: schema_validator.cpp: undefined reference to boost::match_results
+
LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
PORTSCOUT= limitw:1,even
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 7936e28e738b..202fc5fec4f4 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= libode.so:devel/ode \
libcurl.so:ftp/curl \
libxdg-basedir.so:x11/libxdg-basedir
+BROKEN_powerpc64= fails to compile: hashtable.h: no match for call to __gnu_cxx::hash
+
GNU_CONFIGURE= yes
USES= compiler:features dos2unix gmake jpeg localbase lua:51 sqlite
USE_GNOME= libxml2
diff --git a/games/zdoom/Makefile b/games/zdoom/Makefile
index 7db269ba2cff..1e4ab5d6d546 100644
--- a/games/zdoom/Makefile
+++ b/games/zdoom/Makefile
@@ -19,6 +19,9 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libsndfile.so:audio/libsndfile
+NOT_FOR_ARCHS= powerpc64
+NOT_FOR_ARCHS_REASON= fails to compile: invokes x86 assembly
+
USE_GITHUB= yes
GH_ACCOUNT= rheit