aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-05-09 20:17:06 +0800
committeritetcu <itetcu@FreeBSD.org>2006-05-09 20:17:06 +0800
commitf7012b25dcca78e0fe162658da79a0d5b89823e9 (patch)
tree6b360a712a41c6f52a4319669e2f4c70088d4b7c /games
parentad80c1fb010464702fbc40230ca0dc4541b9e738 (diff)
downloadfreebsd-ports-gnome-f7012b25dcca78e0fe162658da79a0d5b89823e9.tar.gz
freebsd-ports-gnome-f7012b25dcca78e0fe162658da79a0d5b89823e9.tar.zst
freebsd-ports-gnome-f7012b25dcca78e0fe162658da79a0d5b89823e9.zip
Update to 1.9.0b3.
PR: ports/94821 Submitted by: Igor Pokrovsky <ip@doom.homeunix.org> (maintainer) Approved by: lawrance (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/deng/Makefile9
-rw-r--r--games/deng/distinfo6
-rw-r--r--games/deng/files/patch-Src_dd__pinit.c6
3 files changed, 11 insertions, 10 deletions
diff --git a/games/deng/Makefile b/games/deng/Makefile
index 54573b3ba5cf..ed8c64671022 100644
--- a/games/deng/Makefile
+++ b/games/deng/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= deng
-PORTVERSION= 1.8.6
-PORTREVISION= 2
+PORTVERSION= 1.9.0b3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/-beta/}
MAINTAINER= ip@doom.homeunix.org
COMMENT= An enhanced Doom, Heretic and Hexen source port
@@ -30,7 +30,8 @@ ONLY_FOR_ARCHS= i386
SUB_FILES= pkg-message
SUB_LIST= "PREFIX=${PREFIX}" "DOCSDIR=${DOCSDIR}"
-.include "${.CURDIR}/../doom-data/Makefile.include"
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/games/doom-data/Makefile.include"
.if exists(${LOCALBASE}/lib/libopenal.so.0) || defined(WITH_OPENAL)
WITH_OPENAL= yes
@@ -67,4 +68,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/deng/distinfo b/games/deng/distinfo
index 6bc5b14efe63..4604d2bef02b 100644
--- a/games/deng/distinfo
+++ b/games/deng/distinfo
@@ -1,3 +1,3 @@
-MD5 (deng-1.8.6.tar.gz) = 1717d0de5bc8efba9076d6b8e2055d08
-SHA256 (deng-1.8.6.tar.gz) = 06e33d9efe3522c72940bda0d6892e58e2b1479f2b261a885b7854b9ce0201a6
-SIZE (deng-1.8.6.tar.gz) = 3157590
+MD5 (deng-1.9.0-beta3.tar.gz) = 581fefd6165dd4104b25656a6b9f31b4
+SHA256 (deng-1.9.0-beta3.tar.gz) = a52dca759ab48a14548f255f955c10602a6591aa48687993dd4b6131723ce5fb
+SIZE (deng-1.9.0-beta3.tar.gz) = 3224025
diff --git a/games/deng/files/patch-Src_dd__pinit.c b/games/deng/files/patch-Src_dd__pinit.c
index 79f7f7557b89..468e5e81063f 100644
--- a/games/deng/files/patch-Src_dd__pinit.c
+++ b/games/deng/files/patch-Src_dd__pinit.c
@@ -1,11 +1,11 @@
--- Src/dd_pinit.c.orig
+++ Src/dd_pinit.c
-@@ -227,7 +227,7 @@
+@@ -226,7 +226,7 @@
FH_Clear();
ArgShutdown();
- free(mainzone);
+ Z_Shutdown();
- DD_ShutdownDGL();
-+// DD_ShutdownDGL();
++ //DD_ShutdownDGL();
// Close the message output file.
fclose(outFile);