aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2017-02-03 20:35:51 +0800
committerehaupt <ehaupt@FreeBSD.org>2017-02-03 20:35:51 +0800
commit00c11fe1f9e3f297fe2216a1acb0a250e0dfb528 (patch)
tree38ee704ba036402fe96a6e418695791fd75dadcf /games
parente688e1e3c836f6e126a7ec637b4e5f695676c063 (diff)
downloadfreebsd-ports-gnome-00c11fe1f9e3f297fe2216a1acb0a250e0dfb528.tar.gz
freebsd-ports-gnome-00c11fe1f9e3f297fe2216a1acb0a250e0dfb528.tar.zst
freebsd-ports-gnome-00c11fe1f9e3f297fe2216a1acb0a250e0dfb528.zip
Fix build with clang 4.0
PR: 216630 (based on) Notified by: jbeich
Diffstat (limited to 'games')
-rw-r--r--games/bloboats/Makefile4
-rw-r--r--games/bloboats/files/patch-Makefile2
-rw-r--r--games/bloboats/files/patch-src_menu.cpp12
3 files changed, 16 insertions, 2 deletions
diff --git a/games/bloboats/Makefile b/games/bloboats/Makefile
index 23e78a4923cc..81de34598a0e 100644
--- a/games/bloboats/Makefile
+++ b/games/bloboats/Makefile
@@ -15,7 +15,7 @@ COMMENT= Boat racing game in the spirit of Elasto Mania or X-Moto
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/copying.txt
-USES= gmake
+USES= dos2unix gmake
USE_SDL= mixer image net sdl
USE_GL= gl glu
@@ -23,4 +23,6 @@ MAKE_ENV+= DATADIR="${DATADIR}" STAGEDIR=${STAGEDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+DOS2UNIX_FILES= src/*.cpp
+
.include <bsd.port.mk>
diff --git a/games/bloboats/files/patch-Makefile b/games/bloboats/files/patch-Makefile
index 7a6dd4ac88e5..76f99fb0d3d1 100644
--- a/games/bloboats/files/patch-Makefile
+++ b/games/bloboats/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2010-11-23 19:27:16 UTC
+--- Makefile.orig 2017-02-03 12:18:46 UTC
+++ Makefile
@@ -7,16 +7,13 @@
### Installation directory (Installation prefix)
diff --git a/games/bloboats/files/patch-src_menu.cpp b/games/bloboats/files/patch-src_menu.cpp
new file mode 100644
index 000000000000..610b249da3b6
--- /dev/null
+++ b/games/bloboats/files/patch-src_menu.cpp
@@ -0,0 +1,12 @@
+--- src/menu.cpp.orig 2017-02-03 12:18:46 UTC
++++ src/menu.cpp
+@@ -1567,7 +1567,8 @@ void menu::resolution() {
+ // Get resolutions
+ vector<Resolution> resolutions;
+ SDL_Rect** modes = SDL_ListModes(NULL, SDL_FULLSCREEN|SDL_HWSURFACE|SDL_OPENGL);
+- if(modes > 0) {
++ // if(modes > 0) {
++ if(modes != '\0') {
+ Uint32 bpp = SDL_GetVideoInfo()->vfmt->BitsPerPixel;
+ for(int i=0; modes[i] && i < 10; ++i) {
+ Resolution resolution;