aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-07-29 06:00:47 +0800
committeralepulver <alepulver@FreeBSD.org>2006-07-29 06:00:47 +0800
commit055f45d428f01e5db426bfe00db3a4034d378dd9 (patch)
tree6d2c921a57281536957d895d792f744d58e107b2 /games
parent08563b90ecc6fca4789069f44e0ec89c75d26b2f (diff)
downloadfreebsd-ports-gnome-055f45d428f01e5db426bfe00db3a4034d378dd9.tar.gz
freebsd-ports-gnome-055f45d428f01e5db426bfe00db3a4034d378dd9.tar.zst
freebsd-ports-gnome-055f45d428f01e5db426bfe00db3a4034d378dd9.zip
Quake II: Ground Zero (Rogue) Mission Pack.
Take out the Big Gun sounded simple enough, except the Strogg were waiting. You, and a few marines like you, are the lucky ones. You've made it down in one piece and are still able to contact the fleet. The Gravity Well, the Strogg's newest weapon in its arsenal against mankind, is operational. With the fleet around Stroggos, 5% of ground forces surviving, and that number dwindling by the second, your orders have change: free your comrades. Destroy the Gravity Well. - New Enemies -- The Stalker, Turrets, Daedalus, Medic Commander, Carrier, and the Black Widow. - 14 Entirely new levels and 10 new deathmatch levels. - New Power-Ups -- Deathmatch specific power-ups: Vengeance Sphere, Hunter Sphere, and Anti-matter bomb. - New Weapons -- The Chainsaw, ETF Rifle and Plasma Beam. This port installs the game.so file, but you still need the original data. WWW: http://www.idsoftware.com/games/quake/quake2-grndzero/
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/quake2-rogue/Makefile50
-rw-r--r--games/quake2-rogue/distinfo3
-rw-r--r--games/quake2-rogue/files/Makefile74
-rw-r--r--games/quake2-rogue/files/patch-g_local.h11
-rw-r--r--games/quake2-rogue/files/pkg-message.in8
-rw-r--r--games/quake2-rogue/pkg-descr20
7 files changed, 167 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index d7981726941e..07e35401b0d2 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -557,6 +557,7 @@
SUBDIR += quake2-data
SUBDIR += quake2-extras
SUBDIR += quake2-relay
+ SUBDIR += quake2-rogue
SUBDIR += quake2-source
SUBDIR += quake2forge
SUBDIR += quake2lnx
diff --git a/games/quake2-rogue/Makefile b/games/quake2-rogue/Makefile
new file mode 100644
index 000000000000..289a3e96807f
--- /dev/null
+++ b/games/quake2-rogue/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: quake2-rogue
+# Date created: 26 Jul 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= rogue
+PORTVERSION= 3.20
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_IDSOFTWARE}
+MASTER_SITE_SUBDIR= quake2/source
+PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}src${PORTVERSION:S/.//}
+EXTRACT_SUFX= .shar.Z
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Quake II Ground Zero (Rogue) Mission Pack
+
+NO_WRKSUBDIR= yes
+
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
+
+PLIST_FILES= %%Q2DIR%%/${PORTNAME}/game.so
+PLIST_DIRS= %%Q2DIR%%/${PORTNAME}
+
+SUB_FILES= pkg-message
+
+.include "${.CURDIR}/../quake2-data/Makefile.include"
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @cd ${WRKDIR} && \
+ uncompress -c ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} | \
+ ${TAIL} +454 | ${SH}
+
+post-extract:
+ @${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
+
+post-patch:
+ @${REINPLACE_CMD} -e '/#include <nan.h>/d' ${WRKSRC}/g_local.h
+ @${REINPLACE_CMD} -e 's/__linux__/__unix__/' ${WRKSRC}/q_shared.[ch]
+
+do-install:
+ ${MKDIR} ${Q2DIR}/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/game.so ${Q2DIR}/${PORTNAME}
+
+.include <bsd.port.post.mk>
diff --git a/games/quake2-rogue/distinfo b/games/quake2-rogue/distinfo
new file mode 100644
index 000000000000..e9eb8f053452
--- /dev/null
+++ b/games/quake2-rogue/distinfo
@@ -0,0 +1,3 @@
+MD5 (roguesrc320.shar.Z) = 7d5e052839c9e629bad0a6570aa70554
+SHA256 (roguesrc320.shar.Z) = ceefb2fd748961cb0bc3244220f3eb09d8f7b8ca2eb32cdf9b284727a2fdc919
+SIZE (roguesrc320.shar.Z) = 626769
diff --git a/games/quake2-rogue/files/Makefile b/games/quake2-rogue/files/Makefile
new file mode 100644
index 000000000000..50da24cdd25f
--- /dev/null
+++ b/games/quake2-rogue/files/Makefile
@@ -0,0 +1,74 @@
+# $FreeBSD$
+
+SHLIB= game
+SHLIB_NAME= game.so
+
+SRCS= dm_ball.c \
+ dm_tag.c \
+ g_ai.c \
+ g_chase.c \
+ g_cmds.c \
+ g_combat.c \
+ g_func.c \
+ g_items.c \
+ g_main.c \
+ g_misc.c \
+ g_monster.c \
+ g_newai.c \
+ g_newdm.c \
+ g_newfnc.c \
+ g_newtarg.c \
+ g_newtrig.c \
+ g_newweap.c \
+ g_phys.c \
+ g_save.c \
+ g_spawn.c \
+ g_sphere.c \
+ g_svcmds.c \
+ g_target.c \
+ g_trigger.c \
+ g_turret.c \
+ g_utils.c \
+ g_weapon.c \
+ m_actor.c \
+ m_berserk.c \
+ m_boss2.c \
+ m_boss3.c \
+ m_boss31.c \
+ m_boss32.c \
+ m_brain.c \
+ m_carrier.c \
+ m_chick.c \
+ m_flash.c \
+ m_flipper.c \
+ m_float.c \
+ m_flyer.c \
+ m_gladiator.c \
+ m_gunner.c \
+ m_hover.c \
+ m_infantry.c \
+ m_insane.c \
+ m_medic.c \
+ m_move.c \
+ m_mutant.c \
+ m_parasite.c \
+ m_soldier.c \
+ m_stalker.c \
+ m_supertank.c \
+ m_tank.c \
+ m_turret.c \
+ m_widow.c \
+ m_widow2.c \
+ p_client.c \
+ p_hud.c \
+ p_trail.c \
+ p_view.c \
+ p_weapon.c \
+ q_shared.c
+
+CFLAGS+= -Dstricmp=strcasecmp -ffast-math -funroll-loops \
+ -fomit-frame-pointer -fexpensive-optimizations
+
+LDFLAGS+= -L/lib -L/usr/lib -lm
+
+.include <bsd.lib.mk>
diff --git a/games/quake2-rogue/files/patch-g_local.h b/games/quake2-rogue/files/patch-g_local.h
new file mode 100644
index 000000000000..aa1631d639c2
--- /dev/null
+++ b/games/quake2-rogue/files/patch-g_local.h
@@ -0,0 +1,11 @@
+--- ./g_local.h.orig Fri Jul 28 16:29:27 2006
++++ ./g_local.h Fri Jul 28 16:33:09 2006
+@@ -27,7 +27,7 @@
+ #ifdef __sun__
+ #define _isnan(a) (NaN((a)))
+ #else
+-#define _isnan(a) ((a)==NAN)
++#define _isnan(a) (isnan(a))
+ #endif
+ #endif
+
diff --git a/games/quake2-rogue/files/pkg-message.in b/games/quake2-rogue/files/pkg-message.in
new file mode 100644
index 000000000000..369f982534da
--- /dev/null
+++ b/games/quake2-rogue/files/pkg-message.in
@@ -0,0 +1,8 @@
+==============================================================================
+
+To complete the installation of this port you need to copy the file
+"rogue/pak0.pak" and the directory "rogue/video" with its contents from the
+original Quake II: Ground Zero (Rogue) Mission Pack distribution to
+"%%Q2DIR%%/rogue".
+
+==============================================================================
diff --git a/games/quake2-rogue/pkg-descr b/games/quake2-rogue/pkg-descr
new file mode 100644
index 000000000000..9e917837af5c
--- /dev/null
+++ b/games/quake2-rogue/pkg-descr
@@ -0,0 +1,20 @@
+Quake II: Ground Zero (Rogue) Mission Pack.
+
+Take out the Big Gun sounded simple enough, except the Strogg were waiting.
+You, and a few marines like you, are the lucky ones. You've made it down in
+one piece and are still able to contact the fleet. The Gravity Well, the
+Strogg's newest weapon in its arsenal against mankind, is operational. With
+the fleet around Stroggos, 5% of ground forces surviving, and that number
+dwindling by the second, your orders have change: free your comrades. Destroy
+the Gravity Well.
+
+- New Enemies -- The Stalker, Turrets, Daedalus, Medic Commander, Carrier, and
+ the Black Widow.
+- 14 Entirely new levels and 10 new deathmatch levels.
+- New Power-Ups -- Deathmatch specific power-ups: Vengeance Sphere, Hunter
+ Sphere, and Anti-matter bomb.
+- New Weapons -- The Chainsaw, ETF Rifle and Plasma Beam.
+
+This port installs the game.so file, but you still need the original data.
+
+WWW: http://www.idsoftware.com/games/quake/quake2-grndzero/