aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-01-12 05:50:17 +0800
committeranholt <anholt@FreeBSD.org>2003-01-12 05:50:17 +0800
commit0f75c83d938094b05d68644b90239d52844cf3ad (patch)
tree2a2e55319e2a684e8bc5fb7b9e7255bc149a93b5 /games
parent662609594c76846acaab9c922355dee668619a86 (diff)
downloadfreebsd-ports-gnome-0f75c83d938094b05d68644b90239d52844cf3ad.tar.gz
freebsd-ports-gnome-0f75c83d938094b05d68644b90239d52844cf3ad.tar.zst
freebsd-ports-gnome-0f75c83d938094b05d68644b90239d52844cf3ad.zip
Add tileworld, an SDL puzzle game.
PR: ports/43832 Submitted by: Stefan `Sec` Zehl <sec@42.org>
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/tileworld/Makefile29
-rw-r--r--games/tileworld/distinfo1
-rw-r--r--games/tileworld/pkg-comment1
-rw-r--r--games/tileworld/pkg-descr11
-rw-r--r--games/tileworld/pkg-plist42
6 files changed, 85 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 7ab03f72024a..8f7dec0a3dad 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -299,6 +299,7 @@
SUBDIR += tetrinet
SUBDIR += tetrinet-x
SUBDIR += textmaze
+ SUBDIR += tileworld
SUBDIR += tinymux
SUBDIR += tkmoo
SUBDIR += tksol
diff --git a/games/tileworld/Makefile b/games/tileworld/Makefile
new file mode 100644
index 000000000000..eac587ea5fd9
--- /dev/null
+++ b/games/tileworld/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: tileworld
+# Date created: 08. Oct 02
+# Whom: sec@42.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tileworld
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://www.muppetlabs.com/~breadbox/pub/software/tworld/
+DISTNAME= tworld-${PORTVERSION}
+
+MAINTAINER= sec@42.org
+
+LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+USE_REINPLACE= YES
+ALL_TARGET= tworld
+
+MAN6= tworld.6
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|make|$${MAKE}|g; s|cp -i|cp|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/games/tileworld/distinfo b/games/tileworld/distinfo
new file mode 100644
index 000000000000..d34b541d514f
--- /dev/null
+++ b/games/tileworld/distinfo
@@ -0,0 +1 @@
+MD5 (tworld-1.0.tar.gz) = 4ccb1d38da7dcdc9c982b9c8e55ee232
diff --git a/games/tileworld/pkg-comment b/games/tileworld/pkg-comment
new file mode 100644
index 000000000000..19bbfec5de07
--- /dev/null
+++ b/games/tileworld/pkg-comment
@@ -0,0 +1 @@
+An emulation of the game "Chip's Challenge"
diff --git a/games/tileworld/pkg-descr b/games/tileworld/pkg-descr
new file mode 100644
index 000000000000..609663141b16
--- /dev/null
+++ b/games/tileworld/pkg-descr
@@ -0,0 +1,11 @@
+Tile World is an emulation of the game "Chip's Challenge". "Chip's
+Challenge" was originally written for the Atari Lynx by Chuck Sommerville,
+and was later ported to MS Windows by Microsoft (among other ports).
+
+"Chip's Challenge" is a game made up of both intellectually engaging
+puzzles and situations demanding fast reflexes. As you might have guessed,
+it is a tile-based game. The object of each level is simply to get out --
+i.e., to find and achieve the exit tile. This simple task, however, can
+sometimes be extremely challenging.
+
+WWW: http://www.muppetlabs.com/~breadbox/software/tworld/
diff --git a/games/tileworld/pkg-plist b/games/tileworld/pkg-plist
new file mode 100644
index 000000000000..acade97e5ec6
--- /dev/null
+++ b/games/tileworld/pkg-plist
@@ -0,0 +1,42 @@
+bin/tworld
+share/tworld/sets/intro-ms.dac
+share/tworld/sets/intro-lynx.dac
+share/tworld/sets/cc-ms.dac
+share/tworld/sets/cc-lynx.dac
+share/tworld/sets/CCLP2.dac
+share/tworld/data/intro.dat
+share/tworld/res/rc
+share/tworld/res/tiles.bmp
+share/tworld/res/font.bmp
+share/tworld/res/atiles.bmp
+share/tworld/res/block.wav
+share/tworld/res/traphit.wav
+share/tworld/res/ting.wav
+share/tworld/res/tick.wav
+share/tworld/res/thief.wav
+share/tworld/res/teleport.wav
+share/tworld/res/tada.wav
+share/tworld/res/splash.wav
+share/tworld/res/socket.wav
+share/tworld/res/snick.wav
+share/tworld/res/slurp.wav
+share/tworld/res/skaturn.wav
+share/tworld/res/skate.wav
+share/tworld/res/popup.wav
+share/tworld/res/plip.wav
+share/tworld/res/oof.wav
+share/tworld/res/force.wav
+share/tworld/res/door.wav
+share/tworld/res/ding.wav
+share/tworld/res/derezz.wav
+share/tworld/res/death.wav
+share/tworld/res/crackle.wav
+share/tworld/res/click.wav
+share/tworld/res/chack.wav
+share/tworld/res/bump.wav
+share/tworld/res/bomb.wav
+share/tworld/res/whisk.wav
+@dirrm share/tworld/sets
+@dirrm share/tworld/data
+@dirrm share/tworld/res
+@dirrm share/tworld