aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-11-12 18:20:40 +0800
committersobomax <sobomax@FreeBSD.org>2001-11-12 18:20:40 +0800
commit19167337b07657cefec9414e8fe4400ee09a4af6 (patch)
tree73d7168336bd7a273200dd5282912bd3ec7799a7 /games
parentba799645b74a6e4b0c7413e209b80df60d14e38a (diff)
downloadfreebsd-ports-gnome-19167337b07657cefec9414e8fe4400ee09a4af6.tar.gz
freebsd-ports-gnome-19167337b07657cefec9414e8fe4400ee09a4af6.tar.zst
freebsd-ports-gnome-19167337b07657cefec9414e8fe4400ee09a4af6.zip
Fix a breakage resulted from path to gdk-pixbuf's includes being hardcoded.
Reported by: Mike Harding <mvh@ix.netcom.com> Anders Andersson <anders@codefactory.se>
Diffstat (limited to 'games')
-rw-r--r--games/gnome-games/Makefile3
-rw-r--r--games/gnomegames/Makefile3
-rw-r--r--games/gnomegames2/Makefile3
3 files changed, 6 insertions, 3 deletions
diff --git a/games/gnome-games/Makefile b/games/gnome-games/Makefile
index 7aed19eb56bf..cbee96797aea 100644
--- a/games/gnome-games/Makefile
+++ b/games/gnome-games/Makefile
@@ -23,7 +23,8 @@ USE_GMAKE= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
+ `gdk-pixbuf-config --cflags`" \
LIBS="-L${LOCALBASE}/lib" \
MSGFMT=${LOCALBASE}/bin/msgfmt-new \
XGETTEXT=${LOCALBASE}/bin/xgettext-new
diff --git a/games/gnomegames/Makefile b/games/gnomegames/Makefile
index 7aed19eb56bf..cbee96797aea 100644
--- a/games/gnomegames/Makefile
+++ b/games/gnomegames/Makefile
@@ -23,7 +23,8 @@ USE_GMAKE= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
+ `gdk-pixbuf-config --cflags`" \
LIBS="-L${LOCALBASE}/lib" \
MSGFMT=${LOCALBASE}/bin/msgfmt-new \
XGETTEXT=${LOCALBASE}/bin/xgettext-new
diff --git a/games/gnomegames2/Makefile b/games/gnomegames2/Makefile
index 7aed19eb56bf..cbee96797aea 100644
--- a/games/gnomegames2/Makefile
+++ b/games/gnomegames2/Makefile
@@ -23,7 +23,8 @@ USE_GMAKE= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
+ `gdk-pixbuf-config --cflags`" \
LIBS="-L${LOCALBASE}/lib" \
MSGFMT=${LOCALBASE}/bin/msgfmt-new \
XGETTEXT=${LOCALBASE}/bin/xgettext-new