aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-12-04 07:14:35 +0800
committergerald <gerald@FreeBSD.org>2013-12-04 07:14:35 +0800
commit227b1a7d9acb305615b501c4250eafef02565706 (patch)
tree1260d88b1d00f5bd2c6486207ceda55b0732db47 /games
parentc872ae0c48710ad143554568350117691e35983e (diff)
downloadfreebsd-ports-gnome-227b1a7d9acb305615b501c4250eafef02565706.tar.gz
freebsd-ports-gnome-227b1a7d9acb305615b501c4250eafef02565706.tar.zst
freebsd-ports-gnome-227b1a7d9acb305615b501c4250eafef02565706.zip
Fix the build with GCC 4.7 and later (which do fewer extraneous
#includes of system include files). [1] On the way adjust to the new LIB_DEPENDS format. PR: 183342 [1] Submitted by: Christoph Moench-Tegeder <cmt@burggraben.net> [1]
Diffstat (limited to 'games')
-rw-r--r--games/battletanks/Makefile6
-rw-r--r--games/battletanks/files/patch-mrt-base_file.h10
2 files changed, 13 insertions, 3 deletions
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index cffa2597b6ff..efaec9e8de18 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -12,9 +12,9 @@ COMMENT= Fast 2D tank arcade game with multiplayer and split-screen modes
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
- expat.6:${PORTSDIR}/textproc/expat2 \
- vorbisfile.6:${PORTSDIR}/audio/libvorbis \
- smpeg.1:${PORTSDIR}/multimedia/smpeg
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
+ libsmpeg.so:${PORTSDIR}/multimedia/smpeg
USES= pkgconfig
USE_BZIP2= yes
diff --git a/games/battletanks/files/patch-mrt-base_file.h b/games/battletanks/files/patch-mrt-base_file.h
new file mode 100644
index 000000000000..6f39e5ece4ce
--- /dev/null
+++ b/games/battletanks/files/patch-mrt-base_file.h
@@ -0,0 +1,10 @@
+--- mrt/base_file.h.orig 2013-11-16 13:43:12.000000000 +0100
++++ mrt/base_file.h 2013-11-16 13:44:09.000000000 +0100
+@@ -20,6 +20,7 @@
+ */
+
+ #include <string>
++#include <sys/types.h>
+ #include "export_mrt.h"
+
+ namespace mrt {