aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-02-21 02:12:36 +0800
committertijl <tijl@FreeBSD.org>2017-02-21 02:12:36 +0800
commit2e88d6cb30bb6d8431414d73c87362f0fec9775d (patch)
treec4c88991d6d90d028b8718eb4995f3c5e821ec8c /games
parent2900c88e416a6ca25fd5e444d7627619588c0b67 (diff)
downloadfreebsd-ports-gnome-2e88d6cb30bb6d8431414d73c87362f0fec9775d.tar.gz
freebsd-ports-gnome-2e88d6cb30bb6d8431414d73c87362f0fec9775d.tar.zst
freebsd-ports-gnome-2e88d6cb30bb6d8431414d73c87362f0fec9775d.zip
Remove unnecessary mikmod dependency.
Test LINUX_ARCH instead of ARCH.
Diffstat (limited to 'games')
-rw-r--r--games/linux-worldofgoo-demo/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/linux-worldofgoo-demo/Makefile b/games/linux-worldofgoo-demo/Makefile
index fe61721e0ef7..9a10b7d8e101 100644
--- a/games/linux-worldofgoo-demo/Makefile
+++ b/games/linux-worldofgoo-demo/Makefile
@@ -15,7 +15,7 @@ COMMENT= Demo version of incredible physics based puzzle/construction game
ONLY_FOR_ARCHS= i386 amd64
USES= linux
-USE_LINUX= dri libvorbis mikmod sdl12 sdlmixer
+USE_LINUX= dri libvorbis sdl12 sdlmixer
NO_BUILD= yes
WRKSRC= ${WRKDIR}/WorldOfGooDemo
DATADIR= ${PREFIX}/share/WorldOfGoo
@@ -23,9 +23,9 @@ DOCSDIR= ${PREFIX}/share/doc/WorldOfGoo
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
+.if ${LINUX_ARCH} == "i386"
TARGET_BIN= WorldOfGoo.bin32
.else
TARGET_BIN= WorldOfGoo.bin64
@@ -54,4 +54,4 @@ do-install:
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>