aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-02-07 22:42:13 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-02-07 22:42:13 +0800
commit2ec8887c6dfd4ebaced76cd9957363126aea2d69 (patch)
treedf568a7e618caa36f88cd271f3b2c45b45ba7dc9 /games
parentb811fa0c441ed9cda11155d9306470762f9bc99c (diff)
downloadfreebsd-ports-gnome-2ec8887c6dfd4ebaced76cd9957363126aea2d69.tar.gz
freebsd-ports-gnome-2ec8887c6dfd4ebaced76cd9957363126aea2d69.tar.zst
freebsd-ports-gnome-2ec8887c6dfd4ebaced76cd9957363126aea2d69.zip
- Fix LICENSE
- Fix build with boost 1.60 - Strip binary Approved by: portmgr blanket
Diffstat (limited to 'games')
-rw-r--r--games/pokerth/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/games/pokerth/Makefile b/games/pokerth/Makefile
index 60a510ce8dfc..625c2e610f38 100644
--- a/games/pokerth/Makefile
+++ b/games/pokerth/Makefile
@@ -11,7 +11,7 @@ DISTNAME= PokerTH-${PORTVERSION}-src
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Poker game written in C++/Qt4
-LICENSE= GPLv2
+LICENSE= AGPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
@@ -40,8 +40,11 @@ post-patch:
-e 's|LIB_DIRS =.*|LIB_DIRS = ${LOCALBASE}/lib|g' \
-e '/.*QMAKE_CXXFLAGS.*/d' \
${WRKSRC}/*.pro
+ @${FIND} ${WRKSRC} -name '*.cpp' -print0 | ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's|[io]fstream|std::&|'
post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pokerth
${INSTALL_PROGRAM} ${WRKSRC}/bin/pokerth_server ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/docs/pokerth.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
@${MKDIR} ${STAGEDIR}${DOCSDIR}