aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-11-13 18:02:04 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-11-13 18:02:04 +0800
commit3968cd426c3d6f67f084f361c8febaf1317fb817 (patch)
tree13ee11a077d5148e55eda58734b8b06373fed6c7 /games
parentd9a7bbb30202d03ee5ffc6f90a6b32c3ea6e933d (diff)
downloadfreebsd-ports-gnome-3968cd426c3d6f67f084f361c8febaf1317fb817.tar.gz
freebsd-ports-gnome-3968cd426c3d6f67f084f361c8febaf1317fb817.tar.zst
freebsd-ports-gnome-3968cd426c3d6f67f084f361c8febaf1317fb817.zip
- Update to 0.5
Diffstat (limited to 'games')
-rw-r--r--games/violetland/Makefile27
-rw-r--r--games/violetland/distinfo9
-rw-r--r--games/violetland/files/patch-CMakeLists.txt21
-rw-r--r--games/violetland/files/patch-boost-1.5241
-rw-r--r--games/violetland/pkg-plist7
5 files changed, 48 insertions, 57 deletions
diff --git a/games/violetland/Makefile b/games/violetland/Makefile
index 0e8c30738c25..73fc687aa8bb 100644
--- a/games/violetland/Makefile
+++ b/games/violetland/Makefile
@@ -2,43 +2,42 @@
# $FreeBSD$
PORTNAME= violetland
-PORTVERSION= 0.4.3
-PORTREVISION= 6
+PORTVERSION= 0.5
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Top-down survival shoot 'em up
+LICENSE= GPLv3 CC-BY-SA-3.0
+LICENSE_COMB= multi
+#LICENSE_FILE_GPLv3= "${WRKSRC}/LICENSE (code)" # framework doesn't handle these properly
+#LICENSE_FILE_CC-BY-SA-3.0= "${WRKSRC}/LICENSE (content)"
+
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs
USE_GITHUB= yes
GH_ACCOUNT= ooxi
+GH_TUPLE= jarro2783:CMake-Gettext:6ee6405:cmakegettext/lib/CMake-Gettext
-USES= cmake dos2unix gettext
+USES= cmake gettext
USE_SDL= sdl mixer image ttf
USE_GL= gl glu
-DOS2UNIX_FILES= CMakeLists.txt src/system/utility/FileUtility.cpp
-CMAKE_ARGS= -DDATA_INSTALL_DIR="${DATADIR}"
+CMAKE_ARGS= -DDATA_INSTALL_DIR="${DATADIR}" \
+ -DLOCALE_INSTALL_DIR="${PREFIX}/share/locale"
-PLIST_FILES= bin/violetland \
- share/applications/${PORTNAME}.desktop \
- share/pixmaps/${PORTNAME}.png
PORTDOCS= *
PORTDATA= *
OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} -e '/set.libList/ s|)| ${LOCALBASE}/lib/libintl.so&|' \
- ${WRKSRC}/CMakeLists.txt
-
post-install:
+ @${MKDIR} ${STAGEDIR}${DESKTOPDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
${INSTALL_DATA} ${WRKSRC}/icon-light.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} CHANGELOG README_EN.TXT README_RU.TXT \
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} CHANGELOG.md README.md README_RU.TXT \
${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/violetland/distinfo b/games/violetland/distinfo
index 0feba1029049..a5ae620ae523 100644
--- a/games/violetland/distinfo
+++ b/games/violetland/distinfo
@@ -1,2 +1,7 @@
-SHA256 (ooxi-violetland-0.4.3_GH0.tar.gz) = 678996c02ba780f6cb4199e7d85e508c6c86dd8d3793b9ff9618f1cc7c7755ad
-SIZE (ooxi-violetland-0.4.3_GH0.tar.gz) = 9257919
+TIMESTAMP = 1478881706
+SHA256 (ooxi-violetland-0.5_GH0.tar.gz) = f82c41c67515fbb34207cc34ce91a616da1bb2c8922e3dca30873478b79191cb
+SIZE (ooxi-violetland-0.5_GH0.tar.gz) = 9283612
+SHA256 (jarro2783-CMake-Gettext-6ee6405_GH0.tar.gz) = cfca4e2828d9e67c22b71e35c2a7c6fffa9452081f7602e870108f20d8d3cddd
+SIZE (jarro2783-CMake-Gettext-6ee6405_GH0.tar.gz) = 3602
+SHA256 (fcitx-fcitx-a636a83_GH0.tar.gz) = 6b496d580b08be122cea691cc4562ae88a7f8f1621e08f05d18bc104a27ab45c
+SIZE (fcitx-fcitx-a636a83_GH0.tar.gz) = 2199925
diff --git a/games/violetland/files/patch-CMakeLists.txt b/games/violetland/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..f122b853c6e7
--- /dev/null
+++ b/games/violetland/files/patch-CMakeLists.txt
@@ -0,0 +1,21 @@
+--- CMakeLists.txt.orig 2016-01-04 20:15:21 UTC
++++ CMakeLists.txt
+@@ -12,15 +12,14 @@ find_package(Boost COMPONENTS filesystem
+ add_definitions(-DBOOST_FILESYSTEM_VERSION=3)
+
+ # Searching for libintl using bundled CMake script
+-set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/lib/fcitx/cmake")
+-include(FindLibintl)
++include(FindIntl)
+
+ if(${MINGW})
+ set(LIBINTL_LIBRARIES intl)
+ endif(${MINGW})
+
+-set(incDirList ${SDL_INCLUDE_DIR} ${SDLIMAGE_INCLUDE_DIR} ${SDLTTF_INCLUDE_DIR} ${SDLMIXER_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR} ${Boost_INCLUDE_DIRS} ${LIBINTL_INCLUDE_DIR})
+-set(libList ${SDL_LIBRARY} ${SDLIMAGE_LIBRARY} ${SDLTTF_LIBRARY} ${SDLMIXER_LIBRARY} ${OPENGL_LIBRARIES} ${Boost_LIBRARIES} ${LIBINTL_LIBRARIES})
++set(incDirList ${SDL_INCLUDE_DIR} ${SDLIMAGE_INCLUDE_DIR} ${SDLTTF_INCLUDE_DIR} ${SDLMIXER_INCLUDE_DIR} ${OPENGL_INCLUDE_DIR} ${Boost_INCLUDE_DIRS} ${Intl_INCLUDE_DIR})
++set(libList ${SDL_LIBRARY} ${SDLIMAGE_LIBRARY} ${SDLTTF_LIBRARY} ${SDLMIXER_LIBRARY} ${OPENGL_LIBRARIES} ${Boost_LIBRARIES} ${Intl_LIBRARIES})
+
+ if (DEFINED LOCALE_INSTALL_DIR)
+ set(LOCALEDIR "${LOCALE_INSTALL_DIR}")
diff --git a/games/violetland/files/patch-boost-1.52 b/games/violetland/files/patch-boost-1.52
deleted file mode 100644
index c90329f43b04..000000000000
--- a/games/violetland/files/patch-boost-1.52
+++ /dev/null
@@ -1,41 +0,0 @@
---- CMakeLists.txt.old 2012-11-05 15:19:11.501044743 +0100
-+++ CMakeLists.txt 2012-11-05 15:19:25.415250207 +0100
-@@ -8,7 +8,6 @@
- find_package(SDL_mixer REQUIRED)
- find_package(OpenGL REQUIRED)
- find_package(Boost COMPONENTS filesystem system REQUIRED)
--add_definitions(-DBOOST_FILESYSTEM_VERSION=2)
-
- if(${MINGW})
- set(INTL_LIBRARY intl)
---- src/system/utility/FileUtility.cpp.old 2012-11-05 21:26:07.865488297 +0100
-+++ src/system/utility/FileUtility.cpp 2012-11-05 21:30:44.881208230 +0100
-@@ -20,7 +20,7 @@
-
- while (dir_it != boost::filesystem::directory_iterator()) {
- if (boost::filesystem::is_regular_file(*dir_it))
-- files.push_back(dir_it->filename());
-+ files.push_back(dir_it->path().filename().string());
- ++dir_it;
- }
- return files;
-@@ -32,8 +32,8 @@
-
- while (dir_it != boost::filesystem::directory_iterator()) {
- if (boost::filesystem::is_directory(*dir_it))
-- if (dir_it->path().filename()[0] != '.')
-- subDirs.push_back(dir_it->path().filename());
-+ if (dir_it->path().filename().string()[0] != '.')
-+ subDirs.push_back(dir_it->path().filename().string());
- ++dir_it;
- }
- return subDirs;
-@@ -45,7 +45,7 @@
-
- while (dir_it != boost::filesystem::directory_iterator()) {
- if (boost::filesystem::is_directory(*dir_it))
-- if (dir_it->path().filename()[0] != '.')
-+ if (dir_it->path().filename().string()[0] != '.')
- ++count;
- ++dir_it;
- }
diff --git a/games/violetland/pkg-plist b/games/violetland/pkg-plist
new file mode 100644
index 000000000000..7dd9b9386089
--- /dev/null
+++ b/games/violetland/pkg-plist
@@ -0,0 +1,7 @@
+bin/violetland
+share/applications/violetland.desktop
+share/locale/es/LC_MESSAGES/violetland.mo
+share/locale/fr/LC_MESSAGES/violetland.mo
+share/locale/gl/LC_MESSAGES/violetland.mo
+share/locale/ru/LC_MESSAGES/violetland.mo
+share/pixmaps/violetland.png