aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-02-20 08:09:17 +0800
committerjbeich <jbeich@FreeBSD.org>2018-02-20 08:09:17 +0800
commit4883bbc5dc15ce3a5070f832f1f5e683e62e6788 (patch)
treec8a154eda72f2852740913396adfc47bd86646ee /games
parent09a59806137b141c96f65307bf7dc518a56c1b14 (diff)
downloadfreebsd-ports-gnome-4883bbc5dc15ce3a5070f832f1f5e683e62e6788.tar.gz
freebsd-ports-gnome-4883bbc5dc15ce3a5070f832f1f5e683e62e6788.tar.zst
freebsd-ports-gnome-4883bbc5dc15ce3a5070f832f1f5e683e62e6788.zip
games/openbor: update to 4601
Changes: https://github.com/DCurrent/openbor/compare/35968d0...ab066c1
Diffstat (limited to 'games')
-rw-r--r--games/openbor/Makefile4
-rw-r--r--games/openbor/distinfo6
-rw-r--r--games/openbor/files/patch-source_gamelib_packfile.c8
3 files changed, 9 insertions, 9 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index a57b3382e26b..a26f25e27e05 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openbor
# Hint: svn revision is git rev-list --count ${GH_TAGNAME}
-PORTVERSION?= 4591
+PORTVERSION?= 4601
.ifndef PKGNAMESUFFIX
PORTREVISION= 0
.endif
@@ -31,7 +31,7 @@ PORTSCOUT= ignore:1
USE_GITHUB= yes
GH_ACCOUNT= DCurrent
-GH_TAGNAME?= 35968d0
+GH_TAGNAME?= ab066c1
USES+= gmake pkgconfig
.if ${PORTVERSION} < 4433
diff --git a/games/openbor/distinfo b/games/openbor/distinfo
index de42ef9186ab..7fa0dd389f73 100644
--- a/games/openbor/distinfo
+++ b/games/openbor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1518478876
-SHA256 (DCurrent-openbor-4591-35968d0_GH0.tar.gz) = d993c2e990a237427d6e58a73086c17cf8f2a0b0be40295240b53dd30594e90b
-SIZE (DCurrent-openbor-4591-35968d0_GH0.tar.gz) = 107145240
+TIMESTAMP = 1519052570
+SHA256 (DCurrent-openbor-4601-ab066c1_GH0.tar.gz) = 5ce8ce0d179d82716c5ca4ff4b0ff84a11ede9cf2cdcc62109f81a6c89a2b085
+SIZE (DCurrent-openbor-4601-ab066c1_GH0.tar.gz) = 107146373
diff --git a/games/openbor/files/patch-source_gamelib_packfile.c b/games/openbor/files/patch-source_gamelib_packfile.c
index 0faad2e22e68..0a9155dab81a 100644
--- a/games/openbor/files/patch-source_gamelib_packfile.c
+++ b/games/openbor/files/patch-source_gamelib_packfile.c
@@ -1,12 +1,12 @@
-Reset seek position for BGM with more than 64 tracks
+Reset seek position for BGM with more than 128 tracks
---- source/gamelib/packfile.c.orig 2015-04-18 21:22:03 UTC
+--- source/gamelib/packfile.c.orig 2018-02-19 15:02:50 UTC
+++ source/gamelib/packfile.c
-@@ -1399,7 +1399,7 @@ void packfile_music_read(fileliststruct
+@@ -1408,7 +1408,7 @@ void packfile_music_read(fileliststruct *filelist, int
getBasePath(packfile, filelist[i].filename, 1);
if(stristr(packfile, ".pak"))
{
-- memset(filelist[i].bgmTracks, 0, 256);
+- memset(filelist[i].bgmTracks, 0, PACKFILE_PATH_MAX);
+ memset(filelist[i].bgmTracks, 0, sizeof(filelist[i].bgmTracks));
filelist[i].nTracks = 0;
fd = fopen(packfile, "rb");