aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2004-10-06 13:10:30 +0800
committerdanfe <danfe@FreeBSD.org>2004-10-06 13:10:30 +0800
commit4c99c9408d0302eb0b3682747a41cc0a6def2f43 (patch)
treed0b7ccf4a4de57f2684388ade63b75389ee3c5ad /games
parent95e484cc4fa8961830226d640aef6feaa121d830 (diff)
downloadfreebsd-ports-gnome-4c99c9408d0302eb0b3682747a41cc0a6def2f43.tar.gz
freebsd-ports-gnome-4c99c9408d0302eb0b3682747a41cc0a6def2f43.tar.zst
freebsd-ports-gnome-4c99c9408d0302eb0b3682747a41cc0a6def2f43.zip
Sanitize C++ code a bit, and unbreak with recent GCC.
Reported by: kris Approved by: portmgr (krion), fjoe (mentor, implicit)
Diffstat (limited to 'games')
-rw-r--r--games/trophy/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/games/trophy/Makefile b/games/trophy/Makefile
index b1cc5fd8802e..f1562baa72d6 100644
--- a/games/trophy/Makefile
+++ b/games/trophy/Makefile
@@ -20,19 +20,16 @@ LIB_DEPENDS= clanCore.2:${PORTSDIR}/devel/clanlib
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
BUILD_WRKSRC= ${WRKSRC}/trophy
MAKE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LIBS=${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-extract:
@${FIND} ${BUILD_WRKSRC}/resources -name .cvsignore -exec ${RM} -f {} \;
+ @${REINPLACE_CMD} -e 's/std::sqrt/sqrt/' ${BUILD_WRKSRC}/caimagemanipulation.cpp \
+ ${BUILD_WRKSRC}/catrophy.cpp ${BUILD_WRKSRC}/camath.cpp
do-install:
${MKDIR} ${PREFIX}/bin
@@ -51,4 +48,4 @@ do-install:
${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>