aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-13 22:36:22 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-13 22:36:22 +0800
commit536b468e7276abf56d37e26983b26090cb5d0f71 (patch)
treee2515097e7bac097c589db775bae7278589413bf /games
parent287123fd5c926a351fff38c838baf930ddc4e92a (diff)
downloadfreebsd-ports-gnome-536b468e7276abf56d37e26983b26090cb5d0f71.tar.gz
freebsd-ports-gnome-536b468e7276abf56d37e26983b26090cb5d0f71.tar.zst
freebsd-ports-gnome-536b468e7276abf56d37e26983b26090cb5d0f71.zip
- Convert LIB_DEPENDS to new syntax
- Use space in WWW - Add stage support
Diffstat (limited to 'games')
-rw-r--r--games/xglk/Makefile14
-rw-r--r--games/xglk/pkg-descr2
2 files changed, 8 insertions, 8 deletions
diff --git a/games/xglk/Makefile b/games/xglk/Makefile
index 1dd128df6e39..2902437a3fb3 100644
--- a/games/xglk/Makefile
+++ b/games/xglk/Makefile
@@ -14,18 +14,18 @@ COMMENT= X Windows Implementation of the Glk API
WRKSRC= ${WRKDIR}/${PORTNAME}
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png
USE_XORG= x11
MAKE_ENV+= AR=${AR} RANLIB=${RANLIB} ECHO=${ECHO} RM=${RM}
-NO_STAGE= yes
do-install:
- ${MKDIR} ${PREFIX}/include/xglk
- ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/xglk/
- ${INSTALL_DATA} ${WRKSRC}/libxglk.a ${PREFIX}/lib/
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/Make.xglk ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/xglk
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${STAGEDIR}${PREFIX}/include/xglk/
+ ${INSTALL_DATA} ${WRKSRC}/libxglk.a ${STAGEDIR}${PREFIX}/lib/
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Make.xglk ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/games/xglk/pkg-descr b/games/xglk/pkg-descr
index 0a6e5f0d8346..f64d07840f1f 100644
--- a/games/xglk/pkg-descr
+++ b/games/xglk/pkg-descr
@@ -5,4 +5,4 @@ Glk API which this implements: version 0.6.1.
Designed by Andrew Plotkin <erkyrath@eblong.com>
http://www.eblong.com/zarf/glk/index.html
-WWW: http://www.ifarchive.org/if-archive/programming/glk/implementations/
+WWW: http://www.ifarchive.org/if-archive/programming/glk/implementations/