aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
committertijl <tijl@FreeBSD.org>2014-04-23 21:25:16 +0800
commit55e5c34e31b90aa95311b10bd4a3072f2163ebfe (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /games
parent0c15193d405451f0e1452ba981c8efb1df1447dd (diff)
downloadfreebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.gz
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.tar.zst
freebsd-ports-gnome-55e5c34e31b90aa95311b10bd4a3072f2163ebfe.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Diffstat (limited to 'games')
-rw-r--r--games/ggz-client-libs/Makefile2
-rw-r--r--games/ggz-gtk-client/Makefile2
-rw-r--r--games/libggz/Makefile2
-rw-r--r--games/pinball/Makefile4
4 files changed, 5 insertions, 5 deletions
diff --git a/games/ggz-client-libs/Makefile b/games/ggz-client-libs/Makefile
index 48e23d9f1d93..d7be68dcd45c 100644
--- a/games/ggz-client-libs/Makefile
+++ b/games/ggz-client-libs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ggz-client-libs
PORTVERSION= ${GGZ_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
diff --git a/games/ggz-gtk-client/Makefile b/games/ggz-gtk-client/Makefile
index 213db5d66825..ecd48757590c 100644
--- a/games/ggz-gtk-client/Makefile
+++ b/games/ggz-gtk-client/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ggz-gtk-client
PORTVERSION= ${GGZ_VERSION}
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
diff --git a/games/libggz/Makefile b/games/libggz/Makefile
index cc3255c1e8bc..2294e5516ab0 100644
--- a/games/libggz/Makefile
+++ b/games/libggz/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libggz
PORTVERSION= ${GGZ_VERSION}
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index 31b260fcb286..c40a4795d780 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pinball
PORTVERSION= 0.3.1
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -12,7 +12,7 @@ COMMENT= Emilia Pinball is a free pinball game
LICENSE= GPLv2
-USES= gmake libtool
+USES= gmake libtool:keepla
USE_GL= gl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes