aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-02-09 17:12:48 +0800
committerjbeich <jbeich@FreeBSD.org>2018-02-09 17:12:48 +0800
commit5af7e2ec4c5698bb7edaf8573c1b802d0292c68e (patch)
treec4bc97969afa7cc34b3f9cac4821001e3d6718f1 /games
parentbb87b278c804c69b1d617a8e56b56f270463c152 (diff)
downloadfreebsd-ports-gnome-5af7e2ec4c5698bb7edaf8573c1b802d0292c68e.tar.gz
freebsd-ports-gnome-5af7e2ec4c5698bb7edaf8573c1b802d0292c68e.tar.zst
freebsd-ports-gnome-5af7e2ec4c5698bb7edaf8573c1b802d0292c68e.zip
devel/icu: drop C++98 compatibility workarounds
Now that both USE_GCC and -CURRENT default to C++14 there's little reason to complicate maintenance. Revert r449685 to usher consumers into post-C++11 world. PR: 222433 222434 222435
Diffstat (limited to 'games')
-rw-r--r--games/openttd/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 1bd76de592f7..c1183c122c54 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openttd
DISTVERSION= 1.7.2
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://ca.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
http://cz.binaries.openttd.org/binaries/releases/${DISTVERSION}/ \
@@ -57,6 +58,8 @@ CONFIGURE_ARGS+= --enable-dedicated
CFLAGS+= -I${LOCALBASE}/include
USE_RC_SUBR= ${PORTNAME}
.else
+USES+= compiler:c++11-lib
+USE_CXXSTD= gnu++11
LIB_DEPENDS+= libfreetype.so:print/freetype2 \
libicui18n.so:devel/icu \
libicu-le-hb.so:devel/icu-le-hb \