aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2018-01-08 05:27:59 +0800
committerkrion <krion@FreeBSD.org>2018-01-08 05:27:59 +0800
commit5eb97f6d576c4c0a341f48a54a94de35f963e97b (patch)
treebddc1d6dc6d3a992340239cfc126dc7ab7449ab6 /games
parentfaa254f22fbb33a1ae5728c06f72bca9b3998fde (diff)
downloadfreebsd-ports-gnome-5eb97f6d576c4c0a341f48a54a94de35f963e97b.tar.gz
freebsd-ports-gnome-5eb97f6d576c4c0a341f48a54a94de35f963e97b.tar.zst
freebsd-ports-gnome-5eb97f6d576c4c0a341f48a54a94de35f963e97b.zip
Set LLD_UNSAFE=yes that the port will continue to link with ld.bfd
if /usr/bin/ld is lld, until the issue can be addressed. PR: 214864 Approved by: portmgr (LLD_UNSAFE blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'games')
-rw-r--r--games/OpenTomb/Makefile1
-rw-r--r--games/apricots/Makefile1
-rw-r--r--games/arx-libertatis/Makefile1
-rw-r--r--games/atr3d/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/games/OpenTomb/Makefile b/games/OpenTomb/Makefile
index 5afa9834cf5d..f0091a2b67b7 100644
--- a/games/OpenTomb/Makefile
+++ b/games/OpenTomb/Makefile
@@ -18,6 +18,7 @@ USE_GITHUB= yes
USES= cmake lua openal
USE_SDL= sdl2
+LLD_UNSAFE= yes
SUB_FILES= OpenTomb
post-patch:
diff --git a/games/apricots/Makefile b/games/apricots/Makefile
index 0c7d5f42f59f..dc177878278f 100644
--- a/games/apricots/Makefile
+++ b/games/apricots/Makefile
@@ -20,6 +20,7 @@ PLIST_FILES= bin/${PORTNAME} libexec/${PORTNAME}
PORTDATA= *
PORTDOCS= *
CPPFLAGS+= -DAP_PATH="\"${DATADIR}/\""
+LLD_UNSAFE= yes
DESKTOP_ENTRIES="Apricots" \
"${COMMENT}" \
diff --git a/games/arx-libertatis/Makefile b/games/arx-libertatis/Makefile
index 197f41799d96..fe3d6c078b86 100644
--- a/games/arx-libertatis/Makefile
+++ b/games/arx-libertatis/Makefile
@@ -20,6 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/foreach.hpp:devel/boost-libs
USES= cmake openal tar:xz
USE_SDL= sdl
USE_GL= gl glew
+LLD_UNSAFE= yes
CMAKE_ARGS= -DDATA_DIR=arx \
-DSTRICT_USE=ON
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index 40d1462dc49c..b7912918b5df 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -24,6 +24,7 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+LLD_UNSAFE= yes
OPTIONS_DEFINE= OPENAL
OPTIONS_DEFAULT=OPENAL