aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorkami <kami@FreeBSD.org>2017-01-07 02:23:11 +0800
committerkami <kami@FreeBSD.org>2017-01-07 02:23:11 +0800
commit674784e320d32052b1576df7d7ff6f0db263f39a (patch)
treed771a4ecbcdeb81cda9dd6c4212452085d43a657 /games
parentef24c91481fd33b68821fc87862a6ecdc619b8eb (diff)
downloadfreebsd-ports-gnome-674784e320d32052b1576df7d7ff6f0db263f39a.tar.gz
freebsd-ports-gnome-674784e320d32052b1576df7d7ff6f0db263f39a.tar.zst
freebsd-ports-gnome-674784e320d32052b1576df7d7ff6f0db263f39a.zip
games/ioquake3-devel: Update to snapshot 2904
- Update from 2808 to 2904 - Switch to USE_GITHUB for distifles Reviewed by: mat Approved by: mat Differential Revision: https://reviews.freebsd.org/D8695
Diffstat (limited to 'games')
-rw-r--r--games/ioquake3-devel/Makefile11
-rw-r--r--games/ioquake3-devel/distinfo5
-rw-r--r--games/ioquake3-devel/pkg-message11
-rw-r--r--games/ioquake3/Makefile13
4 files changed, 29 insertions, 11 deletions
diff --git a/games/ioquake3-devel/Makefile b/games/ioquake3-devel/Makefile
index 14540cca49d7..a793e90236db 100644
--- a/games/ioquake3-devel/Makefile
+++ b/games/ioquake3-devel/Makefile
@@ -4,9 +4,7 @@
PORTNAME?= ioquake3-devel
DISTVERSION?= GIT${GITREVISION}
PORTREVISION?= 0
-MASTER_SITES?= ftp://deponie.yamagi.org/freebsd/distfiles/ioquake3/ \
- http://deponie.yamagi.org/freebsd/distfiles/ioquake3/
-EXTRACT_SUFX?= .tar.xz
+MASTER_SITES?=
MAINTAINER?= kami@FreeBSD.org
COMMENT?= Development GIT snapshots of ioquake3
@@ -19,13 +17,18 @@ DISTINFO_FILE?= ${.CURDIR}/../${PORTNAME}/distinfo
PATCHDIR?= ${.CURDIR}/../${PORTNAME}/files
PKGMESSAGE?= ${.CURDIR}/../${PORTNAME}/pkg-message
-GITREVISION?= 2808
+GITREVISION?= 2904
BINSUFFIX?= -devel
IOQ3?= CLIENT TOOLS DLRENDERER GAMELIBS OPUS OPENGL2
IOQ3ARCH?= ${ARCH:S/i386/x86/:S/amd64/x86_64/}
IOQ3SDL?= sdl2
+USE_GITHUB= yes
+GH_ACCOUNT= lonkamikaze
+GH_PROJECT= ioq3-freebsd
+GH_TAGNAME= ${GITREVISION}
+
Q3DOCS?= README.md \
id-readme.txt \
md4-readme.txt \
diff --git a/games/ioquake3-devel/distinfo b/games/ioquake3-devel/distinfo
index a05a90764676..7d4862c9eeec 100644
--- a/games/ioquake3-devel/distinfo
+++ b/games/ioquake3-devel/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ioquake3-devel-GIT2808.tar.xz) = a9fe73c4c29e218e64d782ce8b458a93e4860e81d4c1fc08e6556cd32dfabbb2
-SIZE (ioquake3-devel-GIT2808.tar.xz) = 8166804
+TIMESTAMP = 1480690112
+SHA256 (lonkamikaze-ioq3-freebsd-GIT2904-2904_GH0.tar.gz) = 690e58065f22f01d20a87559b2550c1ab65734a7165d9b38187c2525b8c4f7b0
+SIZE (lonkamikaze-ioq3-freebsd-GIT2904-2904_GH0.tar.gz) = 11566763
diff --git a/games/ioquake3-devel/pkg-message b/games/ioquake3-devel/pkg-message
index 50e32c4d2dd4..c39c536f082a 100644
--- a/games/ioquake3-devel/pkg-message
+++ b/games/ioquake3-devel/pkg-message
@@ -1,2 +1,9 @@
-Should the game have trouble meeting com_maxfps, which would result in less
-effective strafe jumping, set com_busywait 1 to restore the old behaviour.
+The default renderer has switched to OpenGL2. Should you encounter
+a performance drop with this update, you can return to the old
+OpenGL1 rendere by executing:
+
+ ioquake3-devel +seta cl_renderer opengl1
+
+If you have chosen to build without the DLRENDERER option OpenGL1
+is used by default, OpenGL2 can be used by executing the
+`iqouake3_opengl2-devel` binary.
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index a36076bbc152..543b33a7341b 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -33,6 +33,7 @@ OPTIONS_DEFINE= SERVER CURL OPENAL MUMBLE VORBIS DEBUG
OPTIONS_DEFAULT= SERVER CURL OPENAL MUMBLE VORBIS
SERVER_DESC= Install dedicated server
MUMBLE_DESC= Enable Mumble support (no dependencies)
+USE_GL+= gl
.endif
IOQ3_OPTIONS= ${IOQ3:MTOOLS} ${IOQ3:MDLRENDERER} ${IOQ3:MGAMELIBS} \
${IOQ3:MOPUS}
@@ -74,10 +75,12 @@ Q3GAMELIBS?= cgame \
ui
Q3ICON?= ${PREFIX}/share/pixmaps/quake3.xpm
.if ${IOQ3:MOPENGL2}
-Q3RENDERER?= renderer_opengl1_${IOQ3ARCH} renderer_opengl2_${IOQ3ARCH}
+Q3RENDERER?= opengl1 opengl2
.else
-Q3RENDERER?= renderer_opengl1_${IOQ3ARCH}
+Q3RENDERER?= opengl1
.endif
+Q3RENDPREFIX?= renderer_
+Q3RENDSUFFIX?= _${IOQ3ARCH}
Q3INSTALL?=
Q3ENGINEVER?= ${DISTVERSION}
@@ -155,7 +158,11 @@ IOQ3_INST+= PROGRAM;tools/${bin};bin/${bin}${BINSUFFIX}
.endif
.if ${PORT_OPTIONS:MDLRENDERER}
. for renderer in ${Q3RENDERER}
-IOQ3_INST+= LIB;${renderer}.so;${LIBDIR}/${renderer}.so
+IOQ3_INST+= LIB;${Q3RENDPREFIX}${renderer}${Q3RENDSUFFIX}.so;${LIBDIR}/${Q3RENDPREFIX}${renderer}${Q3RENDSUFFIX}.so
+. endfor
+.else
+. for renderer in ${Q3RENDERER:Nopengl1}
+IOQ3_INST+= PROGRAM;${Q3CLIENT}_${renderer}.${IOQ3ARCH};bin/${Q3CLIENT}_${renderer}${BINSUFFIX}
. endfor
.endif
.if ${PORT_OPTIONS:MGAMELIBS}