aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-11-02 18:24:07 +0800
committermadpilot <madpilot@FreeBSD.org>2016-11-02 18:24:07 +0800
commit6b73c54443f9e56b25c77fe0f35d0d543235c067 (patch)
tree92035b7b734ef45cdba3bbe098fd6457d7620157 /games
parent24d71f3d2d394e6feb51f1fca1bb6c6af6f41d91 (diff)
downloadfreebsd-ports-gnome-6b73c54443f9e56b25c77fe0f35d0d543235c067.tar.gz
freebsd-ports-gnome-6b73c54443f9e56b25c77fe0f35d0d543235c067.tar.zst
freebsd-ports-gnome-6b73c54443f9e56b25c77fe0f35d0d543235c067.zip
- Update pioneer to 20161028
- Add NOGPUJOBS option PR: 213873 Submitted by: lightside <lightside@gmx.com>
Diffstat (limited to 'games')
-rw-r--r--games/pioneer/Makefile30
-rw-r--r--games/pioneer/distinfo5
2 files changed, 20 insertions, 15 deletions
diff --git a/games/pioneer/Makefile b/games/pioneer/Makefile
index 5761e8702979..4243112ff65d 100644
--- a/games/pioneer/Makefile
+++ b/games/pioneer/Makefile
@@ -36,7 +36,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USE_GITHUB= yes
GH_ACCOUNT= pioneerspacesim
-GH_TAGNAME= 20160610
+GH_TAGNAME= 20161028
USES= autoreconf gmake pkgconfig
USE_GL= gl
@@ -58,16 +58,19 @@ DESKTOP_ENTRIES="Pioneer" "${COMMENT}" \
"Game;Simulation;" false
SUB_FILES= pkg-message
-SUB_LIST= QUICKSTART_PATH="${QUICKSTART_PATH}"
-OPTIONS_DEFINE= DOCS MODELCOMPILER PROFILER
+OPTIONS_DEFINE= DOCS MODELCOMPILER NOGPUJOBS PROFILER
OPTIONS_DEFAULT= MODELCOMPILER
+DOCS_SUB_LIST= QUICKSTART_PATH="${DOCSDIR}"
+DOCS_SUB_LIST_OFF= \
+ QUICKSTART_PATH="https://raw.githubusercontent.com/${GH_ACCOUNT}/${GH_PROJECT}/${GH_TAGNAME}"
MODELCOMPILER_DESC= Build/install modelcompiler tool
MODELCOMPILER_PLIST_FILES= bin/${PORTNAME}-modelcompiler
+NOGPUJOBS_DESC= Disable EnableGPUJobs for config.ini by default
PROFILER_DESC= Build with internal profiler
PROFILER_CONFIGURE_ON= --enable-profiler
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000054
USE_GCC= yes
@@ -76,29 +79,30 @@ USES+= compiler:c++11-lang
CPPFLAGS+= -I${LOCALBASE}/include
.endif
-.if ${PORT_OPTIONS:MDOCS}
-QUICKSTART_PATH= ${DOCSDIR}
-.else
-QUICKSTART_PATH= \
- https://raw.githubusercontent.com/${GH_ACCOUNT}/${GH_PROJECT}/${GH_TAGNAME}
-.endif
-
post-patch: .SILENT
${REINPLACE_CMD} -e '/^OPTIMISE=/d' \
${WRKSRC}/configure.ac
${REINPLACE_CMD} -e 's/std:://g' \
${WRKSRC}/src/Orbit.cpp
${REINPLACE_CMD} -e 's/std::to_string/to_string/g' \
+ ${WRKSRC}/src/graphics/opengl/GenGasGiantColourMaterial.cpp \
${WRKSRC}/src/graphics/opengl/RendererGL.cpp
post-patch-MODELCOMPILER-off: .SILENT
${REINPLACE_CMD} -e 's/pioneer modelcompiler/pioneer/' \
${WRKSRC}/src/Makefile.am
+post-patch-NOGPUJOBS-on: .SILENT
+# Revert 41272a856d9072404efbfdb10f0e3c9e4f96bb4d commit, in case of
+# GL_OUT_OF_MEMORY OpenGL error, when turning to gas giant planet
+ ${REINPLACE_CMD} -e '/EnableGPUJobs/s|1|0|' \
+ ${WRKSRC}/src/GameConfig.cpp
+
post-patch-PROFILER-off: .SILENT
${REINPLACE_CMD} -e '/^SUBDIRS/s/ profiler//' \
${WRKSRC}/contrib/Makefile.am
- ${REINPLACE_CMD} -i '.p.bak' -e '/libjson.a/s| \\|| ; /libprofiler.a/d' \
+ ${REINPLACE_CMD} -i '.p.bak' -e \
+ '/libprofiler.a/d; $$!N; /libprofiler.a$$/s| \\||; P; D' \
${WRKSRC}/src/Makefile.am
${REINPLACE_CMD} -i '.p.bak' -e '/contrib\/profiler/d' \
${WRKSRC}/configure.ac
@@ -114,4 +118,4 @@ post-install-MODELCOMPILER-on:
${MV} ${STAGEDIR}${PREFIX}/bin/modelcompiler \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}-modelcompiler
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/pioneer/distinfo b/games/pioneer/distinfo
index ad2e8bcacd61..76ddc19ba9e1 100644
--- a/games/pioneer/distinfo
+++ b/games/pioneer/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pioneerspacesim-pioneer-0.0.20160610-20160610_GH0.tar.gz) = 3e658c2747242d2e134ece0ffe910088cb1ecc6e6fcb1b88a3bd75646bafa1c4
-SIZE (pioneerspacesim-pioneer-0.0.20160610-20160610_GH0.tar.gz) = 194457994
+TIMESTAMP = 1477647657
+SHA256 (pioneerspacesim-pioneer-0.0.20161028-20161028_GH0.tar.gz) = d8ceefc7ec22ecdbaf2408a13c80d0368675feebff558457bef2ffc7258f4b77
+SIZE (pioneerspacesim-pioneer-0.0.20161028-20161028_GH0.tar.gz) = 194439211