aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2005-10-16 17:21:59 +0800
committerehaupt <ehaupt@FreeBSD.org>2005-10-16 17:21:59 +0800
commit80f485db88e3b20914876f866e595aa06fc738c7 (patch)
treef30578b33ad285229f25f5abdd38f1cf547157ba /games
parentd5f5960d0c3a184c8ccba2afc26d079ae7f82e3b (diff)
downloadfreebsd-ports-gnome-80f485db88e3b20914876f866e595aa06fc738c7.tar.gz
freebsd-ports-gnome-80f485db88e3b20914876f866e595aa06fc738c7.tar.zst
freebsd-ports-gnome-80f485db88e3b20914876f866e595aa06fc738c7.zip
Add xmoto, a challenging 2D motocross platform game.
PR: 87143 Submitted by: Dmitry Marakasov <amdmi3@mail.ru> Approved by: novel (mentor) (implicit)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/xmoto/Makefile55
-rw-r--r--games/xmoto/distinfo2
-rw-r--r--games/xmoto/files/patch-Makefile.in13
-rw-r--r--games/xmoto/files/patch-configure20
-rw-r--r--games/xmoto/pkg-descr7
-rw-r--r--games/xmoto/pkg-plist8
7 files changed, 106 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 0825caee704c..6a0aa8cdf3ac 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -680,6 +680,7 @@
SUBDIR += xminesweep
SUBDIR += xmj
SUBDIR += xmlink
+ SUBDIR += xmoto
SUBDIR += xmris
SUBDIR += xmulti
SUBDIR += xneko
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
new file mode 100644
index 000000000000..6e7f76b58bbd
--- /dev/null
+++ b/games/xmoto/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: xmoto
+# Date created: 07 Oct 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmoto
+PORTVERSION= 0.1.6
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Challenging 2D motocross platform game
+
+LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
+ png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GL= yes
+USE_REINPLACE= yes
+USE_SDL= sdl
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ SDL_CONFIG="${SDL_CONFIG}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PORTDOCS= README ChangeLog
+
+# game is still in alpha state, other archs are untested
+ONLY_FOR_ARCHS= i386
+
+post-patch:
+ @${FIND} ${WRKSRC}/src -name "*.cpp" -o -name "*.h" | \
+ ${XARGS} ${REINPLACE_CMD} -e "s|$$(${PRINTF} '\r')||g"
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/src/VCommon.h
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/ode/config.h \
+ ${WRKSRC}/src/image/tim_memory_crt.cpp
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/xmoto/distinfo b/games/xmoto/distinfo
new file mode 100644
index 000000000000..bbb4d3f6a7d8
--- /dev/null
+++ b/games/xmoto/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmoto-0.1.6-src.tar.gz) = b5d11e0f90ab5ff886c1dc90fa15cb2e
+SIZE (xmoto-0.1.6-src.tar.gz) = 2780752
diff --git a/games/xmoto/files/patch-Makefile.in b/games/xmoto/files/patch-Makefile.in
new file mode 100644
index 000000000000..d739d2ee4394
--- /dev/null
+++ b/games/xmoto/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in.orig Thu Oct 6 19:21:49 2005
++++ Makefile.in Fri Oct 7 18:25:32 2005
+@@ -76,8 +76,8 @@
+ am__quote = @am__quote@
+ install_sh = @install_sh@
+ INCLUDES = -Isrc
+-CXXFLAGS = -w -O3 -DGAMEDATADIR=\"$(datadir)/@PACKAGE@\"
+-CFLAGS = -w -O3 -DGAMEDATADIR=\"$(datadir)/@PACKAGE@\"
++CXXFLAGS = @CXXFLAGS@ -DGAMEDATADIR=\"$(datadir)/@PACKAGE@\"
++CFLAGS = @CFLAGS@ -DGAMEDATADIR=\"$(datadir)/@PACKAGE@\"
+ SUBDIRS = bin
+
+ image_SOURCES = src/image/tim.cpp src/image/tim_io_stdio.cpp \
diff --git a/games/xmoto/files/patch-configure b/games/xmoto/files/patch-configure
new file mode 100644
index 000000000000..23ee491762f2
--- /dev/null
+++ b/games/xmoto/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Thu Oct 6 19:21:49 2005
++++ configure Fri Oct 7 04:53:57 2005
+@@ -3377,7 +3377,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lSDL $LIBS"
++LIBS="`$SDL_CONFIG --libs` $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -3439,7 +3439,7 @@
+ #define HAVE_LIBSDL 1
+ _ACEOF
+
+- LIBS="-lSDL $LIBS"
++ LIBS="`$SDL_CONFIG --libs` $LIBS"
+
+ else
+
diff --git a/games/xmoto/pkg-descr b/games/xmoto/pkg-descr
new file mode 100644
index 000000000000..6c5cb0f5a7af
--- /dev/null
+++ b/games/xmoto/pkg-descr
@@ -0,0 +1,7 @@
+X-Moto is a challenging 2D motocross platform game, where physics play an all
+important role in the gameplay. You need to control your bike to its limit, if
+you want to have a chance finishing the more difficult of the challenges.
+
+WWW: http://xmoto.sourceforge.net/
+
+- Dmitry Marakasov <amdmi3@mail.ru>
diff --git a/games/xmoto/pkg-plist b/games/xmoto/pkg-plist
new file mode 100644
index 000000000000..3a5274b81807
--- /dev/null
+++ b/games/xmoto/pkg-plist
@@ -0,0 +1,8 @@
+bin/xmoto
+bin/xmoto-edit
+%%DATADIR%%/anims.dat
+%%DATADIR%%/sprites.dat
+%%DATADIR%%/editor.dat
+%%DATADIR%%/fonts.dat
+%%DATADIR%%/xmoto.bin
+@dirrm %%DATADIR%%