aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-02-21 16:03:18 +0800
committeryuri <yuri@FreeBSD.org>2018-02-21 16:03:18 +0800
commit8a28aa1310bf9ba44065e4f6b7d0a7d3e86d8387 (patch)
tree4ba66ed981114ceaeb430e3e9bd58e4b2553db3b /games
parent0728cb273cb492414ea1e109e6546e2631ea945d (diff)
downloadfreebsd-ports-gnome-8a28aa1310bf9ba44065e4f6b7d0a7d3e86d8387.tar.gz
freebsd-ports-gnome-8a28aa1310bf9ba44065e4f6b7d0a7d3e86d8387.tar.zst
freebsd-ports-gnome-8a28aa1310bf9ba44065e4f6b7d0a7d3e86d8387.zip
New port: games/bstone: Source port of Blake Stone
PR: 226047 Submitted by: devel@stasyan.com Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D14441
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/bstone/Makefile34
-rw-r--r--games/bstone/distinfo3
-rw-r--r--games/bstone/pkg-descr18
4 files changed, 56 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index a57f57932e22..71875a7ac35f 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -125,6 +125,7 @@
SUBDIR += bsdrain
SUBDIR += bsdtris
SUBDIR += bsp
+ SUBDIR += bstone
SUBDIR += bubble-chains
SUBDIR += bubbros
SUBDIR += bugsquish
diff --git a/games/bstone/Makefile b/games/bstone/Makefile
new file mode 100644
index 000000000000..beb496428b88
--- /dev/null
+++ b/games/bstone/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= bstone
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.9
+CATEGORIES= games
+
+MAINTAINER= devel@stasyan.com
+COMMENT= Source port of Blake Stone
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+USES= cmake:outsource compiler:c++11-lang localbase:ldflags pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= bibendovsky
+USE_SDL= sdl2
+WRKSRC_SUBDIR= src
+
+PLIST_FILES= bin/bstone
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/bstone ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../CHANGELOG.md ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/games/bstone/distinfo b/games/bstone/distinfo
new file mode 100644
index 000000000000..0851f673c707
--- /dev/null
+++ b/games/bstone/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1519069215
+SHA256 (bibendovsky-bstone-v1.1.9_GH0.tar.gz) = 9298fd2e47aa438bc1eeb84d4152436b12ecfef131a161e6aa1607956ac2fae9
+SIZE (bibendovsky-bstone-v1.1.9_GH0.tar.gz) = 533800
diff --git a/games/bstone/pkg-descr b/games/bstone/pkg-descr
new file mode 100644
index 000000000000..61b8fc0c7c61
--- /dev/null
+++ b/games/bstone/pkg-descr
@@ -0,0 +1,18 @@
+A source port of game Blake Stone: Aliens of Gold and Blake Stone: Planet Strike
+
+Features:
+* High resolution rendering of world (extended vanilla engine)
+* Modern and vanilla controls
+* Allows to customize control bindings
+* Separate volume control of sound effects and music
+
+Supported games:
+* Aliens of Gold v1.0 full
+* Aliens of Gold v2.0 full
+* Aliens of Gold v2.1 full
+* Aliens of Gold v3.0 full
+* Aliens of Gold v3.0 shareware
+* Planet Strike v1.0
+* Planet Strike v1.1
+
+WWW: https://github.com/bibendovsky/bstone