aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-12-24 08:06:00 +0800
committerjbeich <jbeich@FreeBSD.org>2016-12-24 08:06:00 +0800
commit8b105c5e1f79b7936ad3799df095facd30a7aa0e (patch)
tree6192fd56ce5fd333aea441eb36dbd4390eefd2b8 /games
parentc65d14774eb3c0df1797852c8a066bb4c556f3e0 (diff)
downloadfreebsd-ports-gnome-8b105c5e1f79b7936ad3799df095facd30a7aa0e.tar.gz
freebsd-ports-gnome-8b105c5e1f79b7936ad3799df095facd30a7aa0e.tar.zst
freebsd-ports-gnome-8b105c5e1f79b7936ad3799df095facd30a7aa0e.zip
games/openbor: unbreak on DragonFly after r428004
In file included from source/webmlib/halloc/halloc.c:20:0: source/webmlib/halloc/align.h:42:25: error: conflicting types for 'max_align_t' typedef union max_align max_align_t; ^ In file included from source/webmlib/halloc/halloc.h:18:0, from source/webmlib/halloc/halloc.c:19: /usr/include/stddef.h:74:3: note: previous declaration of 'max_align_t' was here } max_align_t; ^
Diffstat (limited to 'games')
-rw-r--r--games/openbor/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/openbor/Makefile b/games/openbor/Makefile
index 20d0446a76c3..046f2c614a06 100644
--- a/games/openbor/Makefile
+++ b/games/openbor/Makefile
@@ -21,7 +21,8 @@ MAKE_ENV= BUILD_LINUX=1 SDKPATH="${LOCALBASE}" \
MAKE_ARGS= CC="${CC}" LIBRARIES="${LOCALBASE}/lib" \
TARGET_ARCH=${ARCH:S/i386/x86/} ARCHFLAGS="" \
TARGET_FINAL='${TARGET}' BUILD_MMX=""
-CFLAGS+= -fgnu89-inline
+CFLAGS+= -fgnu89-inline ${CFLAGS_${OPSYS}}
+CFLAGS_DragonFly= -D_GCC_MAX_ALIGN_T # system stddef.h
LDFLAGS+= -Wl,--as-needed # ogg, pthread, zlib
PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png