aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-05-12 02:05:18 +0800
committeralepulver <alepulver@FreeBSD.org>2006-05-12 02:05:18 +0800
commita05fcf80b5e969573d1d5596473dc5b72630df02 (patch)
tree0c28bcb769170838bc9ff9f1e1d4395361128aa4 /games
parented432972b0cf096991713ed915242d39d9f9d74a (diff)
downloadfreebsd-ports-gnome-a05fcf80b5e969573d1d5596473dc5b72630df02.tar.gz
freebsd-ports-gnome-a05fcf80b5e969573d1d5596473dc5b72630df02.tar.zst
freebsd-ports-gnome-a05fcf80b5e969573d1d5596473dc5b72630df02.zip
ET Pub - An Enemy Territory Modification.
Goals of ET Pub: * Be configuration compatible with shrubet (cvars AND shrubbot.cfg). * Match useful shrub features (e.g. Play Dead, Corpse Dragging, etc.). * Fix bugs. * Add features to try to imporve gameplay on public servers. (e.g. Active Team Balance). WWW: http://et.tjw.org/etpub/ WWW: http://www.etpub.org/ PR: ports/93543 Approved by: garga (mentor)
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/linux-enemyterritory-etpub/Makefile61
-rw-r--r--games/linux-enemyterritory-etpub/distinfo6
-rw-r--r--games/linux-enemyterritory-etpub/pkg-descr12
-rw-r--r--games/linux-enemyterritory-etpub/pkg-plist40
5 files changed, 120 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index bf8c8012fd26..59bfb3992f25 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -360,6 +360,7 @@
SUBDIR += linux-doom3-demo
SUBDIR += linux-enemyterritory
SUBDIR += linux-enemyterritory-etpro
+ SUBDIR += linux-enemyterritory-etpub
SUBDIR += linux-enemyterritory-fortress
SUBDIR += linux-enemyterritory-tce
SUBDIR += linux-goodway
diff --git a/games/linux-enemyterritory-etpub/Makefile b/games/linux-enemyterritory-etpub/Makefile
new file mode 100644
index 000000000000..a5619c6d8720
--- /dev/null
+++ b/games/linux-enemyterritory-etpub/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: etpub
+# Date created: 7 May 2006
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= etpub
+PORTVERSION= 0.6.5
+CATEGORIES= games linux
+MASTER_SITES= http://et.tjw.org/etpub/dist/
+PKGNAMEPREFIX= linux-enemyterritory-
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${CLIENT_PK3}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= ET Pub - An Enemy Territory Modification
+
+RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_ZIP= yes
+USE_LINUX= yes
+
+DATADIR= ${PREFIX}/lib/enemyterritory/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}
+
+CLIENT_PK3= ${PORTNAME}_client-20060310.pk3
+PLIST_SUB= CLIENT_PK3="${CLIENT_PK3}"
+
+pre-patch:
+ @${FIND} ${WRKSRC} -type f -exec ${SH} -c \
+ '${FILE} "$$0" | ${GREP} -q text && \
+ ${REINPLACE_CMD} -i "" -e "s/ $$//" "$$0"' {} \;
+
+do-build:
+.for f in et etded
+ @(${ECHO} "#!/bin/sh"; \
+ ${ECHO} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} "$$@"') > \
+ ${WRKSRC}/${f}-${PORTNAME}
+.endfor
+
+do-install:
+.for f in et etded
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/glibc-2.1/qagame.mp.i386.so ${DATADIR}
+ ${INSTALL_DATA} ${DISTDIR}/${CLIENT_PK3} ${DATADIR}
+ ${CP} -R ${WRKSRC}/extra ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ChangeLog.txt Install.txt Upgrade-0.6.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+ ${CP} -R ${WRKSRC}/docs ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/linux-enemyterritory-etpub/distinfo b/games/linux-enemyterritory-etpub/distinfo
new file mode 100644
index 000000000000..724603c08bb2
--- /dev/null
+++ b/games/linux-enemyterritory-etpub/distinfo
@@ -0,0 +1,6 @@
+MD5 (etpub-0.6.5.zip) = 96bddd85cdafa35e082c5c957246e7b0
+SHA256 (etpub-0.6.5.zip) = d7bc2b09fa1460745836c4733a0cc31c41e4039f262a86b20732d7ff0da7ac70
+SIZE (etpub-0.6.5.zip) = 2063391
+MD5 (etpub_client-20060310.pk3) = 0dc65b79aa84b8d754349a6cc886be8f
+SHA256 (etpub_client-20060310.pk3) = 5585522ba13541f8c54ef3d7c2aea49f433b462292fed104a8e0dbfc1b67a9e4
+SIZE (etpub_client-20060310.pk3) = 2083255
diff --git a/games/linux-enemyterritory-etpub/pkg-descr b/games/linux-enemyterritory-etpub/pkg-descr
new file mode 100644
index 000000000000..785dc5854379
--- /dev/null
+++ b/games/linux-enemyterritory-etpub/pkg-descr
@@ -0,0 +1,12 @@
+ET Pub - An Enemy Territory Modification.
+
+Goals of ET Pub:
+
+* Be configuration compatible with shrubet (cvars AND shrubbot.cfg).
+* Match useful shrub features (e.g. Play Dead, Corpse Dragging, etc.).
+* Fix bugs.
+* Add features to try to imporve gameplay on public servers. (e.g. Active
+ Team Balance).
+
+WWW: http://et.tjw.org/etpub/
+WWW: http://www.etpub.org/
diff --git a/games/linux-enemyterritory-etpub/pkg-plist b/games/linux-enemyterritory-etpub/pkg-plist
new file mode 100644
index 000000000000..56340bfdc43d
--- /dev/null
+++ b/games/linux-enemyterritory-etpub/pkg-plist
@@ -0,0 +1,40 @@
+bin/et-etpub
+bin/etded-etpub
+%%DATADIR%%/%%CLIENT_PK3%%
+%%DATADIR%%/extra/PHP/xpsave/README.txt
+%%DATADIR%%/extra/PHP/xpsave/xpsave.php
+%%DATADIR%%/extra/PHP/xpsave/xpsave_table.php
+%%DATADIR%%/extra/paks/hiddenvo/README.txt
+%%DATADIR%%/extra/paks/hiddenvo/hiddenvo.pk3
+%%DATADIR%%/qagame.mp.i386.so
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.txt
+%%PORTDOCS%%%%DOCSDIR%%/Install.txt
+%%PORTDOCS%%%%DOCSDIR%%/Upgrade-0.6.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/Example/Commented/default.cfg
+%%PORTDOCS%%%%DOCSDIR%%/docs/Example/Commented/server.cfg
+%%PORTDOCS%%%%DOCSDIR%%/docs/Example/Commented/shrubbot.cfg
+%%PORTDOCS%%%%DOCSDIR%%/docs/Example/NoComments/default.cfg
+%%PORTDOCS%%%%DOCSDIR%%/docs/Example/NoComments/server.cfg
+%%PORTDOCS%%%%DOCSDIR%%/docs/Example/NoComments/shrubbot.cfg
+%%PORTDOCS%%%%DOCSDIR%%/docs/Example/mapscripts/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/Example/mapscripts/stalingrad.script
+%%PORTDOCS%%%%DOCSDIR%%/docs/index.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/index_de.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/index_fr.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/index_pub.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/index_pub_de.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/index_pub_fr.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/obituaries.html
+%%PORTDOCS%%%%DOCSDIR%%/docs/obituaries_fr.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/Example/mapscripts
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/Example/NoComments
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/Example/Commented
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs/Example
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/extra/paks/hiddenvo
+@dirrm %%DATADIR%%/extra/paks
+@dirrm %%DATADIR%%/extra/PHP/xpsave
+@dirrm %%DATADIR%%/extra/PHP
+@dirrm %%DATADIR%%/extra
+@dirrm %%DATADIR%%