aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-14 04:03:03 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-14 04:03:03 +0800
commitaf622dcd3026f256a2360d40cc343adbe98cc784 (patch)
treecc0ba9cf077b500c7519beef11dec392c704d4b5 /games
parentf7c045f652c787f9a04ce3cd442e1fecb30ed2ce (diff)
downloadfreebsd-ports-gnome-af622dcd3026f256a2360d40cc343adbe98cc784.tar.gz
freebsd-ports-gnome-af622dcd3026f256a2360d40cc343adbe98cc784.tar.zst
freebsd-ports-gnome-af622dcd3026f256a2360d40cc343adbe98cc784.zip
- Add stage support
- Use PLIST_FILES instead of pkg-plist file
Diffstat (limited to 'games')
-rw-r--r--games/xmball/Makefile14
-rw-r--r--games/xmball/pkg-plist2
2 files changed, 7 insertions, 9 deletions
diff --git a/games/xmball/Makefile b/games/xmball/Makefile
index f9ccbcf46e6a..39ff0c57c17d 100644
--- a/games/xmball/Makefile
+++ b/games/xmball/Makefile
@@ -14,14 +14,14 @@ COMMENT= Masterball puzzle for X Window System
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= imake
USE_XORG= x11 xext xt sm ice
-MAN1= xmball.1
-MANCOMPRESSED= no
-XFREE86_HTML_MAN= no
-NO_STAGE= yes
+PLIST_FILES= bin/xmball \
+ man/man1/xmball.1.gz \
+ lib/X11/app-defaults/Mball
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/xmball ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/Mball.ad ${PREFIX}/lib/X11/app-defaults/Mball
- ${INSTALL_MAN} ${WRKSRC}/xmball.man ${MANPREFIX}/man/man1/xmball.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmball ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/Mball.ad ${STAGEDIR}${PREFIX}/lib/X11/app-defaults/Mball
+ ${INSTALL_MAN} ${WRKSRC}/xmball.man ${STAGEDIR}${MANPREFIX}/man/man1/xmball.1
.include <bsd.port.mk>
diff --git a/games/xmball/pkg-plist b/games/xmball/pkg-plist
deleted file mode 100644
index 364367c69580..000000000000
--- a/games/xmball/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/xmball
-lib/X11/app-defaults/Mball