aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-04-03 20:00:26 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-04-03 20:00:26 +0800
commitb6c384c25ea6aa77b3c72ff2d918b70335bb170e (patch)
tree45bafdcfc8f8cc161f34a10c2cd45907671a9dd9 /games
parentba73dd9abcf3a97334cbdd70d10a24032053a152 (diff)
downloadfreebsd-ports-gnome-b6c384c25ea6aa77b3c72ff2d918b70335bb170e.tar.gz
freebsd-ports-gnome-b6c384c25ea6aa77b3c72ff2d918b70335bb170e.tar.zst
freebsd-ports-gnome-b6c384c25ea6aa77b3c72ff2d918b70335bb170e.zip
- Switch profiler which depends on x86 assembly off by default, fixing build on arm
PR: 207559 Submitted by: lightside@gmx.coma (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/pioneer/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/games/pioneer/Makefile b/games/pioneer/Makefile
index 689a8d9339cd..92e22fb8ca5e 100644
--- a/games/pioneer/Makefile
+++ b/games/pioneer/Makefile
@@ -63,10 +63,12 @@ DESKTOP_ENTRIES="Pioneer" "${COMMENT}" \
SUB_FILES= pkg-message
SUB_LIST= QUICKSTART_PATH="${QUICKSTART_PATH}"
-OPTIONS_DEFINE= DOCS MODELCOMPILER
+OPTIONS_DEFINE= DOCS MODELCOMPILER PROFILER
OPTIONS_DEFAULT= MODELCOMPILER
MODELCOMPILER_DESC= Build/install modelcompiler tool
MODELCOMPILER_PLIST_FILES= bin/${PORTNAME}-modelcompiler
+PROFILER_DESC= Build with internal profiler
+PROFILER_CONFIGURE_ON= --enable-profiler
.include <bsd.port.options.mk>
@@ -94,6 +96,14 @@ post-patch-MODELCOMPILER-off: .SILENT
${REINPLACE_CMD} -e 's/pioneer modelcompiler/pioneer/' \
${WRKSRC}/src/Makefile.am
+post-patch-PROFILER-off: .SILENT
+ ${REINPLACE_CMD} -e '/^SUBDIRS/s/ profiler//' \
+ ${WRKSRC}/contrib/Makefile.am
+ ${REINPLACE_CMD} -i '.p.bak' -e '/libjson.a/s| \\|| ; /libprofiler.a/d' \
+ ${WRKSRC}/src/Makefile.am
+ ${REINPLACE_CMD} -i '.p.bak' -e '/contrib\/profiler/d' \
+ ${WRKSRC}/configure.ac
+
post-install:
(cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
${INSTALL_DATA} ${WRKSRC}/application-icon/pngs/pioneer-256x256.png \