aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-09-15 04:46:48 +0800
committermakc <makc@FreeBSD.org>2010-09-15 04:46:48 +0800
commitb8693a4ce01ad29fc0969c426b6c1090de06699a (patch)
treef813b5928d034952bd76d4ad9f83b7acdfd51ed2 /games
parent6ab3cc44cd0b53e96613ce278d397b01cd5d5df7 (diff)
downloadfreebsd-ports-gnome-b8693a4ce01ad29fc0969c426b6c1090de06699a.tar.gz
freebsd-ports-gnome-b8693a4ce01ad29fc0969c426b6c1090de06699a.tar.zst
freebsd-ports-gnome-b8693a4ce01ad29fc0969c426b6c1090de06699a.zip
Add new port games/openpref:
OpenPref is an open source implementation of European trick-taking game Preferans (also known as Preference). It is written using cross-platform Qt4 framework and is portable between many operating systems including Windows and major Unix flavours. WWW: http://openpref.sourceforge.net PR: based on ports/150509 Submitted by: Konstantin Tokarev <annulen at yandex.ru>
Diffstat (limited to 'games')
-rw-r--r--games/openpref/Makefile33
-rw-r--r--games/openpref/distinfo3
-rw-r--r--games/openpref/pkg-descr6
-rw-r--r--games/openpref/pkg-plist5
4 files changed, 47 insertions, 0 deletions
diff --git a/games/openpref/Makefile b/games/openpref/Makefile
new file mode 100644
index 000000000000..cbab677e0cd4
--- /dev/null
+++ b/games/openpref/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: openpref
+# Date created: 2010-09-12
+# Whom: Konstantin Tokarev <annulen@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openpref
+PORTVERSION= 0.1.3
+CATEGORIES= games
+MASTER_SITES= SF/${PORTNAME}/OpenPref-Qt4/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= annulen@yandex.ru
+COMMENT= Preferans game
+
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui qmake_build moc_build rcc_build uic_build
+HAS_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
+
+DESKTOP_ENTRIES="OpenPref" "${COMMENT}" "${DATADIR}/openpref.png" \
+ "openpref" "Game;CardGame;" false
+
+do-configure:
+ @(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS} )
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/openpref ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}/i18n
+ ${INSTALL_DATA} ${WRKSRC}/openpref_ru.qm ${DATADIR}/i18n
+ ${INSTALL_DATA} ${WRKSRC}/pics/openpref.png ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/openpref/distinfo b/games/openpref/distinfo
new file mode 100644
index 000000000000..753d4f006212
--- /dev/null
+++ b/games/openpref/distinfo
@@ -0,0 +1,3 @@
+MD5 (openpref-0.1.3.tar.gz) = 7b51607c2145f0063f405e159c6410bf
+SHA256 (openpref-0.1.3.tar.gz) = ee4d5c3ec6774a5baa25be04f411e3c4187d4326066c4cb2affdec40427815d3
+SIZE (openpref-0.1.3.tar.gz) = 191824
diff --git a/games/openpref/pkg-descr b/games/openpref/pkg-descr
new file mode 100644
index 000000000000..c7b2799d2382
--- /dev/null
+++ b/games/openpref/pkg-descr
@@ -0,0 +1,6 @@
+OpenPref is an open source implementation of European trick-taking game
+Preferans (also known as Preference). It is written using cross-platform
+Qt4 framework and is portable between many operating systems including
+Windows and major Unix flavours.
+
+WWW: http://openpref.sourceforge.net
diff --git a/games/openpref/pkg-plist b/games/openpref/pkg-plist
new file mode 100644
index 000000000000..59f6143a9711
--- /dev/null
+++ b/games/openpref/pkg-plist
@@ -0,0 +1,5 @@
+bin/openpref
+%%DATADIR%%/openpref.png
+%%DATADIR%%/i18n/openpref_ru.qm
+@dirrm %%DATADIR%%/i18n
+@dirrm %%DATADIR%%