aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-09-30 19:18:08 +0800
committermiwi <miwi@FreeBSD.org>2006-09-30 19:18:08 +0800
commitc61b48d5a9c8b3536a01d24fb9f6e80a2452ce77 (patch)
treef7dbc3d4d773254ac3a13bf8d157a16b60bc427f /games
parenta02a01250ab23d22f995d528f205ee8291a72c2d (diff)
downloadfreebsd-ports-gnome-c61b48d5a9c8b3536a01d24fb9f6e80a2452ce77.tar.gz
freebsd-ports-gnome-c61b48d5a9c8b3536a01d24fb9f6e80a2452ce77.tar.zst
freebsd-ports-gnome-c61b48d5a9c8b3536a01d24fb9f6e80a2452ce77.zip
- Fix build with gcc4.1
PR: ports/103818 Submitted by: Dmitry Marakasov <amdmi3(at)mail.ru> (maintainer)
Diffstat (limited to 'games')
-rw-r--r--games/stroq/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/stroq/Makefile b/games/stroq/Makefile
index c374e5e37d1a..5a1af05e62a3 100644
--- a/games/stroq/Makefile
+++ b/games/stroq/Makefile
@@ -25,9 +25,15 @@ QMAKESPEC= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
+BROKEN= Does not compile on FreeBSD 4.x
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|PlaySquare::||' ${WRKSRC}/playsquare.h
+ ${REINPLACE_CMD} -e 's|Puzzle::||' ${WRKSRC}/puzzle.h
+ ${REINPLACE_CMD} -e 's|Square::||' ${WRKSRC}/square.h
+ ${REINPLACE_CMD} -e 's|SelectPuzzleDialog::||' ${WRKSRC}/selectpuzzledialog.h
+
do-configure:
@cd ${WRKSRC}; \
${SETENV} ${MAKE_ENV} ${QMAKE} -project; \