aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-11-03 06:45:14 +0800
committermat <mat@FreeBSD.org>2016-11-03 06:45:14 +0800
commitd9ec328e16b795889ee8d72196228f00a0a3393a (patch)
treeadf234bd1f2e56ae130e9960e1467b64c9fa0ed6 /games
parent759b32261f3c119f1062868d580795d19060e71b (diff)
downloadfreebsd-ports-gnome-d9ec328e16b795889ee8d72196228f00a0a3393a.tar.gz
freebsd-ports-gnome-d9ec328e16b795889ee8d72196228f00a0a3393a.tar.zst
freebsd-ports-gnome-d9ec328e16b795889ee8d72196228f00a0a3393a.zip
Cleanup no longer needed CHMOD usage after r424898.
PR: 213743 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight
Diffstat (limited to 'games')
-rw-r--r--games/alephone-scenarios/Makefile2
-rw-r--r--games/duel/Makefile4
-rw-r--r--games/ember/Makefile6
-rw-r--r--games/linux-nwnclient/Makefile5
-rw-r--r--games/ptkei/Makefile2
-rw-r--r--games/quake-dpmod/Makefile2
-rw-r--r--games/rocksndiamonds-data/Makefile2
-rw-r--r--games/tuxpaint-config/Makefile3
-rw-r--r--games/tuxpaint/Makefile1
-rw-r--r--games/xtet42/Makefile3
10 files changed, 5 insertions, 25 deletions
diff --git a/games/alephone-scenarios/Makefile b/games/alephone-scenarios/Makefile
index 0752bf5bcdb0..7905c76f8b20 100644
--- a/games/alephone-scenarios/Makefile
+++ b/games/alephone-scenarios/Makefile
@@ -142,8 +142,6 @@ pre-install:
.for f in ${AO_PACKS}
@cd ${WRKDIR} && ${SED} -e 's|%%GAMEDIR%%|${f}|' wrapper > alephone-${f}
.endfor
- @cd ${WRKSRC} && \
- ${FIND} . -type d -print0 | ${XARGS} -0 ${CHMOD} 755
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/games/duel/Makefile b/games/duel/Makefile
index d94d2eac269b..6d236825a1c3 100644
--- a/games/duel/Makefile
+++ b/games/duel/Makefile
@@ -31,8 +31,6 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/libexec
@${MKDIR} ${STAGEDIR}${DATADIR}
- ${CP} -R ${WRKSRC}/runDir/* ${STAGEDIR}${DATADIR}
- ${FIND} ${STAGEDIR}${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
- ${FIND} ${STAGEDIR}${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
+ cd ${WRKSRC}/runDir && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/games/ember/Makefile b/games/ember/Makefile
index 068336049891..26df690801f6 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -53,10 +53,8 @@ post-patch:
${WRKSRC}/src/components/ogre/terrain/HeightMap.cpp
post-install:
- (cd ${WRKDIR}/ember-media-${PORTVERSION}/media && ${FIND} . -type f -print | \
- ${CPIO} -pdmu -R${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR}/media)
- ${FIND} ${STAGEDIR}${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 0755
- ${FIND} ${STAGEDIR}${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 0644
+ (cd ${WRKDIR}/ember-media-${PORTVERSION}/media && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/media)
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/games/linux-nwnclient/Makefile b/games/linux-nwnclient/Makefile
index 031f849ef549..31be7ee0ddf5 100644
--- a/games/linux-nwnclient/Makefile
+++ b/games/linux-nwnclient/Makefile
@@ -89,10 +89,7 @@ do-configure:
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
- (cd ${WRKSRC} && ${FIND} . -print | \
- ${CPIO} -pdmuv -R${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DATADIR})
- ${FIND} ${STAGEDIR}${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 0755
- ${FIND} ${STAGEDIR}${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 0644
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
(cd ${STAGEDIR}${DATADIR} && ${CHMOD} 0755 dmclient nwmain nwserver)
.if defined(BINKPLAYERFILE)
(cd ${STAGEDIR}${DATADIR} && ${CHMOD} 0755 nwmovies/BinkPlayer)
diff --git a/games/ptkei/Makefile b/games/ptkei/Makefile
index 97044cc64fe4..d171bf7e7a25 100644
--- a/games/ptkei/Makefile
+++ b/games/ptkei/Makefile
@@ -16,8 +16,6 @@ USES= python
do-build:
@${FIND} ${WRKSRC} -name "*.pyc" -delete
- @${FIND} ${WRKSRC} \( -type f -or -type l \) | ${XARGS} ${CHMOD} 644
- @${FIND} ${WRKSRC} -type d | ${XARGS} ${CHMOD} 755
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC} 2>/dev/null
do-install:
diff --git a/games/quake-dpmod/Makefile b/games/quake-dpmod/Makefile
index 2bae302b2f86..be466d0dc690 100644
--- a/games/quake-dpmod/Makefile
+++ b/games/quake-dpmod/Makefile
@@ -23,8 +23,6 @@ DATADIR= ${Q1DIR}/${PORTNAME}
post-extract:
# Remove CVS directories
@${FIND} ${WRKSRC} -type d -name CVS -print0 | ${XARGS} -0 ${RM} -r
-# Fix permissions
- @${CHMOD} go-w ${WRKSRC}/dpmod/progs.dat
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/games/rocksndiamonds-data/Makefile b/games/rocksndiamonds-data/Makefile
index 5035ed8c8dbc..5aec55303259 100644
--- a/games/rocksndiamonds-data/Makefile
+++ b/games/rocksndiamonds-data/Makefile
@@ -91,7 +91,7 @@ post-extract-script:
.for l in DX_Boulderdash Supaplex
@${FIND} ${WRKDIR}/${PORTNAME}/${l} -name '*.level' | ${XARGS} \
- ${CHMOD} 644
+ ${CHMOD} go-w
.endfor
.for l in ${LEVELS_BD_FANS:S/$/.zip/} Alans_Random_Levels.zip \
diff --git a/games/tuxpaint-config/Makefile b/games/tuxpaint-config/Makefile
index 7230ab5bfed1..45dcb687ca36 100644
--- a/games/tuxpaint-config/Makefile
+++ b/games/tuxpaint-config/Makefile
@@ -31,7 +31,4 @@ LDFLAGS+= -L${LOCALBASE}/lib -lintl
OPTIONS_DEFINE= DOCS
-post-extract:
- @${CHMOD} -R a+rX ${WRKSRC}
-
.include <bsd.port.mk>
diff --git a/games/tuxpaint/Makefile b/games/tuxpaint/Makefile
index b402e45816fa..4a1442baf323 100644
--- a/games/tuxpaint/Makefile
+++ b/games/tuxpaint/Makefile
@@ -46,7 +46,6 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS
post-extract:
- @${CHMOD} -R a+rX ${WRKSRC}
@${RM} -r ${WRKSRC}/fonts/locale/vi_docs
post-patch:
diff --git a/games/xtet42/Makefile b/games/xtet42/Makefile
index ff4974901651..4de1af7808a4 100644
--- a/games/xtet42/Makefile
+++ b/games/xtet42/Makefile
@@ -15,9 +15,6 @@ CONFIGURE_ARGS= --localstatedir=/var/games
USE_XORG= x11
ALL_TARGET= ${PORTNAME}
-post-extract:
- @${CHMOD} -R u+w ${WRKSRC}
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xtet42 ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xtet42.6 ${STAGEDIR}${MANPREFIX}/man/man6