aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-05 11:30:25 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-05 11:30:25 +0800
commitda90d7cc05126e0addf7a1ee86aea0b8a1a7c067 (patch)
treeaff8c200701b1f29974a2ee63d126ce8d4e31da3 /games
parent560948c1d12eda54c77c41816de8c249199844ab (diff)
downloadfreebsd-ports-gnome-da90d7cc05126e0addf7a1ee86aea0b8a1a7c067.tar.gz
freebsd-ports-gnome-da90d7cc05126e0addf7a1ee86aea0b8a1a7c067.tar.zst
freebsd-ports-gnome-da90d7cc05126e0addf7a1ee86aea0b8a1a7c067.zip
games/wizznic: use clang and unbreak with gcc5 or later
board.o: In function `doRules': board.c:(.text+0x14b1): undefined reference to `getTicks' draw.o: In function `drawPath': draw.c:(.text+0x90d): undefined reference to `plotPixel' draw.o: In function `draw': draw.c:(.text+0x9aa): undefined reference to `setting' [...] PR: 216707 Reported by: antoine (via exp-run)
Diffstat (limited to 'games')
-rw-r--r--games/wizznic/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/wizznic/Makefile b/games/wizznic/Makefile
index 537c9561dbaf..c92a9097cdbe 100644
--- a/games/wizznic/Makefile
+++ b/games/wizznic/Makefile
@@ -4,7 +4,7 @@
PORTNAME= wizznic
PORTVERSION= 0.9.9
DISTVERSIONSUFFIX=-src
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Source%20Releases/
@@ -18,10 +18,10 @@ LIB_DEPENDS= libpng.so:graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
USES= gmake tar:bzip2
+USE_CSTD= gnu89
USE_SDL= image mixer sdl
MAKE_ENV= DATADIR=${DATADIR}/ BINDIR=${PREFIX}/bin
ALL_TARGET= sdl
-USE_GCC= yes
PORTDOCS= changelog.txt credits.txt music-score-credits.txt readme.txt