aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-10-01 21:32:10 +0800
committergahr <gahr@FreeBSD.org>2012-10-01 21:32:10 +0800
commitdfbac70c2d55dab050d6fe49f0e7ca2df1eca2cd (patch)
tree4f77aadd6b2438029a3187125a5848e853bf84ce /games
parent5f8674be49d4863e0a4ac7c1d028bb86b0e9980b (diff)
downloadfreebsd-ports-gnome-dfbac70c2d55dab050d6fe49f0e7ca2df1eca2cd.tar.gz
freebsd-ports-gnome-dfbac70c2d55dab050d6fe49f0e7ca2df1eca2cd.tar.zst
freebsd-ports-gnome-dfbac70c2d55dab050d6fe49f0e7ca2df1eca2cd.zip
- Convert to OptionsNG
Notified by: http://wiki.freebsd.org/Ports/Options/ConvertingToOptionsNG
Diffstat (limited to 'games')
-rw-r--r--games/gnubg/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/gnubg/Makefile b/games/gnubg/Makefile
index b6b2f8f8ca57..bce9dbc0bd14 100644
--- a/games/gnubg/Makefile
+++ b/games/gnubg/Makefile
@@ -28,8 +28,8 @@ LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
WRKSRC= ${WRKDIR}/gnubg
-OPTIONS= ESOUND "Enable sound support" ON \
- NLS "Enable gettext support" ON
+OPTIONS_DEFINE= ESOUND NLS
+OPTIONS_DEFAULT=ESOUND NLS
CONFIGURE_ARGS= --with-board3d
@@ -42,15 +42,15 @@ USE_AUTOTOOLS= libtool automake
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_ESOUND)
+.if ${PORT_OPTIONS:MESOUND}
USE_GNOME+= esound
.else
CONFIGURE_ENV+= ac_cv_path_AUDIOFILE_CONFIG=no ac_cv_path_ESD_CONFIG=no
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CONFIGURE_ARGS+= --enable-nls
@@ -78,4 +78,4 @@ post-patch:
pre-configure:
cd ${WRKSRC} && ./autogen.sh
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>